PDA

Vollständige Version anzeigen : WENN Abfrage


Simpsonx
11.04.2012, 22:01
Hallo Zusammen,

ich habe ein Problem mit einer Abfrage von Zwei Zellen.
Ich habe z.B. A1 20,00 € und in B1 25,00 € stehen und möchte in C1 die Differenz haben, dass wäre in diesem Fall 5,00 €.

Die Formel hierfür wäre einfach, B1-A1. Es kann aber auch sein, dass in B1 eine höhere Zahl wie in A1 steht, in diesem Fall soll C1 0,00 € sein.
Es kann auch sein, dass in B1 garnichts steht, dann soll C1 auch 0,00 € sein.

Ich habe zig Wenn und Wenn Oder etc ausprobiert und habe immer wieder das Problem, dass er beim Bersuch wenn ich wild Zahlen eingebe und die wieder ändere meine Zelle nicht mehr aktualisiert obwohl in den Optionen automatisch eingestellt ist.

Wichtig wäre mir eine richtige Formel dazu.

Meine Formel war:

=WENN(B1="";C1=0;WENN(B1=0;C1=0;WENN(B1<A1;C1=0;WENN(B1>A1;B1-A1;"FEHLER"))))

Vielen Dank schon mal vorab.

Peter9
11.04.2012, 22:15
hi,

Ich habe z.B. A1 20,00 € und in B1 25,00 € stehen und möchte in C1 die Differenz haben, dass wäre in diesem Fall 5,00 €.

Die Formel hierfür wäre einfach, B1-A1. Es kann aber auch sein, dass in B1 eine höhere Zahl wie in A1 steht, in diesem Fall soll C1 0,00 € sein.



das Wiederspricht sich doch da in B1 eine höhere Zahl steht


gruß Peter9

Simpsonx
11.04.2012, 22:21
SORRY!!!

Da hast Du recht!!

Ich meinte es kann sein das in A! eine höhere Zahl als in B1 steht, somit würde es eine Minuszahl ergeben, dass soll auch nicht sein, in dem Fall auch 0,00 €.

Peter9
11.04.2012, 22:24
hi,

dann mit der Formel

=WENN(A1<B1;-A1+B1;"0,00")

Gruß Peter9

Simpsonx
11.04.2012, 22:35
So verstehst Du es vielleicht besser:



60952

Peter9
11.04.2012, 22:48
hi,

aha dann so

=WENN(A1="";"0,00";WENN(B1=0;"0,00";WENN(B1>A1;-A1+B1;"0,00")))

Gruß Peter9

Simpsonx
11.04.2012, 22:59
Vielen Dank!!!

Es geht.

Ich kenne mich eigentlich mit Excel sehr gut aus, aber mein Fehler war das -A1+B1, denn -A1 kannte ich nicht.

hary
11.04.2012, 23:20
Moin
etwas kuerzer mit: und
=WENN(UND(A1<>"";B1<>"";B1>A1);-A1+B1;"0,00")
gruss hary