PDA

Vollständige Version anzeigen : Summenprodukt mit ODER


huffli
04.04.2012, 16:55
Hallo,

ich habe folgende folgende Formel:

=SUMMENPRODUKT(((Rohdaten!$D$2:$D$500="AB")+(Rohdaten!$D$2:$D$500="XY"))
*(((Rohdaten!$C$2:$C$500=D20)+(Rohdaten!$C$2:$C$500=D21)+(Rohdaten!$C$2:$C$500=D 22)+(Rohdaten!$C$2:$C$500=D23))*(Rohdaten!$B$2:$B$500=$A2)*(Rohdaten!$E$2:$E$500 )))

Das Verknüpfen mit ODER (+) funktioniert. Gerne würde ich den fetten Bereich verschlanken in der Form: (Rohdaten!$C$2:$C$500=D20,D21,D22,D23), doch leider bekomme ich das nicht hin. Hat jemand von euch eine Idee?

Viele Grüße
Huffli

josef e
04.04.2012, 21:45
<div style="width:98%; margin-left:5px; margin-right:15px; text-align:justify;">
Hallo ?,

so?

=SUMMENPRODUKT(ISTZAHL(VERGLEICH(Rohdaten!$D$2:$D$500;{"AB";"XY"};0))*ISTZAHL(VERGLEICH(Rohdaten!$C$2:$C$500;D20:D23;0))*(Rohdaten!$B$2:$B$500=$ A2)*(Rohdaten!$E$2:$E$500))


</div>

<div style="width:100px; text-align:center; color:white; font-style:italic; font-size:0.8em; font-family:Tahoma; background-color:royalblue;margin-left:5px; margin-top:15px; padding:4px; border:3px double darkblue;">&laquo; Gru&szlig; Sepp &raquo;</div>

huffli
16.04.2012, 10:21
Hi Sepp,

das hat funktioniert. Danke für deine Hilfe!

Zur Info: Mein Versuch mit MTRANS(D20:D23) hat leider einen #WERT-Fehler ergeben.

Schöne Grüße
Huffli