PDA

Vollständige Version anzeigen : Mittelwert mit Bedingung Datum


Alpay
28.03.2012, 12:50
Hallo,
ich möchte den Mittelwert von allen Zahlungen erhalten, die in einem bestimmten Zeitraum getätigt wurden.
Spalte A: Datum (im Format: 01.01.1999)
Spalte B: Zahlung (im Format: 200)

Jetzt soll z.B. der Mittelwert von allen Zahlungen im Zeitraum 1999-2002 berechnet werden. Ich habs probiert mit:

{=MITTELWERT(WENN((DATWERT($A:$A)>="01.01.1999")*(DATWERT($A:$A)<="31.12.2002");$B:$B))}

Dies ist aber leider falsch. Wie gehts richtig?

Ach ja, ich suche immer den Mittelwert zwischen vollen Jahren (falls es über JAHR() einfacher gehen sollte).

Vielen Dank im Vorraus!

Alpay
28.03.2012, 12:53
Ich glaub ich habs. Ist das so richtig?

{=MITTELWERT(WENN(($A:$A>=DATWERT("01.01.1999"))*($A:$A<=DATWERT("31.12.2002"));$B:$B))}

mücke
28.03.2012, 13:31
Moin,

... ich würde nur auf ganze Spalten verzichten (A:A, B:B)
Anbei noch eine Variante mit Jahr.
<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Calibri,Arial; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >C</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="text-align:right; ">1,00</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >C3</td><td >{=MITTELWERT(WENN<span style=' color:008000; '>(<span style=' color:#0000ff; '>(JAHR<span style=' color:#ff0000; '>(A2:A99)</span>&gt;=1999)</span>*<span style=' color:#0000ff; '>(JAHR<span style=' color:#ff0000; '>(A2:A99)</span>&lt;=2002)</span>;B2:B99)</span>)}</td></tr></table></td></tr><tr><td ><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>Enth&auml;lt Matrixformel:</span><span style=' font-family:Arial,Arial; font-size:9pt;'><br />Umrandende </span><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>{ }</span><span style=' font-family:Arial,Arial; font-size:9pt;'> nicht miteingeben,<br />sondern Formel mit STRG+SHIFT+RETURN abschlie&szlig;en!</span></td></tr><tr><td ><a href="http://www.online-excel.de/excel/singsel.php?f=26" style="font-family:Arial; font-size:8pt;font-weight:bold;color:#000080;" target='_blank'>Matrix verstehen</a></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>