PDA

Vollständige Version anzeigen : INCLUDEPICTURE mit variablem Bild


vobabear
24.08.2009, 14:56
Hallo,

ich habe ein Problem mit "IncludePicture". Folgenden Pfad gebe ich ein:
\\Fs007i4e\groupdata\orga\testus\usneu\xxx.tif
danach kopiere ich statt xxx.tif {unters2txt} hinein --> dort steht meine Tif (Unterschrift) für den Serienbrief. Danach setzt word diese Zeile sofort in
INCLUDEPICTURE "\\\\Fs007i4e\\groupdata\\orga\\testus\\usneu\\Fehler! Textmarke nicht definiert." \* MERGEFORMAT
um. Wenn ich das Dokument speichere wird diese Zeile auf
INCLUDEPICTURE "../../orga/testus/usneu/Fehler!%20Textmarke%20nicht%20definiert." \* MERGEFORMATINET
geändert. Was mache ich falsch bzw. wie 'sage' ich word, daß der Befehl so richtig lautet?
Im Voraus Danke für die Antworten

Gerhard H
24.08.2009, 17:11
Hallo vobabaer,

ich hab nicht ganz verstanden: "{unters2txt} ...dort steht meine tif..."

Ist {unters2txt} ein Seriendruckfeld? Dann müsste dort stehen: {mergefield unters2txt}

Ansonsten setz die Pfadangaben in doppelte Backslashes. Wenn du Leerzeichen in den Pfadangaben hast, setz alles noch in Anführungszeichen.

Wahrscheinlich siehst du die Bilder erst, wenn du den Seriendruck in ein neues Dokumentausgeführt hast, und dort nochmal die Bilder aktualisierst (am besten: alles markieren, F9)

vobabear
25.08.2009, 08:15
Hallo Gerhard,

ich habe eine Vorlage (.dot) dort ist die Befehlszeile ohne Mergefield. Aber auch ohne Mergefield funktionierts in dieser Vorlage.

Wenn ich die Pfadangabe in doppelte Backslashes setze, verdoppelt Word immer die Backslahses.

Ich versuche es immer mit dem Serienbrief und aktualisiere es mit F9. -> Nichts.

Ich habe es in der Zwischenzeit auch mit dem richtigen Namen der tif gemacht-funktioniert auch nicht.

Vobabear

Gerhard H
25.08.2009, 11:46
Hallo Vobabaer,

ich habs jetzt nochmal ausprobiert. Erstaunlicherweise funktioniert das bei mir auch ohne die Angabe "mergefield...". Da sträubt sich aber was innerlich bei mir ;-)

Wie dem auch sei: Damit wir nicht aneinander vorbeireden, hab ich ein PDF-Doku angehängt, in dem ich beschrieben habe, wie ich das mache, und wie es bei mir auch funktioniert.

Vielleicht siehst du einen Unterschied zu dir.

Nachtrag: Ich seh grad: Der Unterschied könnte sein: Ich arbeite mit absoluten Pfadangaben, du mit relativen. Wie es mit relativen Pfadangaben korrekt geht, weiß ich (noch) nicht. Versuchs mal inzwischen: Geht es mit absoluten Pfaden?

vobabear
25.08.2009, 12:51
Hallo Gerhard,

ich habe das alles probiert. Im Prinzip bekomme ich das Bild auf das Dokument. Leider geht Word her und speichert sich das erste Bild. Selbstverständlich habe ich auch alles markiert und mit F9 aktualisiert. Auch die Serienbriefe anzeigen und aktualisieren lassen - gleiches Problem.

Vobabear

vobabear
25.08.2009, 15:02
Nachtrag: Nach langem testen habe ich herausgefunden, daß Word beim Speichern immer das letzte Bild als Text speichert (nicht der Feldname) und danach geht nichts mehr d. h. auch in der Serienbrieffunktion wird KEIN Bild mehr angezeigt - auch nicht das gespeicherte!

vobabear

Gerhard H
25.08.2009, 17:13
Hallo vobabaer,

leider muss ich an dieser Stelle passen. Deine Beispielpfade sehen so aus, als ob du die Bilder von einem Netzlaufwerk holst? Da mögen noch Rechte und was weiß ich eine Rolle spielen. Davon hab ich aber keinen Schimmer.

Sorry, vielleicht weiß ein anderer weiter.

vobabear
28.08.2009, 07:32
Nun habe ich im Internet die Lösung gefunden:

Die Option "Extras - Optionen… - Allgemein - Weboptionen… - Dateien - Links beim Speichern aktualisieren" MUSS deaktiviert sein andernfalls wird die Feldfunktion beim speichern zerstört.

Vobabear