PDA

Vollständige Version anzeigen : Zeilensummen der Tabelle nach abhängigkeit des Spaltenkopfes addieren !


Icemen83
07.05.2009, 08:23
Moin!

Ich habe ein Problem und weiß nicht weiter, liegt auch daran das ich mit VBA nicht so bewandert bin. Ich hoffe ihr könnt mir helfen. Danke schonmal im vorraus.

Problem: Ich habe eine Tabelle mit 2000 Spalten und 1900 Zeilen.

Aufgebaut ist die wie folgt: (formatierung hier ist blöde, denkt euch je eine Zahl unter die SPXXXX Spalte)

SP2200 SP1200 SP1300
1 5 5
9 5 5
1 5 7
4 6 2
5 2 4
6 0 3

Ich will nun alle Zeilen addieren, in denen der Kopf(also diese SPXXXX) an der zweiten stelle eine 2 hat, also SPX2XX. Hoffe ihr versteht wie ich das meine.

In diesem Bsp. kommt dann raus:

SPX2XX
6
14
6
10
7
6

Die Ausgabe soll dann in Tabelle2 geschrieben werden.

Ich habe versucht die Tabelle in ein Array einzulesen, leider weiß nicht so recht wie ich das mit dem vergleichen des Spaltenkopfes und dann mit den durchlaufen der einzelnen Werte machen muss.

Bin jeden Tipp und Hilfe dankbar, Gruß Frank

chris-kaiser
07.05.2009, 08:30
hiho


=SUMMENPRODUKT((TEIL(A$1:bxx$1;4;1)="2")*A2:bxx2)

sind das echt 2000 Spalten, wow

Icemen83
07.05.2009, 08:56
danke dir, so einfach ist das manchmal !

ja, das sind 1900 spalten, sind verkaufszahlen von einzelnen produkten und ich will die spalten zwegs dataminings gruppieren, daher die addition

nochmals danke... !!!