PDA

Vollständige Version anzeigen : Probleme mit Datum und Uhrzeit zählen


Fleischmann
30.04.2009, 10:54
Moin,

ich habe folgendes Problem wo ich mal Hilfe bräuchte. Wir haben eine Störungsliste für Anlagen und Maschinenstörungen.

In der Spalte A steht das Datum und die Uhrzeit des Anrufes

Ich möchte jetzt auf einem extra Arbeitsblatt gerne eine kleine Auswertung fahren.

Ich wollte in B2 ein Datum eingeben z.B. 30.04.09
und er soll dann in der Störungsliste zählen wieviele Störungen eingegangen sind. Zählewenn funktioniert nicht, weil zu dem Datum ja auch die Uhrzeit mit enthalten ist.

Gibt es da noch eine Möglichkeit ?

Danke für Eure Hilfe

Thorsten

chris-kaiser
30.04.2009, 11:16
hiho

=SUMMENPRODUKT(N(KÜRZEN(A1:A20)=E1))

in E1 das gesuchte Datum

bzw wenn nicht nur ein Datum in A steht, sondern auch Texte vorkommen können
=SUMME(N(KÜRZEN(WENN(ISTZAHL(A1:A1000);A1:A1000))=E1))
die Formel muß aber mit Strg+Umschalt+Enter abgeschlossen werden

Fleischmann
30.04.2009, 12:19
Moin Chris,

und was bedeuet das N in der Formel ?

Gruß Thorsten

chris-kaiser
30.04.2009, 12:22
Hallo Thorsten


=SUMMENPRODUKT(N(KÜRZEN(A1:A20)=E1))


KÜRZEN(A1:A20)=E1)
hier würden die Wahrheitswerte als Wahr;Falsch;Wahr
usw, vorliegen
damit kann aber nicht gerechnet werden
es wird 1;0;1 usw. gebraucht
das n wandelt diese Wahrheitswerte in eben diese Zahlen

du könntest auch folgendes verwenden
=SUMMENPRODUKT(--(KÜRZEN(A1:A20)=E1))

oder

=SUMMENPRODUKT(0+(KÜRZEN(A1:A20)=E1))

oder

=SUMMENPRODUKT(1*(KÜRZEN(A1:A20)=E1))

usw.

dies alles wird einfach gebraucht um diese Wahr;Falsch in Zahlen umzuwandeln