PDA

Vollständige Version anzeigen : Rechen- oder Denkfehler? -- Oder: Was ist nun richtig?


v1p
30.04.2009, 09:56
Also irgendwie bin ich etwas 'confused'...

... Möglichkeit 1: Rechenfehler von Excel ...
... Möglichkeit 2: Denkfehler von mir ... ?!

Wert A Wert B Ergebnis Wert A Wert B Ergebnis
-5100 6000 -0,85 5100 6000 0,85
-5444 4488 -1,213012478 5444 4488 1,21
-1254 1555 -0,806430868 1254 1555 0,81
-11187 12000 -0,93225 11187 12000 0,93
-11843 11554 -1,025012983 11843 11554 1,03
-11182 11548 -0,9683062 11182 11548 0,97
-1244 1000 -1,244 1244 1000 1,24
-8444 8444 -1 8444 8444 1
-55698 56589 -0,984254891 55698 56589 0,98
-1,004876566 1,005


Wert A Wert B Ergebnis Wert A Wert B Ergebnis
-5100 6000 =A2/B2 5100 6000 =RUNDEN((F2/G2);2)
-5444 4488 =A3/B3 5444 4488 =RUNDEN((F3/G3);2)
-1254 1555 =A4/B4 1254 1555 =RUNDEN((F4/G4);2)
-11187 12000 =A5/B5 11187 12000 =RUNDEN((F5/G5);2)
-11843 11554 =A6/B6 11843 11554 =RUNDEN((F6/G6);2)
-11182 11548 =A7/B7 11182 11548 =RUNDEN((F7/G7);2)
-1244 1000 =A8/B8 1244 1000 =RUNDEN((F8/G8);2)
-8444 8444 =A9/B9 8444 8444 =RUNDEN((F9/G9);2)
=SUMME(A2:A9) =SUMME(B2:B9) =A10/B10 =SUMME(F2:F9) =SUMME(G2:G9) =RUNDEN((F10/G10);2)
=SUMME(C2:C9)/8 =SUMME(H2:H9)/8


ich hoffe, dass das weitesgehend selbsterklärend ist ...

Wenn ich die einzelnen Werte aus der Ergebnis-Spalte addiere und durch die Anzahl Teile, erhalte ich nicht den selben Wert wie wenn ich die Werte Summiere und dann durch einander teile.. auch nicht gerundet.. Warum?!

EarlFred
30.04.2009, 10:13
Hallo v1p,

keine Sorge, Excel rechnet richtig.

Beispiel:

Du addierst 3 Brüche:
1/3 + 1/2 + 1/4
= 4/12 + 6/12 + 3/12
= 13/12

Dies geteilt durch 3 (Anzahl der Brüche) ergibt gerundet 0,36
(entspricht Deiner Formel =SUMME(C2:C9)/8)

In Spalte A und B addierst Du Zähler und Nenner der Brüche separat und teilst die Summen:
(1 + 1 + 1) / (3 + 2 + 4) = 3/9 = 1/3 = 0,33
(entspricht Deiner Formel =A10/B10)

Rechenfehler? Denke nicht ;)

Grüße
EarlFred

(http://de.wikipedia.org/wiki/Mittelwert)

magie61
30.04.2009, 10:36
Als Erklärung dafür dient die erste Grundregel in der Mathematik: Punktrechnung (Multiplikation und Division) geht vor Strichrechnung (Addition und Subtraktion) :)
Gruß
magie61

v1p
30.04.2009, 11:19
@EarlFred: OK Prinzip verstehe ich, anhand von Brüchen zumindest. Allerdings, da es sich ja um Einzelwerte handelt hatte ich gedacht, dass sich die Sache anders verhalten sollte...

@magie61: ja klar! auf welches Feld beziehst du dich, dass ich das als Erklärung bekomme? Weil die einzelnen Berechnungen "an sich" sollten von einem "Klammerfehler" ja nicht betroffen sein.
Excel Summiert ja auch erst bevor es teilt...

BoskoBiati
30.04.2009, 11:41
Hallo Phil,

erste Regel bei Brüchen: Brüche mit unterschiedlichen Nennern können nicht ohne Weiteres addiert werden, sondern man muss sie auf einen gemeinsamen Nenner bringen.
Jede Deiner Divisionen ist letztendlich ein Bruch. Also müsstest Du in B10 alle Werte von B2 bis B9 miteinander multiplizieren (vereinfacht ausgedrückt, sonst mußt Du das kleinste gemeinsame Vielfache suchen) und jede Zahl von A2 bis A9 mit dieser Zahl multiplizieren und dann durch die entsprechende Zahl in B dividieren und dann alles addieren, dann wäre das Ergebnis identisch mit der Summe B2:B9.
Kurz gesagt: Dein Rechengang in C10 summe a / Summe B ist mathematisch falsch!

magie61
30.04.2009, 11:42
SUMME(C2:C9)/8 ist nicht anderes als (A2/B2+A3/B3+A4/B4...)/n, wobei n hier 8 ist.
A10/B10 ist aber (A2+A3+A4+...)/(B2+B3+B4...) und das ergibt ein anderes Ergebnis.

Gruß
magie61

PS. Nur wenn ein Term sich in den anderen umwandeln lassen könnte, würden die Ergebnisse gleich sein.

v1p
30.04.2009, 12:30
Über Brüche erzählt ihr mir nix neues .. und dass ein Bruch nix anderes als eine Division ist, ist auch klar.
Zumindest war das als ich mein ABI gemacht habe auch schon so... ich war halt nur etwas verwundert, dass die Werte zwar ähnlich sind, aber nicht gleich.

OK und ZU -- Dankeschön :)

EarlFred
30.04.2009, 12:32
Hallo Phil,

also, dass beide Rechenwege zu verschiedenen Ergebnissen kommen, ist vermutlich klarer geworden.

Allerdings weiß ich nicht, was in Deinem Sinne nun mathematisch "richtig" wäre. Was willst Du denn ermitteln bzw. was soll das Ergebnis aussagen? Vielleicht kommen wir so weiter...

Grüße
EarlFred

v1p
30.04.2009, 12:39
Korrekt ist der Weg über den Mittelwert aller Werte der Spalte C .. da ich pro Zeile einen Wert pro Person ausrechne und dann einen Mittelwert dieser errechne.

Was mich halt nur stutzig machte ist die Tatsache, dass es halt ein anderes Ergebnis herauskommt weil auf den ersten Blick die Werte gleich sein müssten ... Aber eben nur auf den ersten :)

Erklärung dazu:

Spalte A: aufgelaufene Kosten
Spalte B: gefahrene KM

deswegen erschien es mir eig logisch, wenn ich alle Kosten addiere und alle Km ergibt sich auch ein mittelwert aller einzelnen werte ..

EarlFred
30.04.2009, 13:10
Hallo Phil,

OK, deswegen meine Frage nach der Aussage der Zahl - die ist mir nicht klar genug definiert.

Umkehrschluss Deiner Rechnung: Dein Mittelwert sollen mittlere Kosten/km über die gesamte Fahrzeugflotte sein.
Ergo:
Gesamtkilometer * (Mittlere Kosten/km) soll sein = Gesamtkosten. Das ist aber ungleich, da die Einzelquotienten unterschiedlich gewichtet sind.
(z. B. fährt einer immer in der Stadt, verbraucht er dabei mehr Benzin als einer, der immer 120 auf der Autobahn fährt -> Kosten / km unterscheiden sich stark, wobei die gefahrenen Kilometer auch nicht übereinstimmen)

Wenn es darum geht, die Durchschnittskosten der gesamten Fahrzeugflotte zu bewerten, würde ich Gesamtkosten / Gesamtkilometer ansetzen.

(Edit: Siehe auch hier: http://www.ms-office-forum.de/forum/showpost.php?p=1126740&postcount=9)

Grüße
EarlFred

v1p
30.04.2009, 13:21
Jetzt haben 'wir' den Salat :) ...

Wenn es darum geht, die Durchschnittskosten der gesamten Fahrzeugflotte zu bewerten, würde ich Gesamtkosten / Gesamtkilometer ansetzen.

.. Ja und Nein ..

Ich möchte zum einen wissen welches Fahrzeug wieviele Kosten / KM hat und zum anderen welchen Schnitt ich über alle gesehen habe.
Wie du schon sagtest fahren die Fahrzeuge unterschiedliche Strecken mit unterschielichen Aufliegern ...

EarlFred
30.04.2009, 13:34
Hallo Phil,

und genau das geht nicht! Dann musst Du mit beiden Berechnungsmethoden parallel arbeiten.

Wenn Du z. B. die Kosten, die ein Fahrzeug verursacht hat, an den Fahrer weiterberechnen willst, dann bestimmt über
(Kosten Fahrzeug x) / (Kilometer Fahrzeug x) * gefahrene Kilometer
Ich denke, dass dies sogar die steuerlich anerkannte Methode ist, wenn man ein dienstlich zur Verfügung gestelltes Fahrzeug in Ausnahmen privat nutzt, ohne geldwerten Vorteil anrechnen lassen zu müssen. Über die Abrechnung anhand dieses Mittelwertes und des Fahrtenbuches, so meine ich, wäre die steueliche Schuld abgeleistet, da kein geldwerter Vorteil entsteht. Aber ich bin kein Steuerberater, also frag lieber einen, der sich damit auskennt ;)

Für z. B. Prognosen der Gesamtkosten der Flotte pro Jahr, würde ich allerdings den im letzten Post angesetzten Rechenweg nutzen, also Gesamtkosten / Gesamtkilometer * prognostizierte km.

Wie gesagt: Es kommt darauf an, was die Zahl denn aussagen soll! Aber das kann ich nicht wissen, nur raten...

Grüße
EarlFred

IngGi
30.04.2009, 15:19
Hallo zusammen,

könnte das grundlegende Problem nicht auch hierin bestehen?

http://www.ms-office-forum.net/forum/showthread.php?t=225928

Gruß Ingolf

BoskoBiati
30.04.2009, 15:33
Hallo zusammen,

ich denke das Grundproblem ist einfach dass die Regeln der Mathematik einfach besagen, dass der Rechengang (1/3+1/4+1/5)/3 ein anderes Ergebnis bringt als ((1+1+1)/(3+4+5))/3! Die anfänglich dargestellte Tabelle mag ja zufälligerweise nur geringe Differenzen aufzeigen, aber wenn man die Werte mal abändert, dann kann das ganz anders aussehen:<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:47px;" /><col style="width:54px;" /><col style="width:61px;" /><col style="width:40px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >N</td><td >O</td><td >P</td><td >Q</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >14</td><td style="text-align:center; ">5100</td><td style="text-align:center; ">10000</td><td style="text-align:center; ">0,51</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >15</td><td style="text-align:center; ">5444</td><td style="text-align:center; ">11100</td><td style="text-align:center; ">0,49045</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >16</td><td style="text-align:center; ">1254</td><td style="text-align:center; ">5000</td><td style="text-align:center; ">0,2508</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >17</td><td style="text-align:center; ">11187</td><td style="text-align:center; ">1500</td><td style="text-align:center; ">7,458</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >18</td><td style="text-align:center; ">11843</td><td style="text-align:center; ">4000</td><td style="text-align:center; ">2,96075</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >19</td><td style="text-align:center; ">11182</td><td style="text-align:center; ">8000</td><td style="text-align:center; ">1,39775</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >20</td><td style="text-align:center; ">1244</td><td style="text-align:center; ">20000</td><td style="text-align:center; ">0,0622</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >21</td><td style="text-align:center; ">8444</td><td style="text-align:center; ">6000</td><td style="text-align:center; ">1,407333</td><td style="text-align:center; ">1,817</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >22</td><td style="text-align:center; ">55698</td><td style="text-align:center; ">65600</td><td style="text-align:center; ">0,849055</td><td >&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >P14</td><td >=N14/O14</td></tr><tr><td >P15</td><td >=N15/O15</td></tr><tr><td >P16</td><td >=N16/O16</td></tr><tr><td >P17</td><td >=N17/O17</td></tr><tr><td >P18</td><td >=N18/O18</td></tr><tr><td >P19</td><td >=N19/O19</td></tr><tr><td >P20</td><td >=N20/O20</td></tr><tr><td >P21</td><td >=N21/O21</td></tr></table></td></tr></table><br /><br /><b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:40px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >Q</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >21</td><td style="text-align:center; ">1,817</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >Q21</td><td >=MITTELWERT(P14:P21)</td></tr></table></td></tr></table><br /><br /><b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:61px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >P</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >22</td><td style="text-align:center; ">0,849055</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >P22</td><td >=N22/O22</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

v1p
30.04.2009, 16:41
Ja OK... schon verstanden...

Wobei ich nun immer noch nicht weiß welcher Wert der "richtigere" ist...

Was ich wissen muss - Kurz und Knapp

A) Kosten pro KM pro Fahrzeug --> ist klar, gibts auch nur eine Möglichkeit
B) Kosten pro KM Fuhrpark (alle Fahrzeuge gesamt)

zu B .. nehme ich jetzt den Wert vom Fuhrpark, sprich ich addiere einfach die einzenen KM und Kosten Werte, oder Nehme ich den Mittelwert der Einzelnen Fahrzeugwerte (Kosten pro KM)

EarlFred
30.04.2009, 19:15
Hallo Phil,

für die Kosten des Fuhrparks ist m. E.

Gesamtkosten / Gesamtkilometer

die richtige Berechnung...

Grüße
EarlFred

v1p
07.05.2009, 07:51
Sorry, dass ich mich jetzt erst melde. ..

Das denke ich auch, allerdings ist es auch "logisch" den Schnitt der Fahrzeuge zu nehmen, ist schon blöd, dass es mathematisch nicht das selbe ist obwohl rein von der Logik was gegeben ist und was rauskommen sollte über welchen weg auch immer das gleiche ergeben sollte