PDA

Vollständige Version anzeigen : Zählenwenn mit Abweichung +/- 1


Access2000
20.04.2009, 09:24
Hallo zusammen,
ich habe ein kleines Problem mit einer Zählenwenn-Formel.
Ich benötige zwei Ergebnisse.
Einmal benötige die Anzahl der exakten Übereinstimmungen der Spalten
A und B. Diese Formel habe ich bereits (im Beispiel in C2).
Zum zweiten benötige ich die Anzahl, welche Werte in Spalte B um 1 bzw. 2 Sekunden abweichen (also z.B. in Spalte A 14:41:16 und in Spalte B 14:41:15) müsste als Ergebnis 1 liefern.
Dafür weiß ich bisher leider noch keine Lösung.
Ich arbeite hier mit Excel2002.
Habt ihr eine Idee?

Klaus

jinx
20.04.2009, 09:28
Moin, Klaus,

da sollte die Verwendung von SUMMENPRODUKT analog zu Summewenn Zählenwenn mit zwei oder mehr Kriterien (http://www.ms-office-forum.net/forum/showthread.php?t=148535) helfen.

Access2000
20.04.2009, 09:48
Hallo,

danke für den Link. Ich werde mir das mal anschauen und melde mich auf jeden Fall wieder.

Klaus

Access2000
20.04.2009, 11:56
Ich bin es nochmal,

ich denke das Prinzip von =SUMMENPRODUKT habe ich schon verstanden.
Wäre für meinen Fall auch die richtige Funktion. Aber irgendwie bekomme ich es trotzdem nicht hin (+/- 2 Sekunden)???
Kann mir jemand bei der Formel helfen.

Klaus

jinx
20.04.2009, 12:59
Moin, Klaus,

möglicherweise so (für die erste Zeile):

=SUMME((($A$2:$A$109)>=($B2-ZEIT(0;0;1)))+(($B$2:$B$109)<=($B2+ZEIT(0;0;1))))

Access2000
21.04.2009, 12:22
Hallo jinx,

habe ich irgendwie mit deiner Formel nicht so ganz hinbekommen.
Ich habe es jetzt aber mit meiner ursprünglichen Formel gelöst.

=SUMME(ZÄHLENWENN($A$2:$A$109;B2:B109))

Sowie 4 ausgeblendete Spalten und darauf wieder die o.g. Formel.

=SUMME(B2-ZEIT(0;0;1))
=SUMME(B2+ZEIT(0;0;1))
=SUMME(B2-ZEIT(0;0;2))
=SUMME(B2+ZEIT(0;0;2))

Nochmals danke
Klaus