PDA

Vollständige Version anzeigen : #WERT! Problem


TobiasT
16.04.2009, 19:43
Guten Abend miteinander.

Ich hätte (wieder einmal^^) ein kleines Problemchen mit Excel. Und zwar habe ich einen Dienstplan erstellt. Nun habe ich noch das Problem, dass ich es einfach nicht hinbekomme, dass der #WERT! nicht mit einbezogen wird, bzw erst gar nicht erscheint.

Zur Veranschaulichung:
http://img6.imageshack.us/img6/2516/dienstplan.jpg

An allen Tagen, an denen ein Dienst eingetragen ist, aber noch keine Uhrzeit (da noch nicht gearbeitet), erscheint dieser Wert und wirkt sich somit natürlich auf die bisherige Berechnung aus. Wie kann man das ändern? So dass evtl auch in diesen zellen ein "-" erscheint? Bin mit meinem Latein gerade am Ende.


Und noch ein kleines weiteres Problem: Wie bringe ich Excel dazu, wenn ich z.B. in der Spalte "von" eine 17 (für 17:00 Uhr) eingebe, mir daraus 17:00 zu zaubern? Normal formatiert bleibt es eine 17 (und wird nicht als Uhrzeit angerechnet) und als Uhrzeit wird "17.01.1900 00:00:00" daraus gemacht.

Ich habe die Datei auch mal mit angehängt wegen den Formeln.


Gruß,
Tobias

ransi
16.04.2009, 19:50
HAllo

DAs problem sind die "-".
<b>April</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:40px;" /><col style="width:40px;" /><col style="width:40px;" /><col style="width:40px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >G</td><td >H</td><td >I</td><td >J</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >19</td><td colspan="2" style="text-align:center; ">-</td><td colspan="2" style="text-align:center; ">-</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >20</td><td colspan="2" style="text-align:center; ">-</td><td colspan="2" style="text-align:center; ">-</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >21</td><td colspan="2" style="text-align:center; ">-</td><td colspan="2" style="text-align:center; ">-</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >22</td><td colspan="2" style="text-align:center; ">-</td><td colspan="2" style="text-align:center; ">-</td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>


LAss die Zellen leer oder schreib ne 0 rein.
Dann läuft es wie gewünscht.

ransi

TobiasT
16.04.2009, 19:59
Hi ransi.


Oh Mann, da hätte ich auch selbst drauf kommen können *Kopf -> Tisch* So einfach und doch so wirkungsvoll^^ Ich danke dir recht herzlich ;)


Bleibt nur noch das andere "kleine" Problem mit der Uhrzeit eintragen. Was da auch schick wäre: Wenn ich "1330" eingebe, Excel mir daraus auch "13:30" macht. Ist das überhaupt möglich, so wie ich mir das wünsche?


Gruß,
Tobias

hary
16.04.2009, 20:01
Hi versuch mal. Formel gekuertzt

Tabellenblattname: April<table border="1" width="222" bgcolor="#FFFF00" id="table1"><tr><td width="5" bgcolor="#00FFFF">&nbsp;</td><td width="40" bgcolor="#00FFFF"><p align="center">A</td><td width="10" bgcolor="#00FFFF"><p align="center">B</td><td width="50" bgcolor="#00FFFF"><p align="center">C</td><td width="10" bgcolor="#00FFFF"><p align="center">D</td><td width="5" bgcolor="#00FFFF"><p align="center">E</td><td width="10" bgcolor="#00FFFF"><p align="center">F</td><td width="5" bgcolor="#00FFFF"><p align="center">G</td><td width="10" bgcolor="#00FFFF"><p align="center">H</td><td width="5" bgcolor="#00FFFF"><p align="center">I</td><td width="10" bgcolor="#00FFFF"><p align="center">J</td><td width="5" bgcolor="#00FFFF"><p align="center">K</td><td width="10" bgcolor="#00FFFF"><p align="center">L</td><td width="5" bgcolor="#00FFFF"><p align="center">M</td><td width="10" bgcolor="#00FFFF"><p align="center">N</td></tr><tr><td width="5" bgcolor="#00FFFF">3</td><td width="40"><p align="center">Mittwoch </td><td width="10"><p align="center">&nbsp;</td><td width="50"><p align="center">01.04.2009 </td><td width="10"><p align="center">&nbsp;</td><td width="5"><p align="center">- </td><td width="10"><p align="center">&nbsp;</td><td width="5"><p align="center">- </td><td width="10"><p align="center">&nbsp;</td><td width="5"><p align="center">- </td><td width="10"><p align="center">&nbsp;</td><td width="5"><p align="center">- </td><td width="10"><p align="center">&nbsp;</td><td width="5"><p align="center">- </td><td width="10"><p align="center">&nbsp;</td></tr></table><br>Benutzte Formeln:<br>A3: =C3<br>E3: =D39<br>K3: =WENN(I3="-";"-";(STUNDE(M3)+MINUTE(M3)/60))<br>M3: =WENN(I3="-";"-";REST(I3-G3;1))
Gruss Hary

TobiasT
16.04.2009, 20:11
Huhu hary.

Diese Version ist auch schick. Und ich könnte die "-" drinnen lassen. Mal schauen, wofür ich mich letzten Endes entscheide^^ Ich danke dir auch recht herzlich ;)


Gruß,
Tobias

BoskoBiati
16.04.2009, 20:12
Hallo Tobias,

Aus Deinem Code in K:
=WENN(E3="-";"";WENN(E3="U";"";WENN(E3="K";"";WENN(E3="X";"";WENN(E3="EW";"";(STUNDE(M3)+MINUTE(M3)/60))))))

würde ich folgenden Code machen:

=WENN(G3="-";"";WENN(oder(E3="-";E3="U";E3="K";E3="X";E3="EW");"";(STUNDE(M3)+MINUTE(M3)/60))

und in M:
=WENN($G3="-";"";WENN(ODER($E3="-";$E3="U";$E3="K";$E3="X";$E3="EW");"";(REST((I3-G3);1)*24)))

Was die Uhrzeit angeht: Es gibt die beliebte Variante des doppelten Kommas: Bei Extras Optionen Rechtschreibung Autokorrektur: eintragen " ,," ersetzen durch ":"

hary
16.04.2009, 20:14
Hi
machbar ist es schon, nur das Problem: dann hast Du die Zeiten als Text(also wieder umrechnen.
Ich mache es so.
Autokorrektur ersetzen .. durch :
Zweimal Punkt gedrueckt geht auch schnell
Gruss Hary

TobiasT
16.04.2009, 20:41
So, erstmal auch dir dankeschön, Edgar. Nun habe ich ja 3 Versionen zur Auswahl^^

Was das mit den doppelten Kommata, bzw Punkten angeht: Da macht es dann keinen großen Unterschied, ob ich nun 2x "." oder "," oder gleich richtig einen Doppelpunkt setze ;P Dachte nur, es gäbe eine Möglichkeit, dies zu umgehen und das Excel von alleine mit einer bestimmten Formatierung machen zu lassen^^ Na gut, dann bleibt mir wohl nichts anderes übrig, als den Doppelpunkt immer zu setzen.

Hat jemand noch einen Verbesserungsvorschlag oder kann man das nun so lassen, wie es ist? Die Schrift des blau und grün umrandeten wird noch weiß gemacht und gesperrt, so dass man da nix mehr machen kann und das auch nicht mehr sieht. Sonst noch wer eine kleine Idee?


Gruß,
Tobias

BoskoBiati
16.04.2009, 20:43
Hallo Tobias,
das doppelte Komma hat den Vorteil, dass man im Ziffernblock bleiben kann. Man muß nicht immer wechseln zwischen Tastatur und Ziffernblock.
Frage: Warum gibt es zwei Spalten für die Stunden?

TobiasT
16.04.2009, 20:55
Hi Edgar.

Hm, ok. Das klingt einleuchtend ;)


Wegen den 2 Spalten: Wie oben auf dem Bild zu erkennen ist, ist die blau umrandete Spalte die von Excel ausgerechnete Stundenzahl. Und das rot umrandete ist die Umrechnung in die Dezimalzahl der von Excel ausgerechneten Stundenzahl.


Gruß,
Tobias

BoskoBiati
16.04.2009, 21:05
Hallo Tobias,

wenn Du das brauchst, ok. Du könntest aber die Stundenzahl mit
REST(I5-G5;1)*24 direkt als Dezimalzahl anzeigen lassen.

hary
16.04.2009, 21:33
Brauchst Du die blauen Zahlen fuer andere Berechnungen? Wenn nicht kannst die Sparen.

Tabellenblattname: April<table border="1" width="173" bgcolor="#FFFF00" id="table1"><tr><td width="10" bgcolor="#00FFFF">&nbsp;</td><td width="10" bgcolor="#00FFFF"><p align="center">P</td><td width="70" bgcolor="#00FFFF"><p align="center">Q</td><td width="10" bgcolor="#00FFFF"><p align="center">R</td><td width="10" bgcolor="#00FFFF"><p align="center">S</td><td width="10" bgcolor="#00FFFF"><p align="center">T</td><td width="25" bgcolor="#00FFFF"><p align="center">U</td><td width="10" bgcolor="#00FFFF"><p align="center">V</td></tr><tr><td width="10" bgcolor="#00FFFF">14</td><td width="10"><p align="center">&nbsp;</td><td width="70"><p align="center">Anzahl Stunden </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">15</td><td width="10"><p align="center">&nbsp;</td><td width="70"><p align="center">Nacht </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">59:00 </td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">16</td><td width="10"><p align="center">&nbsp;</td><td width="70"><p align="center">Tag: </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">7:30 </td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">17</td><td width="10"><p align="center">&nbsp;</td><td width="70"><p align="center">Veranstaltung: </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">0:00 </td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">18</td><td width="10"><p align="center">&nbsp;</td><td width="70"><p align="center">Messe: </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">0:00 </td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">19</td><td width="10"><p align="center">&nbsp;</td><td width="70"><p align="center">Gesamt: </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">66:30 </td><td width="10"><p align="center">&nbsp;</td></tr></table><br>Benutzte Formeln:<br>U15: =SUMMEWENN(E3:N32;"N";M3:N33)<br>U16: =SUMMEWENN(E3:N32;"T";M3:N32)<br>U17: =SUMMEWENN(E3:N32;"V";M3:N32)<br>U18: =SUMMEWENN(E3:N32;"ME";M3:N32)<br>U19: =SUMME(U15:V18)
Gruss Hary

TobiasT
16.04.2009, 21:34
Hi Edgar.

ja, das habe ich mir auch schon überlegt. Nur habe ich dann das "Klammer-Problem". Da die Berechnung ja in einer "WENN-Formel" läuft, wird das "*24" als Sonst-Wert angesehen.


Gruß,
Tobias

TobiasT
16.04.2009, 21:41
Hi hary.

Hm, Wenn ich diese Formeln eingebe, kommt bei den Nachtschichten die Zahl 2,58 und bei den Tagschichten 0,31 raus?


Gruß,
Tobias

BoskoBiati
16.04.2009, 21:51
Dann stimmt die Klammersetzung nicht:

=WENN($G5="-";"";WENN(ODER($E5="-";$E5="U";$E5="K";$E5="X";$E5="EW");"";REST(I5-G5;1)*24))

In Zeile 36 habe ich noch eine kleine Formatänderung vorgenommen.

hary
16.04.2009, 21:53
Habe was vergessen *24

Tabellenblattname: April<table border="1" width="161" bgcolor="#FFFF00" id="table1"><tr><td width="10" bgcolor="#00FFFF">&nbsp;</td><td width="70" bgcolor="#00FFFF"><p align="center">Q</td><td width="10" bgcolor="#00FFFF"><p align="center">R</td><td width="10" bgcolor="#00FFFF"><p align="center">S</td><td width="10" bgcolor="#00FFFF"><p align="center">T</td><td width="25" bgcolor="#00FFFF"><p align="center">U</td><td width="10" bgcolor="#00FFFF"><p align="center">V</td></tr><tr><td width="10" bgcolor="#00FFFF">14</td><td width="70"><p align="center">Anzahl Stunden </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">15</td><td width="70"><p align="center">Nacht </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">59,00 </td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">16</td><td width="70"><p align="center">Tag: </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">7,50 </td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">17</td><td width="70"><p align="center">Veranstaltung: </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">0,00 </td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">18</td><td width="70"><p align="center">Messe: </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">0,00 </td><td width="10"><p align="center">&nbsp;</td></tr><tr><td width="10" bgcolor="#00FFFF">19</td><td width="70"><p align="center">Gesamt: </td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="10"><p align="center">&nbsp;</td><td width="25"><p align="center">66,50 </td><td width="10"><p align="center">&nbsp;</td></tr></table><br>Benutzte Formeln:<br>U15: =SUMMEWENN($E$3:$N$32;"N";$M$3:$N$32)*24<br>U16: =SUMMEWENN($E$3:$N$32;"T";$M$3:$N$32)*24<br>U17: =SUMMEWENN($E$3:$N$32;"V";$M$3:$N$32)*24<br>U18: =SUMMEWENN($E$3:$N$32;"ME";$M$3:$N$32)*24<br>U19: =SUMME(U15:V18)
Gruss Hary

hary
16.04.2009, 22:10
Hi
Letzte mal vorm Schlaf
schau mal die Mappe an
Gruss hary

TobiasT
16.04.2009, 22:37
Hossa hary.

Vielen Dank für den Anhang. Nun ist es so, wie es sein soll ;) Dann kannst du ja nun beruhigt schlafen gehen ;)


Gruß,
Tobias

hary
16.04.2009, 23:15
Zwei Muedigkeitsfehler
U17 und U18 nimm mal hinten die *24 weg
Gruss Hary
und....Nacht ;-))

TobiasT
17.04.2009, 01:33
Ok, dann nochmal danke an alle, die geholfen haben. Ist somit erledigt ;)


Gruß,
Tobias