PDA

Vollständige Version anzeigen : Formel, aber mit relativen statt absoluten Bezug


hopethisnameworks
24.03.2009, 11:33
Hi again.

Diesmal ist die Lösung wahrscheinlich banal, aber ich habe trozt langer Suche keine Antwort finden können.

Wie kann ich denn bei folgender Formel:
Cells(2, t).FormulaLocal = "=SVERWEIS(Tabelle1!" & Cells(2, t).Address & ";Tabelle2!$G$1:$H$21;2;WAHR)"

bei der der Bezug Cells(2,t) absolut wiedergegeben wird in einen relativen verändern?

Zum besseren Verständnis noch erhalte ich in der Excel Tabelle

=SVERWEIS(Tabelle1!$I$2;Tabelle2!$G$1:$H$21;2;WAHR)

möchte aber

=SVERWEIS(Tabelle1!I2;Tabelle2!$G$1:$H$21;2;WAHR)

als Output bekommen.

danke



Habe es nun selbst rausbekommen.

Einfach in Cells(2, t).Address(xlA1) das Address mit (xlA1) bestücken

jinx
24.03.2009, 16:44
Moin, hopethisnameworks,

oder .Address(0, 0) verwenden...