PDA

Vollständige Version anzeigen : Funktionssuche


Philstift
18.03.2009, 16:48
Hallo zusammen,

Ich brauche dringen Hilfe bei einer Excel Funktion.

Für eine Kontoüberwachung ist es notwendig, einen Namen aus einer Spalte einer vordefinierter Namenliste (alphabetisch Sortiert) in Spalte (C) in der Spalte(A) zu suchen und falls vorhanden, das zu Spalte (A) gehörende Datum in (B) hinter den passenden Namen in (C) in Spalte D wieder zugeben, oder falls es nicht gefunden wird, mit "Fehler" zu füllen.

Soll wie folgt aussehen:


A________B_____________C_________D
Albert____04.10._________ Albert_____04.10.
Susi_____06.12.__________Daniel_____05.11.
Daniel ___05.11._________ Susi_______06.12
Maren___08.02.__________Xaver______Fehler


Wie müsste dafür die in Spalte (D) stehende Funktion aussehen?
Ich bin dankbar für jede Hilfestellung.

Liebe Grüße
Phil

NoNet
18.03.2009, 17:02
Hallo Phil,

das ist die Funktion SVERWEIS()
Gib in D2 folgende Funktion ein und kopiere sie nach unten : =SVERWEIS(C2;$A$2:$B$5;2;0)

In Spalte D wird nun das passende Datum angezeigt, oder aber #NV! (das steht für Nicht Vorhanden !) falls der Namen nicht in Spalte A gefunden wurde (z.B. bei Xaver).

Soll anstelle der Meldung #NV! ein anderer Text (z.B. "Fehler") bei fehlendem Namen angezeigt werden, dann erweitere die Funktion in D2 und kopiere sie nach unten :
=WENN(ISTNV(SVERWEIS(C2;$A$2:$B$5;2;0));"Fehler";SVERWEIS(C2;$A$2:$B$5;2;0))

jinx
18.03.2009, 17:21
Moin NoNet,

wenn es sich wirklich um Excel2007 handelt, dann WennFehler:

=WENNFEHLER(SVERWEIS($D1;$A$1:$B$4;2;FALSCH);"Fehler")

mücke
18.03.2009, 17:24
Hallo Phil,

hab ich dich richtig verstanden ?
Es müssen die Spalten C und D gefüllt werden? ...
... Wenn ja, probier mal dieses:
<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Calibri,Arial; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td >Albert</td><td style="text-align:center; ">04. 10</td><td >Albert</td><td style="text-align:center; ">04. 10</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td >Susi</td><td style="text-align:center; ">06. 12</td><td >Daniel</td><td style="text-align:center; ">05. 11</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td >Daniel</td><td style="text-align:center; ">05. 11</td><td >Maren</td><td style="text-align:center; ">08. 02</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td >Maren</td><td style="text-align:center; ">08. 02</td><td >Susi</td><td style="text-align:center; ">06. 12</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >C1</td><td >{=INDEX($A$1:$A$4;VERGLEICH<span style=' color:008000; '>(KKLEINSTE<span style=' color:#0000ff; '>(Z&Auml;HLENWENN<span style=' color:#ff0000; '>(A$1:A$4;"&lt;"&A$1:A$4)</span>;ZEILEN<span style=' color:#ff0000; '>(A$1:A1)</span>)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(A$1:A$4;"&lt;"&A$1:A$4)</span>;0)</span>)}</td></tr><tr><td >D1</td><td >=WENN(ISTFEHLER<span style=' color:008000; '>(SVERWEIS<span style=' color:#0000ff; '>(C1;$A$1:$B$4;2;0)</span>)</span>;"";SVERWEIS<span style=' color:008000; '>(C1;$A$1:$B$4;2;0)</span>)</td></tr><tr><td >C2</td><td >{=INDEX($A$1:$A$4;VERGLEICH<span style=' color:008000; '>(KKLEINSTE<span style=' color:#0000ff; '>(Z&Auml;HLENWENN<span style=' color:#ff0000; '>(A$1:A$4;"&lt;"&A$1:A$4)</span>;ZEILEN<span style=' color:#ff0000; '>(A$1:A2)</span>)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(A$1:A$4;"&lt;"&A$1:A$4)</span>;0)</span>)}</td></tr><tr><td >D2</td><td >=WENN(ISTFEHLER<span style=' color:008000; '>(SVERWEIS<span style=' color:#0000ff; '>(C2;$A$1:$B$4;2;0)</span>)</span>;"";SVERWEIS<span style=' color:008000; '>(C2;$A$1:$B$4;2;0)</span>)</td></tr><tr><td >C3</td><td >{=INDEX($A$1:$A$4;VERGLEICH<span style=' color:008000; '>(KKLEINSTE<span style=' color:#0000ff; '>(Z&Auml;HLENWENN<span style=' color:#ff0000; '>(A$1:A$4;"&lt;"&A$1:A$4)</span>;ZEILEN<span style=' color:#ff0000; '>(A$1:A3)</span>)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(A$1:A$4;"&lt;"&A$1:A$4)</span>;0)</span>)}</td></tr><tr><td >D3</td><td >=WENN(ISTFEHLER<span style=' color:008000; '>(SVERWEIS<span style=' color:#0000ff; '>(C3;$A$1:$B$4;2;0)</span>)</span>;"";SVERWEIS<span style=' color:008000; '>(C3;$A$1:$B$4;2;0)</span>)</td></tr><tr><td >C4</td><td >{=INDEX($A$1:$A$4;VERGLEICH<span style=' color:008000; '>(KKLEINSTE<span style=' color:#0000ff; '>(Z&Auml;HLENWENN<span style=' color:#ff0000; '>(A$1:A$4;"&lt;"&A$1:A$4)</span>;ZEILEN<span style=' color:#ff0000; '>(A$1:A4)</span>)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(A$1:A$4;"&lt;"&A$1:A$4)</span>;0)</span>)}</td></tr><tr><td >D4</td><td >=WENN(ISTFEHLER<span style=' color:008000; '>(SVERWEIS<span style=' color:#0000ff; '>(C4;$A$1:$B$4;2;0)</span>)</span>;"";SVERWEIS<span style=' color:008000; '>(C4;$A$1:$B$4;2;0)</span>)</td></tr></table></td></tr><tr><td ><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>Enth&auml;lt Matrixformel:</span><span style=' font-family:Arial,Arial; font-size:9pt;'><br />Umrandende </span><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>{ }</span><span style=' font-family:Arial,Arial; font-size:9pt;'> nicht miteingeben,<br />sondern Formel mit STRG+SHIFT+RETURN abschlie&szlig;en!</span></td></tr><tr><td ><a href="http://www.online-excel.de/excel/singsel.php?f=26" style="font-family:Arial; font-size:8pt;font-weight:bold;color:#000080;" target='_blank'>Matrix verstehen</a></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

Philstift
18.03.2009, 18:43
Erst einmal vielen lieben Dank für die schnellen Hilfestellungen! Echt super hier!

NoNet, deine Formel hat funktioniert. Habe sie natürlich noch angepasst und funktioniert nun so, wie ich es haben wollte. Super! Coole Hilfe. Danke!

Jinx, danke für die zusätzlichen Informationen. Funktioniert bestimmt auch. Aber habe NoNet war schneller und habe seine Formel schon eingebaut. Aber lieben Dank dir für deinen ALternativ Vorschlag. Falls ich nicht zu Rande gekommen wäre, hätte ich den Vorschlag verwendet. Lieben Dank dir.

Mücke, danke dass du dir auch noch die Zeit genommen hast, so ausführlich weiter zu helfen und zu erläutern. Echt nett. Aber nur Spalte D muss gefüllt werden. Aber lieben Dank auch dir für deine Mühe.


Schnelle Antworten, nette Hilfe!
Hier komm ich öfter bei Fragen drauf zurück! :)

Einen schönen Abend euch noch!
Liebe Grüße
Phil

mücke
18.03.2009, 22:42
... ist klar im Vorteil ...:grins:
... nur Spalte D muss gefüllt werden ...
Werde beim nächsten mal die Aufgabenstellung etwas gründlicher lesen ...;)
... und Danke fürs Feedback!