PDA

Vollständige Version anzeigen : Auswahlmenü ohne doppelte Vergabe


2bLiNd2sEe
18.03.2009, 11:27
Guten Tag,

ich habe folgendes Problem:

Ich möchte eine Tagesplanung erstellen, bei denen Mitarbeiter sowie Fahrzeuge, Maschinen und Geräte den verschiedenen Baustellen zugeordnet werden sollen.

Dabei soll jedoch vermieden werden, dass ein Mitarbeiter oder ein Fahrzeug, eine Maschine oder ein Gerät zwei oder mehreren Baustellen zugeordnet werden.

Ich habe mich im Internet schon dumm und dämlich gesucht, bin jedoch auf keine Lösung gestoßen und hoffe, dass mir hier jemand weiterhelfen kann.

Gruß

Patrick

jinx
18.03.2009, 16:11
Moin, Patrick,

suchst Du eine Formellösung (Daten/Gültigkeit mit Listen, die nach Auswahl reduziert werden) oder eine Lösung per VBA? Von welchen Größenordnungen sprechen wir? 10 Baustellen, 100 Fahrzeuge, 1000 Mitarbeiter? ;)

2bLiNd2sEe
19.03.2009, 07:02
Moin jinx,

erstmal bin ich auf der Suche nach einer Lösung, die auch funktioniert :D

Die Liste wird eigentlich keinen großen Umfang haben. Wir sprechen da über ~20 Baustellen, ~15 Mitarbeiter und ~40 Fahrzeuge und Maschinen.

jinx
19.03.2009, 17:50
Moin, Patrick,

...nach einer Lösung, die auch funktioniert.
Das hatte ich doch wirklich nicht erwartet... ;) Ich mach mich mal auf die Suche nach dem Link oder der Beispielmappe - leider kann das bis zum Wochenende dauern (ich habe zur Zeit nur die Erinnerung, dass es die Mappe gibt, aber keinen blassen Schimmer vom Namen der Mappe oder dem Thema,. wo sie veröffentlicht wurde). Und wenn sich das nicht ändert, werde ich arbeiten "dürfen" und ein Beispiel zusammenstellen (das ist der Nachteil, wenn man sich immer einmischt). Ich melde mich wieder, wenn von anderer Seite keine Hinweise kommen.

2bLiNd2sEe
22.03.2009, 15:43
Das wäre super, vielen Dank jinx :)

jinx
22.03.2009, 16:41
Moin, Patrick,

anbei ein Muster für ein mögliche Umsetzung. Die Grundliste befindet sich in Tabelle1, der Bereich für Daten/Gültigkeit wird in Spalte E erzeugt. Nach Auswahl über Daten/Gültigkeit steht der gewählte Wert auch in dem DropDown nicht mehr zur Verfügung, für den abzubildenden Bereich wurde ein dynamischer Bereich mit einem Namen versehen (Bereich2)...

<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td><td >E</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td >Beispiel 1</td><td style="text-align:right; ">1</td><td >vergeben</td><td >&nbsp;</td><td >Beispiel 2</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td >Beispiel 2</td><td style="text-align:right; ">0</td><td >Beispiel 2</td><td >&nbsp;</td><td >Beispiel 4</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td >Beispiel 3</td><td style="text-align:right; ">1</td><td >vergeben</td><td >&nbsp;</td><td >Beispiel 5</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td >Beispiel 4</td><td style="text-align:right; ">0</td><td >Beispiel 4</td><td >&nbsp;</td><td >Beispiel 6</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td >Beispiel 5</td><td style="text-align:right; ">0</td><td >Beispiel 5</td><td >&nbsp;</td><td >Beispiel 7</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td >Beispiel 6</td><td style="text-align:right; ">0</td><td >Beispiel 6</td><td >&nbsp;</td><td >Beispiel 8</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td >Beispiel 7</td><td style="text-align:right; ">0</td><td >Beispiel 7</td><td >&nbsp;</td><td >Beispiel 9</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td >Beispiel 8</td><td style="text-align:right; ">0</td><td >Beispiel 8</td><td >&nbsp;</td><td >Beispiel 10</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td >Beispiel 9</td><td style="text-align:right; ">0</td><td >Beispiel 9</td><td >&nbsp;</td><td >Beispiel 11</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td >Beispiel 10</td><td style="text-align:right; ">0</td><td >Beispiel 10</td><td >&nbsp;</td><td >Beispiel 12</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >11</td><td >Beispiel 11</td><td style="text-align:right; ">0</td><td >Beispiel 11</td><td >&nbsp;</td><td >Beispiel 13</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >12</td><td >Beispiel 12</td><td style="text-align:right; ">0</td><td >Beispiel 12</td><td >&nbsp;</td><td >Beispiel 14</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >13</td><td >Beispiel 13</td><td style="text-align:right; ">0</td><td >Beispiel 13</td><td >&nbsp;</td><td >Beispiel 15</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >14</td><td >Beispiel 14</td><td style="text-align:right; ">0</td><td >Beispiel 14</td><td >&nbsp;</td><td >Beispiel 16</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >15</td><td >Beispiel 15</td><td style="text-align:right; ">0</td><td >Beispiel 15</td><td >&nbsp;</td><td >Beispiel 17</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >16</td><td >Beispiel 16</td><td style="text-align:right; ">0</td><td >Beispiel 16</td><td >&nbsp;</td><td >Beispiel 18</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >17</td><td >Beispiel 17</td><td style="text-align:right; ">0</td><td >Beispiel 17</td><td >&nbsp;</td><td >Beispiel 19</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >18</td><td >Beispiel 18</td><td style="text-align:right; ">0</td><td >Beispiel 18</td><td >&nbsp;</td><td >Beispiel 20</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >19</td><td >Beispiel 19</td><td style="text-align:right; ">0</td><td >Beispiel 19</td><td >&nbsp;</td><td style="text-align:right; ">0</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >20</td><td >Beispiel 20</td><td style="text-align:right; ">0</td><td >Beispiel 20</td><td >&nbsp;</td><td style="text-align:right; ">0</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >A1</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B1</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A1)</td></tr><tr><td >C1</td><td >=WENN(B1=1;"vergeben";A1)</td></tr><tr><td >E1</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A2</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B2</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A2)</td></tr><tr><td >C2</td><td >=WENN(B2=1;"vergeben";A2)</td></tr><tr><td >E2</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A3</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B3</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A3)</td></tr><tr><td >C3</td><td >=WENN(B3=1;"vergeben";A3)</td></tr><tr><td >E3</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A4</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B4</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A4)</td></tr><tr><td >C4</td><td >=WENN(B4=1;"vergeben";A4)</td></tr><tr><td >E4</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A5</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B5</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A5)</td></tr><tr><td >C5</td><td >=WENN(B5=1;"vergeben";A5)</td></tr><tr><td >E5</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A6</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B6</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A6)</td></tr><tr><td >C6</td><td >=WENN(B6=1;"vergeben";A6)</td></tr><tr><td >E6</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A7</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B7</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A7)</td></tr><tr><td >C7</td><td >=WENN(B7=1;"vergeben";A7)</td></tr><tr><td >E7</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A8</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B8</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A8)</td></tr><tr><td >C8</td><td >=WENN(B8=1;"vergeben";A8)</td></tr><tr><td >E8</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A9</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B9</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A9)</td></tr><tr><td >C9</td><td >=WENN(B9=1;"vergeben";A9)</td></tr><tr><td >E9</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A10</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B10</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A10)</td></tr><tr><td >C10</td><td >=WENN(B10=1;"vergeben";A10)</td></tr><tr><td >E10</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A11</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B11</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A11)</td></tr><tr><td >C11</td><td >=WENN(B11=1;"vergeben";A11)</td></tr><tr><td >E11</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A12</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B12</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A12)</td></tr><tr><td >C12</td><td >=WENN(B12=1;"vergeben";A12)</td></tr><tr><td >E12</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A13</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B13</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A13)</td></tr><tr><td >C13</td><td >=WENN(B13=1;"vergeben";A13)</td></tr><tr><td >E13</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A14</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B14</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A14)</td></tr><tr><td >C14</td><td >=WENN(B14=1;"vergeben";A14)</td></tr><tr><td >E14</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A15</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B15</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A15)</td></tr><tr><td >C15</td><td >=WENN(B15=1;"vergeben";A15)</td></tr><tr><td >E15</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A16</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B16</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A16)</td></tr><tr><td >C16</td><td >=WENN(B16=1;"vergeben";A16)</td></tr><tr><td >E16</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A17</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B17</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A17)</td></tr><tr><td >C17</td><td >=WENN(B17=1;"vergeben";A17)</td></tr><tr><td >E17</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A18</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B18</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A18)</td></tr><tr><td >C18</td><td >=WENN(B18=1;"vergeben";A18)</td></tr><tr><td >E18</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A19</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B19</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A19)</td></tr><tr><td >C19</td><td >=WENN(B19=1;"vergeben";A19)</td></tr><tr><td >E19</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr><tr><td >A20</td><td >="Beispiel " & ZEILE()</td></tr><tr><td >B20</td><td >=Z&Auml;HLENWENN(Tabelle2!A:A;A20)</td></tr><tr><td >C20</td><td >=WENN(B20=1;"vergeben";A20)</td></tr><tr><td >E20</td><td >{=INDEX(C$1:C$99;KKLEINSTE<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(<span style=' color:#ff0000; '>(C$1:C$99&lt;&gt;"vergeben")</span>;ZEILE<span style=' color:#ff0000; '>($1:$99)</span>)</span>;ZEILE<span style=' color:#0000ff; '>()</span>)</span>)}</td></tr></table></td></tr><tr><td ><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>Enth&auml;lt Matrixformel:</span><span style=' font-family:Arial,Arial; font-size:9pt;'><br />Umrandende </span><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>{ }</span><span style=' font-family:Arial,Arial; font-size:9pt;'> nicht miteingeben,<br />sondern Formel mit STRG+SHIFT+RETURN abschlie&szlig;en!</span></td></tr><tr><td ><a href="http://www.online-excel.de/excel/singsel.php?f=26" style="font-family:Arial; font-size:8pt;font-weight:bold;color:#000080;" target='_blank'>Matrix verstehen</a></td></tr></table> <br />

2bLiNd2sEe
25.03.2009, 10:25
Funktioniert bestens, vielen Dank für die Lösung :)