PDA

Vollständige Version anzeigen : Stundenerfassung Teilzeit?


andrefrey
17.03.2009, 17:39
Moin,
ich habe hier die Stundenerfassung (Januar) von Mitarbeitern.
Nun gibt es ja Menschen, die in Teilzeit (0,5-Stelle z.B.) arbeiten und das z.B. nur am Montag, Dienstag und Donnerstag.
An diesen beiden Tagen arbeiten sie 6,42 Stunden.
Ich habe ein Tabellenblatt mit den individuellen Daten der Ma.
Das wirft mir für jeden Stellenanteil aber nur aus, mit welchen Stunden (3,85) der Ma arbeiten müsste, wenn der Stellenanteil auf die übliche 5-Tage-Woche verteilt ist.
Die 3,85 tauchen dann natürlich auch im SOLL der Zeiterfassung auf.

Was muss ich machen, damit im SOLL der Stundenerfassung (Januar) tatsächlich die 6,42 Std. für Montags, Dienstags und Donnerstags erscheint.

1. Die Formel in der Stundenerfassung (Januar) anpassen --> wie?
2. oder besser die Tabelle individuelle Daten verändern --> wie?

Für Tipps wäre ich sehr dankbar

Andreas

die Mappe als Anhang.

jinx
17.03.2009, 17:44
Moin, andrefrey,

für B7:

=B6/AUFRUNDEN(5*B5;0)

andrefrey
17.03.2009, 17:57
dann kommt zwar 6,42 raus aber wie muss ich die Formel in JANUAR H11 ändern, damit da auch nur an den entsprechenden Tagen die 6,42 erscheint?

Gruß
Andreas

jinx
17.03.2009, 18:10
Moin, Andreas,

für H11 z.B.
=WENN($B$4<1;WAHL(WOCHENTAG($A11;2);$B$6;$B$6;0;0;$B$6;0;0);$B$6)

Thomas Ramel
17.03.2009, 19:35
Grüezi Andreas

Schau dir doch mal den Arbeitsrapport Nr 6 auf meinem WebSpace näher an:

http://users.quick-line.ch/ramel/Files/ARBEITS-RAPPORTE/

In den gelb hinterlegten Zellen kannst Du deine Werte wie folgt eingeben:

R15: 38:30
R16: 50%
R17: 3

Damit wird dir dann, abhängig vom Monatsersten in B7 das Tages-/Wochen- und Monats-Soll berechnet.

Gib dann in R6:R12 überall wo nicht gearbeitet wird 0:00 ein, sodass am Ende 3 Arbetistage übrig bleiben, welche in Summe (R13) wieder dem Wochen-Soll (R18) entsprechen.

In S6:S12 kannst Du noch tägliche Pausenzeiten eintragen, wenn es solche gibt oder einfach alle Werte auf '0' setzen.


Damit ist das Tabellenblatt (inkl. Feiertage) fertig vorbereitet und in der Erfassung werden nur an den ausgwiesenen Wochentagen die Soll-Zeiten eingetragen.


Es gibt noch ein paar Features mehr, darin, aber vielleicht kannst Du dir hier das Wichtigste mal ansehen oder die Mappe gleich ganz übernehmen.

mücke
18.03.2009, 07:47
Guten Morgen Andreas,

anbei mal eine kleine Anpassung deiner Mappe.
Die individuellen Soll-Stunden/Tag und die Feiertage werden jetzt mit berücksichtigt.
Schau mal bitte, ob es das ist was du wolltest.
Wenn noch Fragen oder Wünsche offen sind, einfach fragen ;)

andrefrey
18.03.2009, 19:08
Vielen Dank für die unterschiedlichen Lösungen,
die von Dirk pass wie die Faust aufs Auge :) :)

danke und Gruß
Andreas

mücke
18.03.2009, 22:44
Hi Andreas,

... wenn es passt!

andrefrey
19.03.2009, 09:53
Hi Dirk,
nur noch eine Verständnisfrage:
Wenn ich die Formel in SOll rnterkopiere erscheint #NV an den darauffolgenden Tagen, warum?

<b>Januar 2009</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Century Gothic,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:116px;" /><col style="width:40px;" /><col style="width:40px;" /><col style="width:40px;" /><col style="width:40px;" /><col style="width:40px;" /><col style="width:40px;" /><col style="width:50px;" /><col style="width:51px;" /><col style="width:47px;" /><col style="width:61px;" /><col style="width:23px;" /><col style="width:23px;" /><col style="width:23px;" /><col style="width:23px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td><td >E</td><td >F</td><td >G</td><td >H</td><td >L</td><td >M</td><td >N</td><td >O</td><td >P</td><td >Q</td><td >R</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td rowspan="2" style="font-weight:bold; font-size:12pt; text-align:center; ">Januar</td><td colspan="2" style="font-weight:bold; text-align:center; ">Dienstzeit 1</td><td colspan="2" style="font-weight:bold; text-align:center; ">Dienstzeit 2</td><td colspan="2" style="font-weight:bold; text-align:center; ">Dienstzeit 3</td><td rowspan="2" style="font-weight:bold; text-align:center; ">SOLL</td><td rowspan="2" style="font-weight:bold; text-align:center; ">IST</td><td rowspan="2" style="font-weight:bold; text-align:center; ">Ersatz- zeit</td><td rowspan="2" style="font-weight:bold; text-align:center; ">Tages- saldo</td><td rowspan="2" style="font-weight:bold; text-align:center; ">K</td><td rowspan="2" style="font-weight:bold; text-align:center; ">U</td><td rowspan="2" style="font-weight:bold; text-align:center; ">SU</td><td rowspan="2" style="font-weight:bold; text-align:center; ">FB</td></tr><tr style="height:19px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td style="font-weight:bold; text-align:center; ">von</td><td style="font-weight:bold; text-align:center; ">bis</td><td style="font-weight:bold; text-align:center; ">von</td><td style="font-weight:bold; text-align:center; ">bis</td><td style="font-weight:bold; text-align:center; ">von</td><td style="font-weight:bold; text-align:center; ">bis</td></tr><tr style="height:19px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td style="text-align:center; ">Do, &nbsp; 01.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="text-align:center; ">0,00</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td style="text-align:center; ">0,00 </td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >11</td><td style="text-align:center; ">Fr, &nbsp; 02.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td >#NV</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td >#NV</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >12</td><td style="background-color:#ffcc00; text-align:center; ">Sa, &nbsp; 03.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#ffcc00; text-align:center; ">0,00</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td style="text-align:center; ">0,00 </td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >13</td><td style="background-color:#ffcc00; text-align:center; ">So, &nbsp; 04.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#ffcc00; text-align:center; ">0,00</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td style="text-align:center; ">0,00 </td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >14</td><td style="text-align:center; ">Mo, &nbsp; 05.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td >#NV</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td >#NV</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >15</td><td style="text-align:center; ">Di, &nbsp; 06.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="text-align:center; ">0,00</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td style="text-align:center; ">0,00 </td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >16</td><td style="text-align:center; ">Mi, &nbsp; 07.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td >#NV</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td >#NV</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >17</td><td style="text-align:center; ">Do, &nbsp; 08.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td >#NV</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td >#NV</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >18</td><td style="text-align:center; ">Fr, &nbsp; 09.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td >#NV</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td >#NV</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >19</td><td style="background-color:#ffcc00; text-align:center; ">Sa, &nbsp; 10.01.</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#ffcc00; text-align:center; ">0,00</td><td style="color:#ffffff; text-align:center; ">0,00 </td><td style="color:#ffffff; text-align:center; ">0,00</td><td style="text-align:center; ">0,00 </td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td><td style="background-color:#00ffff; font-weight:bold; ">&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >A10</td><td >=DATUM('individuelle Daten'!C2;O6;1)</td></tr><tr><td >H10</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A10;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A10)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A10&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A10)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L10</td><td >=SUMME(I10:K10)</td></tr><tr><td >M10</td><td >=WENN(O10="K";$B$6;WENN<span style=' color:008000; '>(P10="U";$B$6;WENN<span style=' color:#0000ff; '>(Q10="SU";$B$6;WENN<span style=' color:#ff0000; '>(R10="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N10</td><td >=WENN(H10&lt;0;0;SUMME<span style=' color:008000; '>(L10+M10-H10)</span>)</td></tr><tr><td >A11</td><td >=+A10+1</td></tr><tr><td >H11</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A11;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A11)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A11&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A11)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L11</td><td >=SUMME(I11:K11)</td></tr><tr><td >M11</td><td >=WENN(O11="K";$B$6;WENN<span style=' color:008000; '>(P11="U";$B$6;WENN<span style=' color:#0000ff; '>(Q11="SU";$B$6;WENN<span style=' color:#ff0000; '>(R11="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N11</td><td >=WENN(H11&lt;0;0;SUMME<span style=' color:008000; '>(L11+M11-H11)</span>)</td></tr><tr><td >A12</td><td >=+A11+1</td></tr><tr><td >H12</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A12;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A12)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A12&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A12)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L12</td><td >=SUMME(I12:K12)</td></tr><tr><td >M12</td><td >=WENN(O12="K";$B$6;WENN<span style=' color:008000; '>(P12="U";$B$6;WENN<span style=' color:#0000ff; '>(Q12="SU";$B$6;WENN<span style=' color:#ff0000; '>(R12="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N12</td><td >=WENN(H12&lt;0;0;SUMME<span style=' color:008000; '>(L12+M12-H12)</span>)</td></tr><tr><td >A13</td><td >=+A12+1</td></tr><tr><td >H13</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A13;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A13)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A13&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A13)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L13</td><td >=SUMME(I13:K13)</td></tr><tr><td >M13</td><td >=WENN(O13="K";$B$6;WENN<span style=' color:008000; '>(P13="U";$B$6;WENN<span style=' color:#0000ff; '>(Q13="SU";$B$6;WENN<span style=' color:#ff0000; '>(R13="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N13</td><td >=WENN(H13&lt;0;0;SUMME<span style=' color:008000; '>(L13+M13-H13)</span>)</td></tr><tr><td >A14</td><td >=+A13+1</td></tr><tr><td >H14</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A14;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A14)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A14&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A14)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L14</td><td >=SUMME(I14:K14)</td></tr><tr><td >M14</td><td >=WENN(O14="K";$B$6;WENN<span style=' color:008000; '>(P14="U";$B$6;WENN<span style=' color:#0000ff; '>(Q14="SU";$B$6;WENN<span style=' color:#ff0000; '>(R14="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N14</td><td >=WENN(H14&lt;0;0;SUMME<span style=' color:008000; '>(L14+M14-H14)</span>)</td></tr><tr><td >A15</td><td >=+A14+1</td></tr><tr><td >H15</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A15;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A15)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A15&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A15)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L15</td><td >=SUMME(I15:K15)</td></tr><tr><td >M15</td><td >=WENN(O15="K";$B$6;WENN<span style=' color:008000; '>(P15="U";$B$6;WENN<span style=' color:#0000ff; '>(Q15="SU";$B$6;WENN<span style=' color:#ff0000; '>(R15="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N15</td><td >=WENN(H15&lt;0;0;SUMME<span style=' color:008000; '>(L15+M15-H15)</span>)</td></tr><tr><td >A16</td><td >=+A15+1</td></tr><tr><td >H16</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A16;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A16)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A16&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A16)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L16</td><td >=SUMME(I16:K16)</td></tr><tr><td >M16</td><td >=WENN(O16="K";$B$6;WENN<span style=' color:008000; '>(P16="U";$B$6;WENN<span style=' color:#0000ff; '>(Q16="SU";$B$6;WENN<span style=' color:#ff0000; '>(R16="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N16</td><td >=WENN(H16&lt;0;0;SUMME<span style=' color:008000; '>(L16+M16-H16)</span>)</td></tr><tr><td >A17</td><td >=+A16+1</td></tr><tr><td >H17</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A17;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A17)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A17&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A17)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L17</td><td >=SUMME(I17:K17)</td></tr><tr><td >M17</td><td >=WENN(O17="K";$B$6;WENN<span style=' color:008000; '>(P17="U";$B$6;WENN<span style=' color:#0000ff; '>(Q17="SU";$B$6;WENN<span style=' color:#ff0000; '>(R17="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N17</td><td >=WENN(H17&lt;0;0;SUMME<span style=' color:008000; '>(L17+M17-H17)</span>)</td></tr><tr><td >A18</td><td >=+A17+1</td></tr><tr><td >H18</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A18;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A18)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A18&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A18)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L18</td><td >=SUMME(I18:K18)</td></tr><tr><td >M18</td><td >=WENN(O18="K";$B$6;WENN<span style=' color:008000; '>(P18="U";$B$6;WENN<span style=' color:#0000ff; '>(Q18="SU";$B$6;WENN<span style=' color:#ff0000; '>(R18="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N18</td><td >=WENN(H18&lt;0;0;SUMME<span style=' color:008000; '>(L18+M18-H18)</span>)</td></tr><tr><td >A19</td><td >=+A18+1</td></tr><tr><td >H19</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A19;2)</span>&gt;5;0;WENN<span style=' color:008000; '>(Z&Auml;HLENWENN<span style=' color:#0000ff; '>(Feiertage;A19)</span>&gt;0;0;WENN<span style=' color:#0000ff; '>(A19&lt;=HEUTE<span style=' color:#ff0000; '>()</span>;VERWEIS<span style=' color:#ff0000; '>(WOCHENTAG<span style=' color:#804000; '>(A19)</span>;$C$5:$G$5;$C$6:$G$6)</span>;0)</span>)</span>)</td></tr><tr><td >L19</td><td >=SUMME(I19:K19)</td></tr><tr><td >M19</td><td >=WENN(O19="K";$B$6;WENN<span style=' color:008000; '>(P19="U";$B$6;WENN<span style=' color:#0000ff; '>(Q19="SU";$B$6;WENN<span style=' color:#ff0000; '>(R19="FB";$B$6;0)</span>)</span>)</span>)</td></tr><tr><td >N19</td><td >=WENN(H19&lt;0;0;SUMME<span style=' color:008000; '>(L19+M19-H19)</span>)</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

Gruß
Andreas

mücke
19.03.2009, 10:05
Hallo Andreas,

ich kann in der Formel keinen Fehler finden. Bei mir funktioniert es.
Hast du in der Zeile 6 etwas verändert, oder in der TB individuelle Daten?
Er sucht die SOLL-Zeiten und findet diese nicht.
Lad doch bitte mal die Mappe hoch, wo der Fehler auftritt, dann schau ich mir diese naoch mal an.

andrefrey
19.03.2009, 11:06
Hallo Dirk,
sorry, war mein Fehler, ich hatte in Zeile 6 nur in Spalte B was drin.
So ist das, wenn man nicht genau hinschaut.
Danke für deine Hilfsbereitschaft.

Gruß
Andreas

mücke
19.03.2009, 11:49
Hi Andreas,

kein Probel ;)
Wenn noch Fragen offen sind, einfach melden.

andrefrey
20.03.2009, 08:13
es klappt wirklich super, nur ich musste die Formel neu schreiben.
Wenn ich sie kopiert habe wollte es nicht funktionieren, obwohl sie absolut identisch war.
Komisch.
Egal, einmal neu getipt und nach unten ausgefüllt - passt

Gruß
Andreas