PDA

Vollständige Version anzeigen : Die letzten 7 Tage ohne Sonntag anzeigen


Basejumper
15.03.2009, 17:04
Hallo zusammen, ich habe folgendes Problem:

Ich möchte in einer Tabelle, in A1 das Heute Datum haben, in A2 den Vortag, A3 vor 2 Tagen, usw. bis A7. Nur sollen mir dabei nur Mo.-Sa. angezeigt werden, ausgenommen Sonntage!
Hat jemand eine Idee wie ich das mache ??? :(

A1=HEUTE()
A2= ?
A3= ?
A4= ?
A5= ?
A6= ?
A7= ?

Hoffe jemand kann mir helfen :rolleyes:

Gruß

jinx
15.03.2009, 17:31
Moin, Basejumper,

wie soll das Problem der Eingabe des heutigen Sonntags geregelt werden?

<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="text-align:right; ">15.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="text-align:right; ">14.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="text-align:right; ">13.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="text-align:right; ">12.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="text-align:right; ">11.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="text-align:right; ">10.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td style="text-align:right; ">09.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td style="text-align:right; ">07.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td style="text-align:right; ">06.03.2009</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >A1</td><td >=HEUTE()</td></tr><tr><td >A2</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A1-1;2)</span>=7;A1-2;A1-1)</td></tr><tr><td >A3</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A2-1;2)</span>=7;A2-2;A2-1)</td></tr><tr><td >A4</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A3-1;2)</span>=7;A3-2;A3-1)</td></tr><tr><td >A5</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A4-1;2)</span>=7;A4-2;A4-1)</td></tr><tr><td >A6</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A5-1;2)</span>=7;A5-2;A5-1)</td></tr><tr><td >A7</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A6-1;2)</span>=7;A6-2;A6-1)</td></tr><tr><td >A8</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A7-1;2)</span>=7;A7-2;A7-1)</td></tr><tr><td >A9</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(A8-1;2)</span>=7;A8-2;A8-1)</td></tr></table></td></tr></table> <br />

Backowe
15.03.2009, 17:49
Hi,

<table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:93px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="text-align:right; ">Sa &nbsp;14.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="text-align:right; ">Fr &nbsp; 13.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="text-align:right; ">Do &nbsp;12.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="text-align:right; ">Mi &nbsp;11.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="text-align:right; ">Di &nbsp; 10.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="text-align:right; ">Mo 09.03.2009</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td style="text-align:right; ">Sa &nbsp;07.03.2009</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >A1</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(HEUTE<span style=' color:#0000ff; '>()</span>;2)</span>=7;HEUTE<span style=' color:008000; '>()</span>-1;HEUTE<span style=' color:008000; '>()</span>)</td></tr><tr><td >A2</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(HEUTE<span style=' color:#0000ff; '>()</span>-ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=7;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>-1;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>)</td></tr><tr><td >A3</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(HEUTE<span style=' color:#0000ff; '>()</span>-ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=7;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>-1;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>)</td></tr><tr><td >A4</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(HEUTE<span style=' color:#0000ff; '>()</span>-ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=7;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>-1;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>)</td></tr><tr><td >A5</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(HEUTE<span style=' color:#0000ff; '>()</span>-ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=7;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>-1;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>)</td></tr><tr><td >A6</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(HEUTE<span style=' color:#0000ff; '>()</span>-ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=7;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>-1;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>)</td></tr><tr><td >A7</td><td >=WENN(WOCHENTAG<span style=' color:008000; '>(HEUTE<span style=' color:#0000ff; '>()</span>-ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=7;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>-1;HEUTE<span style=' color:008000; '>()</span>-ZEILE<span style=' color:008000; '>()</span>)</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

Basejumper
15.03.2009, 17:55
Vielen Dank für die schnelle Hilfe :)

Klappt wunderbar ;)

Gruß
Tim