PDA

Vollständige Version anzeigen : Formel in Excel


tcd
13.03.2009, 08:37
:( Habe einen Download aus SAP.

In Zelle A1 steht bspw. eine Konto-Nr. 40100

In spalte B1 bis G5 stehen versch. Belege

Ab Zelle A6 habe ich nun ein anderes Konto 40200 darunter auch wieder
versch. Belege b6 bis g24

etc.

Wie bekomme ich die Konto-nr. 40100 in Zelle A2-A5,
40200 von A7 bis A24, usw., ohne dies manuell machen zu müssen.

Ich hatte da mal eine entsprechende Hilfs-Formel, aber ich komm nicht
mehr drauf.

Gruss

tcd

Excel 2003

BoskoBiati
13.03.2009, 08:48
Hallo tcd,

mit einem Makro:
Option Explicit
Public Sub ausfüllen()


Dim intA As Integer
Dim IntB As Long
IntB = 1
intA = 1
While Cells(intA, 2) <> ""
If Cells(intA, 1) <> "" Then
IntB = intA
intA = intA + 1
Else
Cells(intA, 1) = Cells(IntB, 1)
intA = intA + 1
End If
Wend

End Sub

tcd
13.03.2009, 09:51
Danke, klappt wunderbar ...

dann mach ichs ab jetzt mit VBA.

Wenn mir meine Formel wieder einfällt, poste ich sie auch hier noch ...

Gruß

tcd

Madrapour
13.03.2009, 11:03
Hallo,

ich würde, wenn's geht immer ohne Makro arbeiten, wenn's um einfache Dinge geht. In diesem Fall könnte man auch wie folgt vorgehen:

Hilfsspalte vorn enfügen, dort dann in

A1: =B1
A2: =WENN(B2="";A1;B2)

Automatisch runterkopieren (doppelklick auf das kleine Viereck), dann Spalte A markieren u. kopieren, Spalte B markieren, Inhalte einfügen (Werte) und dann Spalte A wieder löschen. Ist zwar immer noch ein bisschen "manuell", geht aber auch innerhalb von 10 Sekunden.

Gruß Stefan.

BoskoBiati
13.03.2009, 11:55
Hallo Stefan,

mach das mal, wenn in unregelmäßigen Abständen die Werte sich ändern und die Spalte sich über einige tausend Zeilen erstreckt!

Madrapour
13.03.2009, 12:02
mach das mal, wenn in unregelmäßigen Abständen die Werte sich ändern und die Spalte sich über einige tausend Zeilen erstreckt!

Hab ich. Werde doch bitte etwas konkreter... :confused:

Stefan.

BoskoBiati
13.03.2009, 12:27
Hallo Stefan,

ok, hat mich überzeugt. Eigentlich war das auch mein erster Ansatz, nur hatte ich irgendwo einen Fehler, so dass ab der 3.Zeile nur 0 stand. Deswegen bin ich davon weg und auf das Makro umgestiegen. Ich denke, das Makro ist zudem um einiges schneller als die händische Variante.