PDA

Vollständige Version anzeigen : Person und Datum mit Zeitraum vergleichen


mücke
10.03.2009, 17:57
Hallo allerseits,

hab da mal ne Frage. :)

Ich möchte prüfen, ob eine Person zu einem bestimmten Zeitraum passt.
Leider sind meine bisherigen Versuche gescheitert und im www hab ich noch nichts passendes gefunden. :(

Mein letzter Ansatz sieht so aus.
Hier müsste ich drei Treffer erhalten (siehe Markierungen)
<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:51px;" /><col style="width:80px;" /><col style="width:19px;" /><col style="width:51px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:51px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td><td >E</td><td >F</td><td >G</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td colspan="2" style="text-align:center; ">Liste A</td><td >&nbsp;</td><td colspan="4" style="text-align:center; ">Liste B</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="text-align:center; ">PersNr.</td><td style="text-align:center; ">Datum</td><td >&nbsp;</td><td style="text-align:center; ">PersNr.</td><td style="text-align:center; ">Beginn</td><td style="text-align:center; ">Ende</td><td style="text-align:center; ">Pr&uuml;fung</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="color:#ff0000; text-align:center; ">1234</td><td style="color:#ff0000; text-align:center; ">24.02.2009</td><td >&nbsp;</td><td style="text-align:center; ">1234</td><td style="text-align:center; ">23.02.2009</td><td style="text-align:center; ">23.02.2009</td><td style="text-align:center; ">0</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="text-align:center; ">1234</td><td style="text-align:center; ">09.02.2009</td><td >&nbsp;</td><td style="color:#ff0000; text-align:center; ">1234</td><td style="color:#ff0000; text-align:center; ">24.02.2009</td><td style="color:#ff0000; text-align:center; ">24.02.2009</td><td style="color:#ff0000; text-align:center; ">0</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="text-align:center; ">1234</td><td style="text-align:center; ">13.02.2009</td><td >&nbsp;</td><td style="color:#ff0000; text-align:center; ">2079</td><td style="color:#ff0000; text-align:center; ">20.02.2009</td><td style="color:#ff0000; text-align:center; ">26.02.2009</td><td style="color:#ff0000; text-align:center; ">0</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="text-align:center; ">1234</td><td style="text-align:center; ">16.02.2009</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td style="text-align:center; ">2000</td><td style="text-align:center; ">15.02.2009</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td style="text-align:center; ">2010</td><td style="text-align:center; ">06.02.2009</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td style="text-align:center; ">2010</td><td style="text-align:center; ">09.02.2009</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td style="color:#ff0000; text-align:center; ">2079</td><td style="color:#ff0000; text-align:center; ">23.02.2009</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >11</td><td style="color:#ff0000; text-align:center; ">2079</td><td style="color:#ff0000; text-align:center; ">24.02.2009</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >G3</td><td >=SUMMENPRODUKT(D3=$A$3:$A$11)*(A3&gt;=$E$3:$E$5)*(A3&lt;=$F$3:$F$5)</td></tr><tr><td >G4</td><td >=SUMMENPRODUKT(D4=$A$3:$A$11)*(A4&gt;=$E$3:$E$5)*(A4&lt;=$F$3:$F$5)</td></tr><tr><td >G5</td><td >=SUMMENPRODUKT(D5=$A$3:$A$11)*(A5&gt;=$E$3:$E$5)*(A5&lt;=$F$3:$F$5)</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

Was mach ich Falsch?!
Kann mir da BITTE jemand unter die Arme greifen?

Besten Dank vorab.

jinx
10.03.2009, 18:04
Moin, Dirk,

erklärst Du mir den Zusammenhang zwischen PersNr und den Datumsbereichen, die Du in den Bedingungen 2 und 3 vergleichst?

IngGi
10.03.2009, 18:04
Hallo Mücke,

ich würde meinen für G3:

=SUMMENPRODUKT(D3=$A$3:$A$11)*(E3<=$A$3:$A$11)*(F3>=$A$3:$A$11)

Gruß Ingolf

mücke
10.03.2009, 18:12
Hallo jinx,

da hat sich der Fehlerteufel in die Formel gemogelt!
Es sollte nicht A3, A4, A5 sondern B3, B4, B5 heißen! Hab ich jetzt geändert, funktioniert aber trotzdem nicht. :(

@Ingolf
Hi Ingolf, funzt leider auch nicht. Hier bekomme ich immer eine 0 als Ergebnis.

jinx
10.03.2009, 18:19
Moin, Mücke,

in G3:
=SUMMENPRODUKT(($A$3:$A$11=$D3)*($B$3:$B$11>=$E3)*($B$3:$B$11<=$F3))
Ergebnis bei mir (XL12):
G3 - 0
G4 - 1
G5 - 2

mücke
10.03.2009, 18:36
Hi jinx,

die Formel funktionier bestens! Vielen Dank :)

Wünsche allen noch einen schönen Abend!