PDA

Vollständige Version anzeigen : Makro: Suchen und Ersetzen von einer Datei zur andern


swordbreacker
10.03.2009, 13:34
Hallo zusamme ich hab folgendes Problem.

Ich habe zwei Tabellen in beiden stehen ID Nummern. Ich möchte jetzt die ID Nummer der ersten Tabelle durch die Information zu der ID-Nummer der zweiten Tabelle ersetzen.

1. Tabelle

1314321aa, weitere Informationen
312312sse, weitere Informationen
usw

2. Tabelle

ID Adresse

1314321aa erstestrasse
312312sse zweitestrasse
usw

Am Schluss soll das Ganze zusammen getragen werden.

erstestrasse, weitere Informationen
zweitestrasse, weitere Informationen

EarlFred
10.03.2009, 13:49
Hallo swordbreacker ,

schau mal nach dem Befehl SVERWEIS.

Beispiel:
=SVERWEIS(A1;[Mappe1]Tabelle1!$A$1:$B$5;2;0)

Es gibt auch abertausende Beispiele hier im Netz, da wirst Du sicher fündig und kannst die Formel auf Deine Bedürfnisse anpassen.

Grüße
EarlFred

swordbreacker
10.03.2009, 14:03
Ja genau so was hab ich gesucht danke!

Monty Burns
10.03.2009, 14:10
Hallo swordbreaker

Hier mal eine kleine Lösung...
Sub InfoZusammentragen()

Dim zeile As Integer
Dim zeilemax As Integer
Dim i As Long
i = 1


With Worksheets("Tabelle1")
zeilemax = .UsedRange.Rows.Count
For zeile = 1 To zeilemax
If ThisWorkbook.Worksheets("Tabelle2").Cells(i, 2).Value <> 0 Then
ThisWorkbook.Worksheets("Tabelle3").Cells(i, 1).Value = ThisWorkbook.Worksheets("Tabelle1").Cells(zeile, 2).Value & ThisWorkbook.Worksheets("Tabelle2").Cells(i, 2).Value
End If
i = i + 1
Next zeile
End With

End Sub

'Hiermit kann man alle Werte aus Spalte B, Tabelle1 zusammen mit allen Werten in Spalte B, Tabelle2
'in Spalte A, Tabelle3 ausgeben.


Hoffe es hilft...

Gruß

- Monty Burns -