PDA

Vollständige Version anzeigen : Formelproblem / Vergleichen


TSteinringer
28.02.2008, 13:59
Liebe Leute!

Ich habe folgendes Problem (und mir fällt die Formel einfach nicht ein):

es gibt in einem dokument 2 tabellenblätter

1.
Kurse (Währung)
EUR 1,00
USD 0,66
usw.

2.
Werte
EUR 150.000
EUR 200.000
USD 100.000

Und ich suche jetzt nach einer formel die mir in jeder zeile von 2. neben den Wert den Umrechnungskurs auf EUR einträgt (wenns schon EUR ist dann 1,00 - aber das macht ohnehin die Tabelle aus 1.), damit ich weiterrechnen kann.

das geht doch irgendwie mit Summewenn oder so?

P.S.: Zieltabelle:
EUR 150.000 1,00
EUR 200.000 1,00
USD 100.000 0,66

myfake
28.02.2008, 14:17
Hi,

schau doch bitte mal, ob Dir das hier hilft:

<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:80px;" /><col style="width:80px;" /><col style="width:12px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td><td >E</td><td >F</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="font-weight:bold; ">Tabelle1</td><td >&nbsp;</td><td >&nbsp;</td><td style="font-weight:bold; ">Tabelle2</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td >EUR</td><td style="text-align:right; ">1,0000</td><td >&nbsp;</td><td >EUR</td><td style="text-align:right; ">150.000</td><td style="text-align:right; ">1,0000</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td >USD</td><td style="text-align:right; ">0,6600</td><td >&nbsp;</td><td >GBP</td><td style="text-align:right; ">100.000</td><td style="text-align:right; ">1,9862</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td >GBP</td><td style="text-align:right; ">1,9862</td><td >&nbsp;</td><td >USD</td><td style="text-align:right; ">50.000</td><td style="text-align:right; ">0,6600</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >F2</td><td >=SVERWEIS(D2;$A$2:$B$4;2;FALSCH)</td></tr><tr><td >F3</td><td >=SVERWEIS(D3;$A$2:$B$4;2;FALSCH)</td></tr><tr><td >F4</td><td >=SVERWEIS(D4;$A$2:$B$4;2;FALSCH)</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

Nur ein kleiner Hinweis: es ist durchaus möglich, dass eine Umrechnug gleich in eine Formel gepackt wird (Dir also den EUR Gegenwert ausgegeben wird)

cu
myfake

IngGi
28.02.2008, 14:19
Hallo TSteinringer,

ich nehme mal an, die Währungseinheiten stehen in einer eigenen Spalte:
<table><tr style="vertical-align:top; text-align:center; "><tr><td>&nbsp;</td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 ><col width=79.999998 ><col width=79.999998 ><col width=79.999998 ></colgroup><tr style="background-color:#cacaca; text-align:center;font-size:8pt; "><td>&nbsp;</td><td>A</td><td>B</td><td>C</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="font-size:9pt; ">EUR</td><td style="text-align:right; ">150.000</td><td style="text-align:right; ">1,00</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="font-size:9pt; ">EUR</td><td style="text-align:right; ">200.000</td><td style="text-align:right; ">1,00</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="font-size:9pt; ">USD</td><td style="text-align:right; ">100.000</td><td style="text-align:right; ">0,66</td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#FFFCF9; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">C1 : =SVERWEIS($A1;Tabelle1!$A$1:$B$2;2;0)<br>C2 : =SVERWEIS($A2;Tabelle1!$A$1:$B$2;2;0)<br>C3 : =SVERWEIS($A3;Tabelle1!$A$1:$B$2;2;0)<br></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table>Gruß Ingolf

TSteinringer
28.02.2008, 14:32
perfekt; danke vielmals