PDA

Vollständige Version anzeigen : englische in deutsche Notation umstellen?


elbonito
27.02.2008, 13:17
Hi Zusammen,

ich habe eine große Tabelle, die Zahlen in englischer Notation enthält. Somit ist das 1000er Trennzeichen ein Komma und kein Punkt. Folglich lässt sich damit auch nicht korrekt rechnen. Das Problem ebenso bei dieser Notation ist, dass 0en bei über 3-stelligen Zahlen nicht dargestellt werden. Bsp.: 1,28 wäre im Deutschen eine 1.280
Wisst Ihr, wie ich die Notationen einfach wechseln kann, ohne dass aus einer 1.280 (1,28) eine 128 wird (wie beim Ersetzen von , auf .)?
Danke euch!

chris-kaiser
27.02.2008, 13:39
hiho

hilft es vielleicht wenn Du bevor Du diese Liste öffnest in Excel
Extras-Optionen -> International -> Trennzeichen von Betriebssystem übernehmen weghakst

dazu müsstest Du aber die Orginalmappe haben .

elbonito
27.02.2008, 13:49
Leider funktioniert das nicht. :-(
Was meinst Du mit Originalmappe? Ich ziehe das Excel-File von einem Server im Internet und speicher sie lokal ab.

chris-kaiser
27.02.2008, 14:02
hi

hake das mal weg, und importiere danach die Daten
geht das auch nicht?

elbonito
27.02.2008, 14:10
Auch das funktioniert leider nicht! :(

chris-kaiser
27.02.2008, 14:24
hiho

eine Möglickeit wäre noch im Imoprtassistenen bei Schritt
3 das Format bekanntzugeben, zum Bsp. als Text
und dachach müsste das ersetzen funktionieren.

ansonsten keine Idee sry,

elbonito
27.02.2008, 14:35
Ich importiere die Datei nicht.
Ich klicke lediglich "öffnen" oder "speichern" an und er öffnet bzw. speichert das file!

chris-kaiser
27.02.2008, 14:38
hiho

deshalb wird es so nicht gehen

da müsste die Systemsteurung auf eng. Einheit umgestellt werden

magie61
27.02.2008, 14:40
Hallo elbonito,

welches Format hat deine Zahlenspalte nach dem Öffnen in Excel?
Wenn sie als Text vorliegt, versuche doch mal Folgendes:
- Spalte markieren -> Daten -> Text in Spalten
- im 3. Schritt auf Weitere klicken und das Dezimalzeichen und Tausendertrennzeichen umstellen
- danach noch die Spalte auf genügend Nachkommastellen formatieren.

Hilft dir das weiter?
Gruß
magie61

elbonito
27.02.2008, 15:16
@chris-kaiser: die gute Nachricht ist, dass damit Kommas durch Punkte ersetzt werden; die schlechte Nachricht ist allerdings, dass die 0en am Ende immer noch fehlen

@magie61: die Zahlen sind leider nicht als Texte formatiert

oh man....

chris-kaiser
27.02.2008, 15:29
hiho

wenn diese Zahlen nun als Text vorliegen

Bearbeiten erstzen , durch nichts
.Bearbeiten ersetzen -> . durch ,

danach spalte markieren -> format Zahl

Daten -> Text in Spalten -> fertigstellen

bei mir geht es so

p.s
sind die Daten aus dem Internet öffentlich
wenn ja poste das URL
dann würde ich es mit diesen Daten versuchen

jinx
27.02.2008, 17:15
<font size="2" face="Century Gothic">Moin, elbonito,

ganz off-topic: Email-Anforderung an www.ms-office-forum.net (http://www.ms-office-forum.net/forum/register.php?do=requestemail&email=) oder Email-Anforderung an ms-office-forum.net (http://ms-office-forum.net/forum/register.php?do=requestemail&email=) zur Anforderung einer erneuten Bestätigung vom Forum, dann steht Dir wieder die Möglichkeit offen, Anhänge zu erstellen oder anzusehen bzw. herunterzuladen. Und die foreneigene Suche funktioniert auch wieder. ;)</font>

elbonito
28.02.2008, 07:27
@chris-kaiser: Leider werden die 0en am Ende immer noch gekappt.
Hier mal die Datei (ist nicht frei verfügbar und hab sie deswegen umgeändert):

Danke sehr!!!

IngGi
28.02.2008, 09:29
Hallo elbonito,

folgende Vorgehensweise hat bei mir funktioniert:

1. Den Wert 1000 in eine leere Zelle schreiben und von dort in die Zwischenablage kopieren.
2. Datenbereich ohne Vorspalte und Tabellenkopf markieren.
3. Bearbeiten | Ersetzen | "," durch "G"
4. Bearbeiten | GeheZu | Inhalte | Konstanten | nur Option "Text" aktivieren
5. Bearbeiten | Ersetzen | "G" durch ","
6. Bearbeiten | Inhalte einfügen | Optionen "Werte" und "Multiplizieren" aktivieren
7. Den Wert 1000 wieder löschen

Gruß Ingolf

elbonito
28.02.2008, 10:39
RIIIIEEEESIG!!! :)
Vielen Dank an Euch alle!