PDA

Vollständige Version anzeigen : Finden


Alfred Jodokus Quak
27.02.2008, 06:35
hallo leute,

ich benötige bitte hilfe. ich habe in der spalte a folgende daten gegeben:

654564 (+43) rertfdstfg
(+49) retertth grtztrft
54546411 (+430) etert 6567
rtzre dzgrtz drgzrdg *
54635432 jzujzgfhj(+66)

Ich möchte aber, dass in Spalte B nur die daten, die in der Klammer stehen, ausgegeben werden.

Ich habe diese formel verwendet:

=TEIL(A1;FINDEN("+";A1);FINDEN(")";A1)-FINDEN("(";A1)-1)

Es funktioniert auch, aber ich möchte auch dass er "nichts" ausgibt wenn eine zelle keine klammer erhält.

Vielleicht kann mir ja jemand helfen

danke, mfg

Mac4
27.02.2008, 08:57
Moin,

versuchs mal so:

=WENN(SUMME(ISTZAHL(FINDEN({"+"."(".")"};A1))*1)>0;TEIL(A1;FINDEN("+";A1);FINDEN(")";A1)-FINDEN("(";A1)-1);"")

chri
27.02.2008, 09:10
Es hat geklappt!!

danke