PDA

Vollständige Version anzeigen : WENN mit SVERWEIS vereinfachen?


MarkusAusMS
26.02.2008, 07:59
Guten Morgen,

habe eine Formel, welche ich ca. 8000x einsetzen muss. Würde daher den Rechenaufwand gerne so gering wie möglich halten. So sieht die Formel aus und funktioniert:

=WENN(
ISTNV(SVERWEIS($A2;Tabelle6!A:B;2;FALSCH));
"0";
WENN(SVERWEIS($A2;Tabelle6!A:B;2;FALSCH)<0;
SVERWEIS($A2;Tabelle6!A:B;2;FALSCH)*(-1);
""
))

Kann man das vereinfachen?

LG
Maik

Woody
26.02.2008, 09:04
Moin Mark,

zunächst: die Formel ließe sich zwar optisch kürzen (statt FALSCH verwende 0), würde aber nicht schneller werden.

Die Verwendung von 3 SVERWEIS Funktionen mag die Performance drücken. Abhilfe wäre die Verwendung einer Hilfsspalte mit nur einer SVERWEIS Funktion und anschließender Interpretation des Ergebnisses.

Also: in einer Zelle B2: +SVERWEIS($A2;Tabelle6!A:B;2;0) und in einer Nachbarzelle +WENN(ISTNV(B2);0;WENN(B2<0;-B2;""))

chris-kaiser
26.02.2008, 09:24
hiho

hier auch noch eine Variante
=WENN(ZÄHLENWENN(Tabelle6!A:B;$A2);WENN(SVERWEIS($A2;Tabelle6!A:B;2;)<0;-SVERWEIS($A2;Tabelle6!A:B;2;);"");0)

wird zwar fast selbe Rechenleistung erfprdern ist aber um 32 Zeichen kürzer

MarkusAusMS
26.02.2008, 11:00
32 Zeichen kürzer bei einer Verwendung von 8000x sind immerhin 256000 Zeichen gespart. THX :-)