PDA

Vollständige Version anzeigen : Monatsnamen aus Zahl


Dominik^^
25.02.2008, 15:26
Hallo,

Ich habe in einem Shett eine Zahl (1-12), die das Monat darstellt. Außerdem habe ich noch Tabellenblätter, die Jänner, Februar, .... heißen!

Ich will jetzt aus der Zahl den Monatsnamen haben! Ich weiß schon dass ioch das kann mit dem Format, aber dann kann ich nicht vergleichen!!!!!

Weiß wer, wie ich das noch umwandeln kann????


Lg,
Dominik

EarlFred
25.02.2008, 15:36
Hallo Dominik,

tja, das Format wär auch meine erste Idee gewesen ;)

Aber es ginge auch so:


=WAHL(A1;"Januar";"Februar";"März";"April";"Mai";"Juni";"Juli";"August";"September";"Oktober";"November";"Dezember")


Der Monat als Zahl von 1 - 12 steht dabei in Zelle A1.

Grüße
EarlFred

M@x
25.02.2008, 16:02
Hi,
andere Variante
=TEXT(DATUM(;A1;1);"MMMM")
Zum Abfangen der Fehlermeldung, wenn in A1 nix drinn steht
=WENN(A1="";"";TEXT(DATUM(;A1;1);"MMMM"))

Dominik^^
26.02.2008, 08:18
Supi Danke!

nögg
01.05.2008, 13:37
Hallo miteinander

Ich muss diese Formel auch in VBA haben. Kann mir jemand helfen?
Vielen Dank.

Grüsse
Bruno

jinx
01.05.2008, 14:27
<font size="2" face="Century Gothic">Moin, Bruno,

Formel eintragen, Makro-Rekorder starten. F2 in der Formelzelle, Aufzeichnung beenden, Code ansehen...

Zahl steht in Zelle A1 der aktiven Tabelle
If [A1] > 0 And [A1] < 13 Then
MsgBox Format(DateSerial(Year(Date), [A1], 1), "MMMM")
End If</font>

nögg
01.05.2008, 14:57
Hallo jinx

Besten Dank für deine Antwort. Ich habe noch weitergesucht und die MonthName-Funktion gefunden:
mit
MsgBox MonthName([A1])
erhalte ich auch meinen gewünschten Wert.

Viele Grüsse
Bruno

jinx
01.05.2008, 16:09
<font size="2" face="Century Gothic">Moin, Bruno,

stimmt, steht ab Excel2000 zur Verfügung - mein Vorgehen ohne Überprüfung der Werte würde der Zahl 0 Dezember und der 14 Februar zuordnen, aber keinen Laufzeitfehler (wie das bei MonthName und einem Wert unter 1 und über 12 der Fall ist)... ;)</font>