PDA

Vollständige Version anzeigen : Wie bekommt man Tabellennamen in Formeln?


schmusibu
21.02.2008, 10:20
Werte mit Hilfe des Tabellennamens in verschiedenen Formeln übernehmen ??

Aufgabe

Verschiedene Tabellen ( mit unterschiedlichen Namen )sollen ausgewertet werden.

z.B.
In Tabelle1 stehen die Tabellennamen der Arbeitsmappe in der 1.Zeile nebeneinander in Zelle A1 (z.B.Tabelle2) und in B2 (z.B.Tabelle3) usw.

Darunter kommen verschiedene Formeln zur Auswertung, die alle Bezug auf die in der ersten Zeile genante Tabelle nehmen sollen.

Noch mal die Frage,

Wie bekommt man den Tabellennamen aus der ersten Zeile in die Formeln?


A1 Tabell1 B1 Tabell2

=VERGLEICH(AP2;Tabell1!$A$1:$EE$1;0)
=WENN(ISTFEHLER(SVERWEIS($A808;Tabell1!$A$3:$EE$5000;AP$12;0));;SVERWEIS($A808;T abell1!$A$3:$EE$5000;AP$12;0))


Wie stelle ich den Verweis innerhalb der Formel auf A1 (Tebelle1) oder B1 (Tebelle2) her.

Mit Dank im voraus.

Mit freundlichen Grüßen
sb

jinx
21.02.2008, 10:25
Moin, sb,

entweder durch die Verwendung der Funktion INDIREKT oder aber analog zu Erzeugung eines Verweises über mehrere Tabellen (http://www.excelformeln.de/formeln.html?welcher=233) (nur bei Zahlen).

Woody
21.02.2008, 10:31
Hallo,

hier ein Muster, wenn Tabelle1 in Zelle A1 steht

=WENN(ISTFEHLER(SVERWEIS($A808;INDIREKT(A1&"!$A$3:$EE$5000");AP$12;0));;SVERWEIS($A808;INDIREKT(A1&"!$A$3:$EE$5000");AP$12;0))

schmusibu
21.02.2008, 11:04
Jippi Juchu
Perfekt
Tag gerettet
usw

Manchmal .....

=WENN(ISTFEHLER(SVERWEIS($A17;INDIREKT(A$1&"!$A$3:$EE$5000");A$12;0));;SVERWEIS($A17;INDIREKT(A$1&"!$A$3:$EE$5000");A$12;0))

funst

Dank

mfg
sb