PDA

Vollständige Version anzeigen : #NV Fehler je Mitarbeiter zählen


ixilon
20.02.2008, 14:16
Hallo zusammen,

ich habe ein kleines Problem.
Ich erstelle derzeit eine Mitarbeiterauswertung und lasse dort verschiedene Daten ( Auftrageber + Dienstleister ) abgleichen.

Jetzt möchte ich gerne die #NV´s zu jedem Mitarbeiter zählen.
In der Spalte E sind die gefundenen Daten sowie die #NV´s.
In der Spalte F sind die gefundenen Namen zu den Datensätzen
In die Spalte K soll das Ergebnis/Anzahl geschrieben werden.
In der Spalte J stehen die Namen der Mitarbeiter.

Im Anhang sende ich Euch mal ein Bild von dieser Tabelle.


Für jede Hilfe bin ich froh und dankbar.

Herzliche Grüße,
Markus

jinx
20.02.2008, 14:20
<font size="2" face="Century Gothic">Moin, Markus,

wenn SummeWenn nicht funktioniert, mit Summenprodukt und IstFehler arbeiten - siehe Summewenn Zählenwenn mit zwei oder mehr Kriterien (http://www.ms-office-forum.net/forum/showthread.php?t=148535).</font>

Crady
20.02.2008, 15:56
Hi,

Habe mich zwar schon lang nicht mit Excel beschäftigt, aber spontan würde einfach die nicht #NVs zusammenzählen und die von der Gesammtzeilenzahl abziehen...

ixilon
20.02.2008, 16:02
Hi,
dann habe ich aber nur die Gesamtsumme der #NV aber nicht je Mitarbeiter.
Danke dennoch für diesen Tip

ixilon
20.02.2008, 16:03
@jinx

Vielen Dank für deine Hilfe.
Leider verstehe ich nicht ganz wie man diese Daten pro Mitarbeiter zählen lässt. Hab ich was übersehen oder denke ich einfach falsch heute :-))


Lg,
Markus

Crady
20.02.2008, 16:20
Hm, ok... da hast Du recht...

Habe wohl die Frage nur überflogen... Wie wäre es denn, wenn Du mittels Wenn Formel die Abfrage so änderst, dass statt einem #NV eben eine 0 oder irgend was anderes kommt (Formatierung dann weiß und keiner sieht es)... Das kannst Du dann zählen...

Wie wird denn Spalte E berechnet? (Formel) Und wie sieht die Datensatzherkunkt aus? Wird die auch berechnet oder werden die Daten da nur eingegeben?

jinx
20.02.2008, 16:23
<font size="2" face="Century Gothic">Moin, Markus,

<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td><td >E</td><td >F</td><td >G</td><td >H</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="text-align:right; ">14525</td><td >&nbsp;</td><td >M&uuml;ller</td><td >&nbsp;</td><td style="font-weight:bold; ">M&uuml;ller</td><td style="text-align:right; ">7</td><td style="text-align:right; ">2</td><td style="text-align:right; ">2</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="text-align:right; ">13430</td><td >&nbsp;</td><td >Meier</td><td >&nbsp;</td><td style="font-weight:bold; ">Meier</td><td style="text-align:right; ">7</td><td style="text-align:right; ">4</td><td style="text-align:right; ">4</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td >#NV</td><td style="text-align:right; ">1</td><td >Schmidt</td><td >&nbsp;</td><td style="font-weight:bold; ">Schmidt</td><td style="text-align:right; ">6</td><td style="text-align:right; ">2</td><td style="text-align:right; ">2</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="text-align:right; ">49651</td><td >&nbsp;</td><td >M&uuml;ller</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td >#NV</td><td style="text-align:right; ">1</td><td >Meier</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="text-align:right; ">85724</td><td >&nbsp;</td><td >Schmidt</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td style="text-align:right; ">50642</td><td >&nbsp;</td><td >M&uuml;ller</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td >#NV</td><td style="text-align:right; ">1</td><td >Meier</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td style="text-align:right; ">83465</td><td >&nbsp;</td><td >Schmidt</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td >#NV</td><td style="text-align:right; ">1</td><td >M&uuml;ller</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >11</td><td style="text-align:right; ">62041</td><td >&nbsp;</td><td >Meier</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >12</td><td >#NV</td><td style="text-align:right; ">1</td><td >Schmidt</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >13</td><td style="text-align:right; ">85132</td><td >&nbsp;</td><td >M&uuml;ller</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >14</td><td >#NV</td><td style="text-align:right; ">1</td><td >Meier</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >15</td><td style="text-align:right; ">32124</td><td >&nbsp;</td><td >Schmidt</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >16</td><td style="text-align:right; ">52063</td><td >&nbsp;</td><td >M&uuml;ller</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >17</td><td >#NV</td><td style="text-align:right; ">1</td><td >Meier</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >18</td><td style="text-align:right; ">83648</td><td >&nbsp;</td><td >Schmidt</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >19</td><td >#NV</td><td style="text-align:right; ">1</td><td >M&uuml;ller</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >20</td><td style="text-align:right; ">19546</td><td >&nbsp;</td><td >Meier</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >B1</td><td >=WENN(ISTNV<span style=' color:008000; '>(A1)</span>;1;"")</td></tr><tr><td >F1</td><td >=Z&Auml;HLENWENN($C$1:$C$20;$E1)</td></tr><tr><td >G1</td><td >=SUMMENPRODUKT(<span style=' color:008000; '>(<span style=' color:#0000ff; '>($C$1:$C$20)</span>=$E1)</span>*<span style=' color:008000; '>(ISTNV<span style=' color:#0000ff; '>($A$1:$A$20)</span>)</span>)</td></tr><tr><td >H1</td><td >=SUMMEWENN($C$1:$C$20;$E1;$B$1:$B$20)</td></tr><tr><td >B2</td><td >=WENN(ISTNV<span style=' color:008000; '>(A2)</span>;1;"")</td></tr><tr><td >F2</td><td >=Z&Auml;HLENWENN($C$1:$C$20;$E2)</td></tr><tr><td >G2</td><td >=SUMMENPRODUKT(<span style=' color:008000; '>(<span style=' color:#0000ff; '>($C$1:$C$20)</span>=$E2)</span>*<span style=' color:008000; '>(ISTNV<span style=' color:#0000ff; '>($A$1:$A$20)</span>)</span>)</td></tr><tr><td >H2</td><td >=SUMMEWENN($C$1:$C$20;$E2;$B$1:$B$20)</td></tr><tr><td >A3</td><td >=FEHLER.TYP(7)</td></tr><tr><td >B3</td><td >=WENN(ISTNV<span style=' color:008000; '>(A3)</span>;1;"")</td></tr><tr><td >F3</td><td >=Z&Auml;HLENWENN($C$1:$C$20;$E3)</td></tr><tr><td >G3</td><td >=SUMMENPRODUKT(<span style=' color:008000; '>(<span style=' color:#0000ff; '>($C$1:$C$20)</span>=$E3)</span>*<span style=' color:008000; '>(ISTNV<span style=' color:#0000ff; '>($A$1:$A$20)</span>)</span>)</td></tr><tr><td >H3</td><td >=SUMMEWENN($C$1:$C$20;$E3;$B$1:$B$20)</td></tr><tr><td >B4</td><td >=WENN(ISTNV<span style=' color:008000; '>(A4)</span>;1;"")</td></tr><tr><td >A5</td><td >=FEHLER.TYP(7)</td></tr><tr><td >B5</td><td >=WENN(ISTNV<span style=' color:008000; '>(A5)</span>;1;"")</td></tr><tr><td >B6</td><td >=WENN(ISTNV<span style=' color:008000; '>(A6)</span>;1;"")</td></tr><tr><td >B7</td><td >=WENN(ISTNV<span style=' color:008000; '>(A7)</span>;1;"")</td></tr><tr><td >A8</td><td >=FEHLER.TYP(7)</td></tr><tr><td >B8</td><td >=WENN(ISTNV<span style=' color:008000; '>(A8)</span>;1;"")</td></tr><tr><td >B9</td><td >=WENN(ISTNV<span style=' color:008000; '>(A9)</span>;1;"")</td></tr><tr><td >A10</td><td >=FEHLER.TYP(7)</td></tr><tr><td >B10</td><td >=WENN(ISTNV<span style=' color:008000; '>(A10)</span>;1;"")</td></tr><tr><td >B11</td><td >=WENN(ISTNV<span style=' color:008000; '>(A11)</span>;1;"")</td></tr><tr><td >A12</td><td >=FEHLER.TYP(7)</td></tr><tr><td >B12</td><td >=WENN(ISTNV<span style=' color:008000; '>(A12)</span>;1;"")</td></tr><tr><td >B13</td><td >=WENN(ISTNV<span style=' color:008000; '>(A13)</span>;1;"")</td></tr><tr><td >A14</td><td >=FEHLER.TYP(7)</td></tr><tr><td >B14</td><td >=WENN(ISTNV<span style=' color:008000; '>(A14)</span>;1;"")</td></tr><tr><td >B15</td><td >=WENN(ISTNV<span style=' color:008000; '>(A15)</span>;1;"")</td></tr><tr><td >B16</td><td >=WENN(ISTNV<span style=' color:008000; '>(A16)</span>;1;"")</td></tr><tr><td >A17</td><td >=FEHLER.TYP(7)</td></tr><tr><td >B17</td><td >=WENN(ISTNV<span style=' color:008000; '>(A17)</span>;1;"")</td></tr><tr><td >B18</td><td >=WENN(ISTNV<span style=' color:008000; '>(A18)</span>;1;"")</td></tr><tr><td >A19</td><td >=FEHLER.TYP(7)</td></tr><tr><td >B19</td><td >=WENN(ISTNV<span style=' color:008000; '>(A19)</span>;1;"")</td></tr><tr><td >B20</td><td >=WENN(ISTNV<span style=' color:008000; '>(A20)</span>;1;"")</td></tr></table></td></tr></table> <br /><br /></font>

IngGi
20.02.2008, 16:25
Hallo Markus,

hast du auf den Link von jinx geklickt?

Schau dir das mal an:
<table><tr style="vertical-align:top; text-align:center; "><tr><td>&nbsp;</td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 ><col width=79.999998 ><col width=79.999998 ></colgroup><tr style="background-color:#cacaca; text-align:center;font-size:8pt; "><td>&nbsp;</td><td>A</td><td>B</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="text-align:right; ">1</td><td style="">Hans</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="">#NV</td><td style="">Hans</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="text-align:right; ">3</td><td style="">Hans</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="">#NV</td><td style="">Hans</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="text-align:right; ">5</td><td style="">Hans</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="">#NV</td><td style="">Peter</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td style="text-align:right; ">7</td><td style="">Peter</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td style="text-align:right; ">8</td><td style="">Peter</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td style="">#NV</td><td style="">Peter</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td style="">#NV</td><td style="">Peter</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >11</td><td style="">&nbsp;</td><td style="">&nbsp;</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >12</td><td style="">Hans</td><td style="text-align:right; ">2</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >13</td><td style="">Peter</td><td style="text-align:right; ">3</td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#FFFCF9; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">B12 : =SUMMENPRODUKT((ISTNV($A$1:$A$10))*($B$1:$B$10=$A12))<br>B13 : =SUMMENPRODUKT((ISTNV($A$1:$A$10))*($B$1:$B$10=$A13))<br></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table>Gruß Ingolf

ixilon
20.02.2008, 16:43
Leider habe ich jetzt keine Berechtigung mehr Dateien zu öffnen.
Kannst Du mir sagen warum??


Aber VIELEN VIELEN VIELEN DANK für deine Hilfe.
Echt Klasse von Dir.


Lieben Gruß,
Markus

jinx
20.02.2008, 16:47
<font size="2" face="Century Gothic">Moin, Markus,

möglicherweise hast Du Deine email-Adresse gewechselt - Email-Anforderung an www.ms-office-forum.net (http://www.ms-office-forum.net/forum/register.php?do=requestemail&email=) oder Email-Anforderung an ms-office-forum.net (http://ms-office-forum.net/forum/register.php?do=requestemail&email=) sollten bei der erneuten Übersendung der Bestätigung helfen...</font>

ixilon
20.02.2008, 16:56
stimmt daran hat es gelegen.
Man sollte auch mal seine Emails lesen :-))