PDA

Vollständige Version anzeigen : Beziehungsprobleme im FE


Tikey
18.01.2008, 12:04
Hallo !

und nein, mit meiner Frau läuft alles bestens ;)

Nur mit Access nicht.....

ich habe meine Datenbank in BE und Master- FE aufgeteilt.
Das Problem ist das im BE die Beziehungen vorhanden sind und angezeigt werden, im Master- FE allerdings nicht. Wenn ich im Master -FE eine Abfrage starten will bekomme ich die Fehlermeldung das keine Beziehungen zwischen den Tabellen bestehen würden.

was meint ihr...was läuft da falsch?

Grüße
Thomas

Gunter Avenius
18.01.2008, 12:06
Hallo,

Setze die Beziehungen im Frontend nicht im Backend.

Josef P.
18.01.2008, 12:37
Jetzt müssten wir nur noch klären, was unter Beziehungen zu verstehen ist. ;)

Ins Backend gehörten die Beziehungen im Sinne der referentiellen Integrität.
Im FE werden Verknüpfungen zw. Tabellen in Abfragen genutzt. :)

Tikey
21.01.2008, 07:11
Hallo Gunter und Josef,

ehrlich gesagt verstehe ich eure Tips nicht wirklich. Wo ist denn jetzt da der Unterschied zwischen Refereziellen Verknüpfungen und Verknüpfungen ?
Was ich meinte waren die Verknüpfungen unter Extras/Beziehungen im Access Menü. Das geht doch nur dort ?

Als die Datenbank in BE/FE Aufgeteilt wurde sind die Tabellen, also auch die Beziehungen, im BE gelandet und im FE die Abfragen, Formulare, Makro´s usw. Das klappte auch soweit.

Nun haben wir die Schwierigkeit die Datenbank zu erweitern.
Wir erstellen mit einer, nicht aufgeteilten,lokal gespeicherten Kopie der Datenbank neue Tabellen, Abfragen und Formulare und wollen sie dann in die richtige Datenbank importieren.
Tabellen und Formulare ließen sich auch anstandslos importieren, mit den Abfragen gab es scheinbar Rechteschwierigkeiten. Also habe ich mir gedacht, erstellst du die zwei Abfragen halt von hand, wobei dann obige Fehlermeldung mit den fehlenden Beziehungen kam.

Tikey
21.01.2008, 08:18
Sorry, ist mir grad heiss eingefallen. Also das häkchen für "Referenzielle Integrität" haben wir bisher erfolgreich ignoriert ;) Haben meist nur darauf geachtet das es eine saubere 1:1 oder 1:n Beziehung ist.
Kam also noch nicht zum einsatz. Hoffe nicht das das schon ein fehler war......