PDA

Vollständige Version anzeigen : Bildlaufleisten-Problem


krampi
01.10.2007, 10:13
Hallo Gemeinde, habe wieder eine Frage.

Ich habe ein Arbeitsblatt "Einstellung" erstellt. Nun wollte ich folgendes erreichen. Man sieht oben in G5 eine Zahl (2,0345). Wenn ich nun die Schieberegler bewege, so möchte ich, dass ich diese verteilen kann (in G6, G8 und G10). Wenn ich also bei der unteren Bildlaufleiste alles so verschoben habe, dass ich 100% erreiche, so dürften die anderen Bildlaufleisten keine Veränderung hervorrufen, da die 2,0345 schon im Unteren "Luxuriös" verteilt sind.
Kann mir da wer helfen? Wäre euch sehr dankbar.
Grüße,
krampi

P.S.:
Inzwischen habe ich zwar etwas versucht, was aber leider immer fehlschlägt. Für jede Zeile habe ich einen Code wie diesen geschrieben:
=F6*(G5-G8-G10)/100
=F8*(G5-G10-G6)/100
=F10*(G5-G6-G8)/100

Dabei sind F6, F8 und F10 jeweils die Zellverknüpfungen. Bewirken soll es, dass man den jeweiligen Wert herausbekommt. (G5-G8-G10) soll bewirken, dass vorher nachgeschaut wird, wie viel vom jeweiligen 100%-Wert (2,0345) noch übrig sind. Wenn jemand versteht, was ich meine, bin ich froh ^^.

krampi
02.10.2007, 22:14
Entschuldigt für den Doppelpost. Aber gibt es denn gar keine Lösung?
Ist es nicht möglich, dass man drei "Bildlaufleisten" hat, die man regeln kann, aber wenn eine 100% hat, man keine weiteren 100% in einer anderen einstellen kann? Derzeit hab ich ja das Problem, dass die sich dann gegenseitig verhindern. :-(

jinx
03.10.2007, 06:12
<font size="2" face="Century Gothic">Moin, krampi,

Du könntest eventuell die Antwortbereitschaft durch einen Anhang erhöhen, aber ich würde wohl eher auf VBA für eine Lösung zurückgreifen. Dazu müsste ich allerdings noch wissen, ob nur bis zum weiter verfügbaren Wert geschoben werden darf oder ob auch der Bereich bis 100% für jede Leiste allein wieder möglich sein soll...</font>

krampi
03.10.2007, 12:02
Hallo Jinx,

habe mal was angehängt.

Es ist so gedacht, dass die "Schiebregler" bzw. "Bildlaufleisten" so verschiebbar sein sollen, dass der 100% Wert (2,0345 als Beispiel) nicht überschritten wird.
Hat also die Leiste B bereits 100% und somit 2,0345 erreicht, so soll entweder das weitere Verschieben in den Leisten A oder C verhindert werden oder sie können sich verschieben lassen, nur ohne Auswirkungen.

jinx
03.10.2007, 17:58
<font size="2" face="Century Gothic">Moin, Krampi,

die Mappe habe ich mir heruntergeladen, aber nach 3 Abstürzen mit Excel2002 und einem mit Excel2003 beim Bewegen des obersten rechten Schiebereglers ist mir bis jetzt nur klar, dass Du meiner Meinung nach die falschen Steuerelemente verwendest... Die Computer bleiben jetzt erst einmal eine Weile aus.

Ich kann nicht sagen, wann ich wieder zurück bin - ich werde mir die Mappe später noch einmal ansehen und mich melden (mein Vorschlag bezog sich auf die anderen, auch ActiveX-Controls genannten Steuerelemente, die mehrere Aktionen haben, mit und auf die sie "reagieren" können).</font>

jinx
03.10.2007, 19:05
<font size="2" face="Century Gothic">Moin, Krampi,

nach wie vor bekomme ich beim Bewegen der Elemente wunderschlne Abstürze von Excel, aber eine Lösung kann auch ohne VBA genutzt werden:<table><tr style="vertical-align:top; text-align:center; "><tr><td>Tabelle1</td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 style="font-weight:bold; "><col width=79.999998 ><col width=79.999998 ><col width=79.999998 ></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td>&nbsp;</td><td>A</td><td>B</td><td>C</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="text-align:right; ">150</td><td style="">&nbsp;</td><td style="">&nbsp;</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="text-align:right; ">150</td><td style="text-align:right; ">0,66666667</td><td style="">&nbsp;</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="">&nbsp;</td><td style="">&nbsp;</td><td style="">&nbsp;</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="text-align:right; ">75</td><td style="text-align:right; ">50</td><td style="text-align:right; ">50</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="text-align:right; ">75</td><td style="text-align:right; ">50</td><td style="text-align:right; ">50</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="text-align:right; ">0</td><td style="text-align:right; ">0</td><td style="text-align:right; ">0</td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#FFFCF9; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">A1 : =SUMME(A4:A6)<br>A2 : =A4+A5+A6<br>B2 : =WENN(A2&lt;100;A2;100/A2)<br>B4 : =WENN($A$2&lt;100;A4;ABRUNDEN<span style=' color:008000; '>(A4*$B$2;0)</span>)<br>C4 : =WENN($A$2&lt;100;A4;ABRUNDEN<span style=' color:008000; '>(A4*$B$2;0)</span>)<br>B5 : =WENN($A$2&lt;100;A5;ABRUNDEN<span style=' color:008000; '>(A5*$B$2;0)</span>)<br>C5 : =WENN($A$2&lt;100;A5;ABRUNDEN<span style=' color:008000; '>(A5*$B$2;0)</span>)<br>B6 : =WENN($A$2&lt;100;A6;ABRUNDEN<span style=' color:008000; '>(A6*$B$2;0)</span>)<br>C6 : =WENN($A$2&lt;100;A6;100-C5-C4)<br></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table>
Die Zellen A4 bis A6 stellen die verlinkten Zellen dar. Deren Werte werden entweder in A2 oder A1 addiert, in B2 erfolgt die Auswertung. Bis 100 werden die Werte übernommen, darüber wird 100 durch den erreichten Wert geteilt und dann in den Ergebniszellen B4 bis B6 abgerundet dargestellt. In der Spalte C ist dann auch eine Möglichkeit, auch bei 3 Schiebereglern mit vollem Ausschalg einmal 34 zu verteilen... ;)

Das mit der Programmierung lass ich lieber sein - das wird mir zu aufwendig... :grins:</font>