PDA

Vollständige Version anzeigen : Formelproblem


Eric Palm
22.06.2007, 13:28
Hallo Fachfrauen und Fachmänner,
ich habe in der Spalte Bezeichnungen von Artikeln stehen. Nun ist es so das ich die Stückzahlen der angelieferten Teile ermittel muss.
Beispiel:
Zelle B2 = Menülöffel / Zelle I2 = (Stückzahl) 1200 (...) = Spaltenüberschrift
Zelle B3 = 68-tlg. Menüset / Zelle I3 = 1500

Nun habe ich um die genaue anzahl an Teilen zu ermitteln mir in Spalte J den Zahlenwert aus B3 auslesen lassen.
=LINKS(B2;MAX(ISTZAHL(TEIL(B2;SPALTE(1:1);1)*1)*SPALTE(1:1)))*1
Ich hatte vor das wenn in der Spalte A keine Zahl zu finden ist mir direkt den Wert aus Spalte I ausgeben zu lassen.
=WENN(ISTFEHLER(LINKS($B3;MAX(ISTZAHL(TEIL($B3;SPALTE(2:2);1)*1)*SPALTE(2:2)))*1 );I3;(LINKS($B3;MAX(ISTZAHL(TEIL($B3;SPALTE(2:2);1)*1)*SPALTE(2:2)))*1))
Das funktioniert auch super gut. Mein anliegen ist es nun wenn doch in der Spalte A eine Zahl zu finden ist, soll der Wert aus Spalte A mit der Stückzahl aus Spalte I multipliziert werden ansonsten soll der Wert aus Spalte I in Spalte J geschrieben werden.
So wie ich mir das dachte geht es leider nicht:
=WENN(ISTFEHLER(LINKS($B3;MAX(ISTZAHL(TEIL($B3;SPALTE(2:2);1)*1)*SPALTE(2:2)))*1 );I3;(LINKS($B3;MAX(ISTZAHL(TEIL($B3;SPALTE(2:2);1)*1)*SPALTE(2:2)))*1))*I3
Kann mir jemand einen Tip geben?
Danke im voraus
Eric

sowosamma
22.06.2007, 13:41
das I3 muß muß in die wenn-dann-Formel, sonst multiplizierst Du den 1.Teil der wenn-dann (also I3) mit sich selbst. Also =WENN(ISTFEHLER(LINKS($B3;MAX(ISTZAHL(TEIL($B3;SPALTE(2:2);1)*1)*SPALTE(2:2)))*1 );I3;(LINKS($B3;MAX(ISTZAHL(TEIL($B3;SPALTE(2:2);1)*1)*SPALTE(2:2)))*1)*I3)

Eric Palm
22.06.2007, 18:45
Hallo Andi,
danke für Deine Hilfe.
Manchmal hat man einfach ein Brett vor dem Kopf. (Ich glaube das ich besonders oft davon betroffen bin)

Gruß
Eric