PDA

Vollständige Version anzeigen : Anzahl Werte aus Zelle auslesen (Komma)


Schnufi
17.07.2006, 07:42
Ich habe in merheren Zellen mehrere Werte, welche mit Komma unterteilt sind,

z.B. in der Zelle A1 sind die Werte 3, 5

Ich benötige die Anzahl Werte pro Zelle, in obigen Fall somit Anzahl 2

Wie kann die Zelle abfragen, so dass die Anzahl jeweils der Werte, welche mit Komma abgrenzt wird, gezählt wird ?

MRR
17.07.2006, 08:11
Formel in B1:
=SUMME((LÄNGE(A1)-LÄNGE(WECHSELN(A1;",";"")))/1)

Schnufi
17.07.2006, 08:24
Hallo Mathias

Danke für Dein Input. Nun, ich eher den VBA-Code. Hatte was noch vergessen in den verschiedenen Zellen gibt es unterschiedliche ANzahl Werte

z.B.

A1 1,3
A2 5
A3 1,2,3
A4 1,6

Die Total Anzahl der A1 bis A4 sind gefragt, also hier 8.

Dies versuche ich zu programieren. Kannst Du mir bitte helfen ?

Gruss, Roger

Schnufi
17.07.2006, 09:03
Hallo Mathias

Mit einer Hilfstabelle und Deinen Angaben konnte ich doch das Problem lösen.

Nun habe ich noch ein weiteres Problem mit den genannten Anzahl, welches Du mir sicherlich helfen kannst.

Ich benötige nun eine Auswertung der Anzahl nach Priorität A, B und C, also diese Zahlen sind nun in Prioritäten in der Spalte B aufgeteilt, welche ich auch noch auswerten muss.

Case Test

A1 1,3 B1 A
A2 5 B2 B
A3 1,2,3 B3 A
A4 1,6 B4 C

Case Test2

C1 1,4,5 B1 A
C2 5,3 B2 B
C3 1,2,3 B3 A
C4 1,6 B4 C

etc.

Auswertung sollte somit so sein

Case Prio Anzahl
Test 1 A 5
B 1
C 2

Test 2 A 7
B 2
C 2

irgendwie mit einem Sverweis oder so ?


Gruss, Roger