PDA

Vollständige Version anzeigen : Formel geht nicht


zipfu
13.07.2006, 20:36
Hallo, habe ein grosses Problehm mit folgender Formel:

=WENN(ODER(D13="fe";D13="f";D13="kr";D13="fx");0;)+WENN(ODER(D$2="Sa";D$2="So";$A$2=D$3;$A$3=D$3;$A$5=D$3;$A$6=D$3;$A$8=D$3;$A$9=D$3;$A$13=D$3;$A$14=D$3;$A$15 =D$3;$A$16=D$3;$A$17=D$3;$A$21=D$3);D15;0)+WENN(ODER($A$4=D$3;$A$7=D$3);D15/2;0)

Soweit geht alles gut, ausser dass folgender Teil nicht berücksichtigt wird.

WENN(ODER(D13="fe";D13="f";D13="kr";D13="fx");0;)

Der Wert sollte null ergeben was er nicht macht!
Wäre super wenn mir jemand von euch weiterhelfen könnte.

zipfu

myfake
13.07.2006, 20:42
Hallo zipfu,

Du vergibst hierin (wie auch in den anderen WENN Bedingungen) keine "Sonst" Anweisung.

Versuche es doch mal so:
WENN(ODER(D13="fe";D13="f";D13="kr";D13="fx");0;"")
-> oder irgendetwas anderes für die Anführungsstriche ;)

cu
myfake

zipfu
13.07.2006, 20:56
Hallo myfake

Erst mal danke für die schnelle Antwort. Leider geht es immer noch nicht.
Merke gerade, dass ich vermutlich irgend etwas nicht begriffen habe.
Wie funktioniert das mir der „Sonst“ Anweisung?

zipfu

myfake
13.07.2006, 21:01
Hallo zipfu,

na ja - Du sagst: Wenn in D13 "fe", "f", "kr" oder "fx" steht dann Null <- dann irgendwas ist die Anweisung nach dem ersten Semikolon, sonst .... <- und das steht dann hinter dem zweiten Semikolon.

Da diese "Anweisungskette" auch bei den anderen WENN-Anweisungen nicht stimmt, gehe ich mal davon aus, dass dort der Fehler liegt. Teste doch mal was passiert, wenn Du auch dort eine Anweisung eingibst (oder versuche mal zu beschreiben, was die Formel denn genau machen soll).

cu
myfake

zipfu
13.07.2006, 21:11
Hallo myfake

Danke für deine Hilfe.
Habe es folgendermassen hingekriegt

=WENN(ODER(E13="fe";E13="f";E13="kr";E13="fx");0;WENN(ODER(E$2="Sa";E$2="So";$A$2=E$3;$A$3=..........

Die werte stimmen nun, bin mir jedoch nicht sicher ob die Programmierung korrekt ist.

zipu

myfake
13.07.2006, 21:23
Hallo zipfu,

wenn die Werte raus kommen, die erwartet werden, dann sollte es doch stimmen ;)

Wenn Du dann auch noch die letzte WENN-Funktion komplettiert hast (bspw.: WENN(ODER($A$4=D$3;$A$7=D$3);D15/2;0;"") ) dann ist die Formel an sich korrekt. Ob die Formel an sich korrekt ist (also zum Problem paßt) kannst nur sagen. :)

cu
myfake

zipfu
13.07.2006, 22:08
myfake,
hat super hingehauen!

Danke!!!

zipfu