PDA

Vollständige Version anzeigen : Summe mehrerer Tabellen


F-B
10.07.2006, 17:13
Plane eine Bundesliga- Tipptabelle.
Ich habe noch das Problem, dass der Spieltagsieger einen Zusatzpunkt in der roten Zelle bekommen soll und wie ich- Tabelle für Tabelle- die Gesamtpunkte zählen kann.
Des weiteren soll natürlich niemand die Zahlen in den Tabellen ändern können (Blattschutz?)?!


Wäre für ein paar Anregungen dankbar (((-;

PS: Kann nicht zippen, daher wäre ein Kontakt über Fred.Brauer@ece.de zum Dateitausch hilfreich.

Freddy

jinx
10.07.2006, 17:18
<font size="2" face="Century Gothic">Moin, F-B,

da ich nicht weiß, was in den riten Zellen steht - die Suche mit dem Begriff Fußball hier im Excel-Forum hat nichts gebracht?</font>

F-B
10.07.2006, 17:59
Nein, leider hat wohl jeder ein anderes Problem (-:

Kann ich dir denn die Tabelle auf eine email- adresse senden und du schaust mal drüber??

Freddy

jinx
10.07.2006, 18:02
<font size="2" face="Century Gothic">Moin, Freddy,

wenn Du meinst, ich könne das Problem lösen (ich kann aber zippen, raren und gerührt sein ;) - jinx at ms-office-forum.net .</font>

F-B
10.07.2006, 18:12
Schön, dass du gerührt sein kannst. Ich werde behutsam mit dir umgehen :)
-habe gemailt.........

PS: Deutschland ist der geilste Club der Welt!!!

jinx
10.07.2006, 18:24
<font size="2" face="Century Gothic">Moin, Freddy,

auf Basis von Jede X-te Zeile addieren (http://www.excelformeln.de/formeln.html?welcher=86) ergibt sich folgender Ansatz für die erste Zeile:<table><tr style="vertical-align:top; text-align:center; "><tr><td>Tabelle1</td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 style="font-weight:bold; "><col width=23.9999994 ><col width=74.999998125 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=25.99999935 ><col width=25.99999935 ><col width=39.999999 ><col width=39.999999 ><col width=39.999999 ><col width=74.999998125 ></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td>&nbsp;</td><td>A</td><td>B</td><td>C</td><td>D</td><td>E</td><td>F</td><td>G</td><td>H</td><td>I</td><td>J</td><td>K</td><td>L</td><td>M</td><td>N</td><td>O</td><td>P</td><td>Q</td><td>R</td><td>S</td><td>T</td><td>U</td><td>V</td><td>W</td><td>X</td><td>Y</td><td>Z</td><td>AA</td><td>AB</td><td>AC</td><td>AD</td><td>AE</td><td>AF</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >13</td><td style="text-align:center; font-weight:bold; ">1</td><td style="font-size:8pt; text-align:center; font-weight:bold; ">Brauer</td><td style="text-align:center; ">3</td><td style="text-align:center; ">1</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">1</td><td style="text-align:center; ">2</td><td style="text-align:center; ">0</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">1</td><td style="text-align:center; ">1</td><td style="text-align:center; ">1</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">2</td><td style="text-align:center; ">0</td><td style="text-align:center; ">0</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">3</td><td style="text-align:center; ">1</td><td style="text-align:center; ">0</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">3</td><td style="text-align:center; ">2</td><td style="text-align:center; ">3</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">3</td><td style="text-align:center; ">3</td><td style="text-align:center; ">1</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">0</td><td style="text-align:center; ">1</td><td style="text-align:center; ">1</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">0</td><td style="text-align:center; ">0</td><td style="text-align:center; ">2</td><td style="background-color:#c0c0c0; text-align:center; font-weight:bold; ">0</td><td style="color:#0000ff; background-color:#ff6600; text-align:center; font-weight:bold; ">13</td><td style="">&nbsp;</td><td style="text-align:right; ">13</td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#FFFCF9; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">E13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(D13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(C45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(C45=C13;D45=D13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(C45-D45)</span>=<span style=' color:#804000; '>(C13-D13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(C45-D45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(C13-D13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>H13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(G13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(F45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(F45=F13;G45=G13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(F45-G45)</span>=<span style=' color:#804000; '>(F13-G13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(F45-G45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(F13-G13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>K13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(J13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(I45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(I45=I13;J45=J13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(I45-J45)</span>=<span style=' color:#804000; '>(I13-J13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(I45-J45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(I13-J13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>N13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(M13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(L45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(L45=L13;M45=M13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(L45-M45)</span>=<span style=' color:#804000; '>(L13-M13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(L45-M45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(L13-M13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>Q13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(P13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(O45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(O45=O13;P45=P13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(O45-P45)</span>=<span style=' color:#804000; '>(O13-P13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(O45-P45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(O13-P13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>T13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(S13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(R45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(R45=R13;S45=S13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(R45-S45)</span>=<span style=' color:#804000; '>(R13-S13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(R45-S45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(R13-S13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>W13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(V13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(U45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(U45=U13;V45=V13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(U45-V45)</span>=<span style=' color:#804000; '>(U13-V13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(U45-V45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(U13-V13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>Z13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(Y13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(X45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(X45=X13;Y45=Y13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(X45-Y45)</span>=<span style=' color:#804000; '>(X13-Y13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(X45-Y45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(X13-Y13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>AC13 : =WENN(ANZAHLLEEREZELLEN<span style=' color:008000; '>(AB13)</span>=1;0;WENN<span style=' color:008000; '>(ANZAHLLEEREZELLEN<span style=' color:#0000ff; '>(AA45)</span>=1;0;WENN<span style=' color:#0000ff; '>(UND<span style=' color:#ff0000; '>(AA45=AA13;AB45=AB13)</span>;3;WENN<span style=' color:#ff0000; '>(<span style=' color:#804000; '>(AA45-AB45)</span>=<span style=' color:#804000; '>(AA13-AB13)</span>;2;WENN<span style=' color:#804000; '>(<span style=' color:#FF7837; '>(VORZEICHEN<span style=' color:#8000ff; '>(AA45-AB45)</span>=VORZEICHEN<span style=' color:#8000ff; '>(AA13-AB13)</span>)</span>;1;0)</span>)</span>)</span>)</span>)<br>AD13 : =WENN(E13&lt;&gt;"-";E13;0)+WENN(H13&lt;&gt;"-";H13;0)+WENN(K13&lt;&gt;"-";K13;0)+WENN(N13&lt;&gt;"-";N13;0)+WENN(Q13&lt;&gt;"-";Q13;0)+WENN(T13&lt;&gt;"-";T13;0)+WENN(W13&lt;&gt;"-";W13;0)+WENN(Z13&lt;&gt;"-";Z13;0)+WENN(AC13&lt;&gt;"-";AC13;0)<br>AF13 : {=SUMME(E13:AC13*<span style=' color:008000; '>(REST<span style=' color:#0000ff; '>(SPALTE<span style=' color:#ff0000; '>(E13:AC13)</span>;3)</span>=2)</span>)}<br><br><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>Enth&auml;lt Matrixformel:</span><span style=' font-family:Arial,Arial; font-size:9pt;'><br />Umrandende </span><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>{ }</span><span style=' font-family:Arial,Arial; font-size:9pt;'> nicht miteingeben,<br />sondern Formel mit STRG+SHIFT+RETURN abschlie&szlig;en!</span></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table>

Für das Verständnis, was die Matrixformel macht, kannst Du Dir bitte einmal Anatomy of an Array Formula (Dick Kusleika) - Analyse des Ablaufs einer Matrixformel (http://www.ms-office-forum.net/forum/showthread.php?t=148538) ansehen...

Zusatz: Für die 3D-Summe (in der Beispielmappe nur von 1-31) kann Flexible Alternative zur Summierung über mehrere Tabellen (Ergänzung) (http://www.excelformeln.de/formeln.html?welcher=234) verwendet werden:<table><tr style="vertical-align:top; text-align:center; "><tr><td>Total</td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 style="font-weight:bold; "><col width=79.999998 ><col width=79.999998 ></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td>&nbsp;</td><td>A</td><td>B</td></tr><tr height=17 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="font-size:8pt; text-align:center; font-weight:bold; ">Brauer</td><td style="text-align:right; ">13</td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#FFFCF9; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">B1 : {=SUMME(SUMME<span style=' color:008000; '>(SUMMEWENN<span style=' color:#0000ff; '>(INDIREKT<span style=' color:#ff0000; '>("Tabelle"&ZEILE<span style=' color:#804000; '>(1:31)</span>&"!AD13")</span>;"&lt;1e+99")</span>)</span>)}<br><br><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>Enth&auml;lt Matrixformel:</span><span style=' font-family:Arial,Arial; font-size:9pt;'><br />Umrandende </span><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>{ }</span><span style=' font-family:Arial,Arial; font-size:9pt;'> nicht miteingeben,<br />sondern Formel mit STRG+SHIFT+RETURN abschlie&szlig;en!</span></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table> </font>

F-B
11.07.2006, 14:11
Super, vielen Dank. Jetzt die letzte Frage:
In der Spalte AD soll derjenige mit den meißten Punkten einen Zusatzpunkt bekommen. Allerdings nur wenn er alleine die meißten hat. Mit der Formel---------
=WENN(AD16=KGRÖSSTE(AD$13:AD$44;1);1;0)
------bekommen alle mit den meißten Punkten einen Extrapunkt. Dann soll aber keiner einen bekommen.
Geht das?
Freddy

jinx
11.07.2006, 19:53
<font size="2" face="Century Gothic">Moin, Freddy,

für den größten und kleinsten Wert Max bzw. Min nutzen und per Zählenwenn prüfen, wie häufig dieser vorkommt:<table><tr style="vertical-align:top; text-align:center; "><tr><td>Tabelle1</td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 style="font-weight:bold; "><col width=74.999998125 ><col width=74.999998125 ></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td>&nbsp;</td><td>AF</td><td>AG</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >13</td><td style="text-align:right; ">14</td><td style="text-align:right; ">1</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >14</td><td style="text-align:right; ">12</td><td style="text-align:right; ">0</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >15</td><td style="text-align:right; ">13</td><td style="text-align:right; ">0</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >16</td><td style="text-align:right; ">11</td><td style="text-align:right; ">0</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >17</td><td style="text-align:right; ">12</td><td style="text-align:right; ">0</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >18</td><td style="text-align:right; ">13</td><td style="text-align:right; ">0</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >19</td><td style="text-align:right; ">11</td><td style="text-align:right; ">0</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >20</td><td style="text-align:right; ">12</td><td style="text-align:right; ">0</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >21</td><td style="text-align:right; ">13</td><td style="text-align:right; ">0</td></tr><tr height=16 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >22</td><td style="text-align:right; ">11</td><td style="text-align:right; ">0</td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#FFFCF9; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">AG13 : =WENN(UND<span style=' color:008000; '>(AF13=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF13;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG14 : =WENN(UND<span style=' color:008000; '>(AF14=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF14;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG15 : =WENN(UND<span style=' color:008000; '>(AF15=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF15;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG16 : =WENN(UND<span style=' color:008000; '>(AF16=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF16;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG17 : =WENN(UND<span style=' color:008000; '>(AF17=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF17;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG18 : =WENN(UND<span style=' color:008000; '>(AF18=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF18;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG19 : =WENN(UND<span style=' color:008000; '>(AF19=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF19;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG20 : =WENN(UND<span style=' color:008000; '>(AF20=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF20;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG21 : =WENN(UND<span style=' color:008000; '>(AF21=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF21;$AF$13:$AF$44)</span>)</span>;1;0)<br>AG22 : =WENN(UND<span style=' color:008000; '>(AF22=MAX<span style=' color:#0000ff; '>(AF$13:AF$44)</span>;Z&Auml;HLENWENN<span style=' color:#0000ff; '>(AF22;$AF$13:$AF$44)</span>)</span>;1;0)<br></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table>
Eine Antwort im Beitrag reicht in aller Regel aus, eine Mail an mich führt eher dazu, dass mich das Problem nicht mehr interessiert... ;) So bin ich nun mal :grins: Und werktags tagsüber bin ich idR nicht im Forum vertreten.</font>

F-B
12.07.2006, 15:15
Okay- danke dir sehr und werde mich jetzt zurückhalten............grins