PDA

Vollständige Version anzeigen : Vergütungsberechnung mit Excel


AC/DC
06.07.2006, 19:37
Hallo Zusammen.

Bin gerade durch googlen auf Eure Seite aufmerksam gemacht worden und hoffe, dass ich hier Hilfe von Euch bekomme.

Bin leider kein Excel Profi, möchte aber mit Excel gerne eine Zeiterfassung mit gleichzeitiger Vergütungsberechnung nutzen.

Die Zeiterfassung habe ich schon so gelöst bekommen:
Datum / Arbeitszeit / Stunden / Vergütung
Montag, 3. Juli 2006 / 14:00-22:15 / 8,00 Std. / ???
WENN(D6>B6;D6-B6;(1-B6)+D6)*24-0,25

Nun aber zu meinem Problem:
Ich möchte mit Excel folgendes Berechnen:
In der Frühschicht von 6:00-14:15 soll Excel nur die Arbeitsstunden von
8 Std. mit dem Stundenlohn z. B.: 10 € Rechnen.

In der Spätschicht von 14:00-22:15 soll Excel die ersten 6 Std. oder besser gesagt bis 20:00 den Stundenlohn + 25% und ab 20:00 mit 50% Zuschlag Berechnen.

Und zuletzt die Nachtschicht von 22:00-06:15 mit + 50% Berechnen.

Der absolute Traum wäre noch, wenn Excel jeden Samstag mit 25% Zuschlag Berechnen würde.

Ich bekomme das einfach nicht hin.
Wenn einem vielleicht "langweilig" ist, bin für jede Hilfe sehr dankbar.

AC/DC

jinx
06.07.2006, 20:52
<font size="2" face="Century Gothic">Moin, Gleich-/Wechselstrom,

mir z.B. ist nicht langweilig - da wäre eine vorbereitete Mappe mehr als willkommen...

Ansonsten kannst Du Dir das Beispiel bei Hajo unter Arbeitszeit & Pause (http://www.downloadcounter.de/counter.pl?file=http://home.media-n.de/ziplies/gepackt/vba/arbeitszeit_pause.zip&user=Hajo+Ziplies) bitte einmal ansehen - und es gibt auch noch die Suche hier im Forum ...</font>

AC/DC
07.07.2006, 17:25
Hallo jinx,

danke für die Antwort.
Habe mein Excel Sheet mal angehängt, ist nicht gerade spektakulär.

Zudem ist noch ein weiteres Problem aufgetaucht. Wenn in irgendeine Zelle der Spalten B oder D leer bleiben, bekomme ich den Wert 23,75, Excel rechnet dann natürlich 24*1-0,25. Die sollte aber leer bleiben, sonnst stimmen am Ende auch nicht mehr die Gesamtstunden von E35.

Ich werd´wahnsinnig...

Nach meiner Logik sollte Excel "ungefähr" wie fogt rechnen:
Wenn Zeile B6 größer oder gleich 14:00 ist, dann bis 20:00 E6 * 10 + 25% und ab 20:00 E6 * 10 + 50%, wenn aber B6 größer oder gleich 22:00 ist, dann E6 * 10 + 50% und wenn A6 gleich Samstag, dann E6 * 10 + 25%, sonst E6 * 10.

Ich hoffe, dass das noch zu verstehhen ist!!!

Habe zusätzlich noch die Vergütungsbeträge der Spalte F mit einem Kommentar versehen.

AC/DC

AC/DC
08.07.2006, 12:14
Habe einige Probleme gelöst bekommen, aber 100 ist das leider immer noch nicht.

Siehe Anhang

Gruß
AC/DC

jinx
08.07.2006, 13:46
<font size="2" face="Century Gothic">Moin, AC/DC,

wenn ich 6 Stunden à 12,50 und 2 Stunden à 15 rechne, bekomme ich den Wert 105 (und nicht, wie gewünscht, 100 - eine sehr arbeitgeberfreundliche Berechnung ;) - aber schöner wäre es meiner Meinung nach mit nur einer Formel für alle Fälle. Mal sehen, ob mich irgendwann die grosse Eingebung heimsucht... :grins:</font>

AC/DC
08.07.2006, 14:13
Hallo,

stimmt, ist mir auch (später) aufgefallen. Habe ich aber in der zweiten Datei geändert. Schau sie Dir mal an.

Das mit nur einer Formel wünsche ich mir ja auch, aber...

Dann hoffe ich mal auf eine Eingebung Deinerseits.

AC/DC

jinx
09.07.2006, 09:19
<font size="2" face="Century Gothic">Moin, AC/DC,

hier ein Ansatz zur möglichen Lösung Deines Problems (mit dem Hinweis, dass zur Zeit nur die Normalarbeitszeit am Samstag richtig berechnet wird):<table><tr style="vertical-align:top; text-align:center; "><tr><td>Blecher 07.06 </td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 style="font-weight:bold; "><col width=227.9999943 ><col width=48.999998775 ><col width=13.99999965 ><col width=48.999998775 ><col width=78.999998025 ><col width=116.999997075 ></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td>&nbsp;</td><td>A</td><td>B</td><td>C</td><td>D</td><td>E</td><td>F</td></tr><tr height=49 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="font-size:14pt; text-align:center; ">Datum</td><th colspan="3" rowspan="1" style="font-size:14pt; text-align:center; ">Arbeitszeit</th><td style="font-size:14pt; text-align:center; ">Stunden</td><td style="font-size:14pt; text-align:center; ">Verg&uuml;tung</td></tr><tr height=20 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="font-size:12pt; text-align:right; ">Samstag, 1. Juli 2006</td><td style="font-size:12pt; text-align:right; ">&nbsp;</td><td style="font-size:12pt; text-align:center; ">-</td><td style="font-size:12pt; ">&nbsp;</td><td style="font-size:12pt; ">&nbsp;</td><td style="font-size:12pt; ">&nbsp;</td></tr><tr height=20 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="font-size:12pt; text-align:right; ">Sonntag, 2. Juli 2006</td><td style="font-size:12pt; text-align:right; ">&nbsp;</td><td style="font-size:12pt; text-align:center; ">-</td><td style="font-size:12pt; ">&nbsp;</td><td style="font-size:12pt; ">&nbsp;</td><td style="font-size:12pt; ">&nbsp;</td></tr><tr height=20 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">Montag, 3. Juli 2006</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">06:00</td><td style="font-size:12pt; background-color:#99cc00; text-align:center; ">-</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">14:15</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">8,00</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">80,00 €</td></tr><tr height=20 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">Dienstag, 4. Juli 2006</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">06:00</td><td style="font-size:12pt; background-color:#99cc00; text-align:center; ">-</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">14:15</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">8,00</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">80,00 €</td></tr><tr height=20 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">Mittwoch, 5. Juli 2006</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">06:00</td><td style="font-size:12pt; background-color:#99cc00; text-align:center; ">-</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">14:15</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">8,00</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">80,00 €</td></tr><tr height=20 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">Donnerstag, 6. Juli 2006</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">06:00</td><td style="font-size:12pt; background-color:#99cc00; text-align:center; ">-</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">14:15</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">8,00</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">80,00 €</td></tr><tr height=20 ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">Freitag, 7. Juli 2006</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">06:00</td><td style="font-size:12pt; background-color:#99cc00; text-align:center; ">-</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">15:15</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">9,00</td><td style="font-size:12pt; background-color:#99cc00; text-align:right; ">90,00 €</td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#FFFCF9; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">E4 : =WENN(B4="";"";H4-0,25)<br>F4 : =WENN(UND<span style=' color:008000; '>(B4="";D4="")</span>;"";WENN<span style=' color:008000; '>(WOCHENTAG<span style=' color:#0000ff; '>(A4;2)</span>=6;1,25;1)</span>*<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(B4=0,25;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(D4&gt;B4;D4-B4;<span style=' color:#FF7837; '>(1-B4)</span>+D4)</span>*24-0,25)</span>*$L$2;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(B4=14/24;6*$L$2*$I$2+2*$L$2*$J$2;8*$L$2*$J$2)</span>)</span>)</span>)</span>)<br>E5 : =WENN(B5="";"";H5-0,25)<br>F5 : =WENN(UND<span style=' color:008000; '>(B5="";D5="")</span>;"";WENN<span style=' color:008000; '>(WOCHENTAG<span style=' color:#0000ff; '>(A5;2)</span>=6;1,25;1)</span>*<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(B5=0,25;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(D5&gt;B5;D5-B5;<span style=' color:#FF7837; '>(1-B5)</span>+D5)</span>*24-0,25)</span>*$L$2;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(B5=14/24;6*$L$2*$I$2+2*$L$2*$J$2;8*$L$2*$J$2)</span>)</span>)</span>)</span>)<br>E6 : =WENN(B6="";"";H6-0,25)<br>F6 : =WENN(UND<span style=' color:008000; '>(B6="";D6="")</span>;"";WENN<span style=' color:008000; '>(WOCHENTAG<span style=' color:#0000ff; '>(A6;2)</span>=6;1,25;1)</span>*<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(B6=0,25;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(D6&gt;B6;D6-B6;<span style=' color:#FF7837; '>(1-B6)</span>+D6)</span>*24-0,25)</span>*$L$2;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(B6=14/24;6*$L$2*$I$2+2*$L$2*$J$2;8*$L$2*$J$2)</span>)</span>)</span>)</span>)<br>E7 : =WENN(B7="";"";H7-0,25)<br>F7 : =WENN(UND<span style=' color:008000; '>(B7="";D7="")</span>;"";WENN<span style=' color:008000; '>(WOCHENTAG<span style=' color:#0000ff; '>(A7;2)</span>=6;1,25;1)</span>*<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(B7=0,25;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(D7&gt;B7;D7-B7;<span style=' color:#FF7837; '>(1-B7)</span>+D7)</span>*24-0,25)</span>*$L$2;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(B7=14/24;6*$L$2*$I$2+2*$L$2*$J$2;8*$L$2*$J$2)</span>)</span>)</span>)</span>)<br>E8 : =WENN(B8="";"";H8-0,25)<br>F8 : =WENN(UND<span style=' color:008000; '>(B8="";D8="")</span>;"";WENN<span style=' color:008000; '>(WOCHENTAG<span style=' color:#0000ff; '>(A8;2)</span>=6;1,25;1)</span>*<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(B8=0,25;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(D8&gt;B8;D8-B8;<span style=' color:#FF7837; '>(1-B8)</span>+D8)</span>*24-0,25)</span>*$L$2;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(B8=14/24;6*$L$2*$I$2+2*$L$2*$J$2;8*$L$2*$J$2)</span>)</span>)</span>)</span>)<br>E9 : =WENN(B9="";"";H9-0,25)<br>F9 : =WENN(UND<span style=' color:008000; '>(B9="";D9="")</span>;"";WENN<span style=' color:008000; '>(WOCHENTAG<span style=' color:#0000ff; '>(A9;2)</span>=6;1,25;1)</span>*<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(B9=0,25;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(D9&gt;B9;D9-B9;<span style=' color:#FF7837; '>(1-B9)</span>+D9)</span>*24-0,25)</span>*$L$2;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(B9=14/24;6*$L$2*$I$2+2*$L$2*$J$2;8*$L$2*$J$2)</span>)</span>)</span>)</span>)<br>E10 : =WENN(B10="";"";H10-0,25)<br>F10 : =WENN(UND<span style=' color:008000; '>(B10="";D10="")</span>;"";WENN<span style=' color:008000; '>(WOCHENTAG<span style=' color:#0000ff; '>(A10;2)</span>=6;1,25;1)</span>*<span style=' color:008000; '>(WENN<span style=' color:#0000ff; '>(B10=0,25;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(D10&gt;B10;D10-B10;<span style=' color:#FF7837; '>(1-B10)</span>+D10)</span>*24-0,25)</span>*$L$2;<span style=' color:#ff0000; '>(WENN<span style=' color:#804000; '>(B10=14/24;6*$L$2*$I$2+2*$L$2*$J$2;8*$L$2*$J$2)</span>)</span>)</span>)</span>)<br></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table></font>

AC/DC
10.07.2006, 10:08
Hallo,

wow, vielen Dank erstmal für die Mühe.

In meinem "Wahn" habe ich aber total vergessen, dass ab 14:00 bis 20:00 ein Zuschlag von 25% noch dazu kommt.
Also müsste in der Zelle F10 der Betrag von 92,50 stehen.

Hätte nicht gedacht, dass das so komplex werden wird.

AC/DC

jinx
10.07.2006, 17:37
<font size="2" face="Century Gothic">Moin, AC/DC,

mein Anfall von Arbeitseifer ist vorbei - wenn Du für mich den Fehler in meiner Anwendung suchen und ausbügeln möchtest, können wir tauschen: ich bin mir dann allerdings ziemlich sicher, dass ich den leichteren Teil erhalten hätte... :grins:</font>