PDA

Vollständige Version anzeigen : Suchen-Ersetzen nur vorne


Janina
05.07.2006, 13:47
Hallo,

wie kann ich denn nur am Anfang einer Zelle etwas Suchen und Ersetzen, den Rest aber beibehalten?

z.B.: meine Zelle lautet M14400M16

Ich möchte das M vorne durch ein P ersetzen, aber das M hinten stehen lassen.

Oder

das M vorne ganz entfernen, das M hinten aber drin lassen

Danke für Eure Hilfe,
Janina

Lukas Mosimann
05.07.2006, 13:53
Hallo Janina
Formel für erste Variante: ="P"&RECHTS(A1;LÄNGE(A1)-1)
Formel für zweite Variante: =RECHTS(A1;LÄNGE(A1)-1)
Gruss
Lukas


Bitte um Rückmeldung

myfake
05.07.2006, 13:56
Hallo Janina,

versuche es doch mal mit dieser Formel:
=WENN(LINKS(A3;1)="M";"P"&RECHTS(A3;LÄNGE(A3)-1);A3)

-> "M14400M16" steht in A3 :)


ich hatte es so verstanden, dass nur wenn vorne ein "M" steht ersetzt werden soll. Sonst einfach so wie von Lukas beschrieben :)


cu
myfake

Janina
05.07.2006, 14:13
Herrlich - es funktioniert - DAAAANKE! Sind beide hilfreich für mich.