PDA

Vollständige Version anzeigen : resfresh unterformular


Dutt
01.04.2004, 14:51
Hallo!
Habe folgendes Problem:
Habe ein hauptformualr, und 2 Unterformulare!
Jetzt gebe ich in einem unterformular daten ein, klicke speichern und nun sollen die gespeicherten werte in unterformular 2 erscheinen! das geht nur wenn ich das ganze formular zu mache und wieder auf!
also:
klick auf speichern in unter1 soll daten in unter2 aktualisieren!
danke und gruß

J_Eilers
01.04.2004, 14:55
Vielleicht so?

Me.Parent!DeinUFoSteuerelement.Form.Requery

Arne Dieckmann
01.04.2004, 14:55
Ungetestet - aus dem Unterformular #1 heraus:

Me.Parent!UFo2.Requery

Dutt
01.04.2004, 14:57
hmmm, er sagt das da was nicht stimmt, weil mein unterfom2 aus 2 wörtern besteht, sagen wir mal "unterformualr nummer2"
wat nu?

J_Eilers
01.04.2004, 14:58
Me.Parent![Dein UFo Steuerelement2].Form.Requery

Arne Dieckmann
01.04.2004, 14:58
Es sollte Dir langsam bekannt sein, dass man in dem Fall den Namen in eckige Klammern setzen muss.


@Jan: Du Schlingel hast Deinen 1. Beitrag geändert. "Parent" stand vorher nicht da. ;)

Dutt
01.04.2004, 14:59
ah jetzt ja! danke es geht @ arne! :)))

J_Eilers
01.04.2004, 15:01
@Arne Ne ich bin von einem UFo im UFo ausgegangen, hab mich dann aber noch umentschieden...Kaffee? ;)

Dutt
01.04.2004, 15:14
@ arne
ich habe das gleiche dann sofort mit [ ] probiert, nur dann will er ein Feld ansteuern!
Das sollte dir langsam mal bekannt sein! :P

Arne Dieckmann
01.04.2004, 15:19
ich habe das gleiche dann sofort mit [ ] probiert, nur dann will er ein Feld ansteuern!

Muss ich das jetzt verstehen? Durch die Verwendung von eckigen Klammern kann man jedes unglücklich benannte Objekt ansteuern. Ein Feld wird dadurch definitiv nicht automatisch "angesprochen".

Dutt
01.04.2004, 15:24
hmmm, also bei mir hat er gemeckert, "blabla konnte feld nicht finden --> name unterform2 (nachdem ich es in eckige klammern geschrieben habe)
so hast du es doch oben gesagt, das ich das mitterweile wissen solle...
nix für ungut!

Arne Dieckmann
01.04.2004, 15:28
Wenn Du nicht weisst, wie Dein Unterformular(steuerelement) in Deinem Hauptformular heisst, kann ich nichts dafür. ;)
Du hast sicherlich nicht die Eigenschaft "Name" des Unterformular-Steuerelementes im Hauptformular verwendet. Und ehrlich gesagt habe ich keine Lust, dass jedes Mal im voraus zu sagen. Irgendwann sollte das jeder einmal mitbekommen haben, da dieses Problem mindestens einmal täglich hier behandelt wird.

Zum Ansprechen von Unterformularen s. auch den Screenshot in diesem Thread:
http://www.ms-office-forum.net/forum/showthread.php?s=&threadid=122681