PDA

Vollständige Version anzeigen : kein Hyperlink in SQL, was tun?


Kurt aus ABG
23.03.2004, 08:29
Guten Morgen Mitstreiter.

In einer A2k Datenbank habe ich im Kundenverwaltung zwei
Hyperlink – Datenfelder, die auch fehlerfrei funktionieren.
Die Datenbank besteht aus FE und BE. Das BE wird jetzt auf einem SQL – Server
installiert. Den Datenaustausch soll in der 1. Umbaufase eine ODBC – Verbindung
realisieren. Mit Umstellung des BE auf SQL – Server ist aber der Datentyp
‚Hyperlink’ nicht mehr verfügbar. Was muss ich anstellen, dass die aus A2k
gewohnte Hyperlink – Funktionalität wieder zur Verfügung steht.

Habe schon im Vorfeld im Forum gesucht und den Beitrag von:

Aquarii vom 4.5.2003

Code 1
DeinTextfeld = "Mail@web.de"
Application.Hyperlink "mailto:" & DeinTextfeld

Code2
DeinTextfeld = "www.microsoft.de"
Application.Hyperlink "http://" & DeinTextfeld

gefunden. Doch leider gibt A2k bei Application.Hyperlink eine Fehlermeldung aus.

Mit freundlichen Grüßen
Kurt

Steffen0815
23.03.2004, 08:36
Kannst du die Fehlermeldung mal näher beschreiben

KHS
23.03.2004, 09:31
M.E. muss es 'Application.FollowHyperlink' lauten.
Oder verwende <b><a href="http://www.ms-office-forum.net/forum/showthread.php?s=&postid=431223" target="_blank">ShellExecute</a></b> (anklicken).
Siehe auch <b><a href="http://www.vbarchiv.net/vbapi/ShellExecute.php" target="_blank">HIER</a></b>.
Vorteil gegenüber 'FollowHyperlink' (weil ja immer mal behauptet wird 'ShellExecute' sei obsolet):
Keine Web-Symbolleiste (die man zwar unterdrücken kann mit 'DoCmd.ShowToolbar "Web", acToolbarNo')
Eine Powerpoint-Präsentation wird auch als solche aufgerufen, nicht wie bei 'FollowHyperlink' in einem Fenster!

Kurt aus ABG
23.03.2004, 11:21
Hi KHS.

Ich dachte an eine einfache Lösung des Problems.
In VB bin ich noch nicht so sattelfest, leider.
Mit 'Application.FollowHyperlink' funktioniert das ganze.

Ich danke euch für die Hilfe.

Schönen Tag noch, bis bald!

Kurt aus ABG
23.03.2004, 13:56
Hallo Mitstreiter.

Nun habe ich die Hinweise von KHS befolgt aber ein Problem tat sich noch auf.
Bevor ich den Aufruf FollowHyperlink starte, möchte ich prüfen ob es sich
wirklich um einen Hyperlink handelt. Ich dachte das geht mit
IsHyperlink(MeinLink), doch leider gibts da wieder eine Fehlermeldung:

"Sub oder Function nicht definiert."

Könnte mir vorstellen, dass ich einen Verweis nicht aktiviert habe,
aber welcher ist das? Wer kann helfen?

mfg Kurt :bawling:

Kurt aus ABG
24.03.2004, 09:01
Guten Morgen.

Muss noch mal meinen Beitrag nach vorne schieben, denn den Fehler
beim Code:

IsHyperlink(MeinLink) konnte ich leider noch nicht finden.

Die Fehlermeldung "Sub oder Function nicht definiert." kommt nach wie vor.

Bitte um Hilfe.

Danke schon im voraus.

mfg Kurt. :tausch:

Arne Dieckmann
24.03.2004, 09:27
IsHyperLink ist IMHO auch keine Funktion, sondern eine Eigenschaft. Da müsste man evtl. eine eigene Funktion schreiben, die den Wert kontrolliert.

Kurt aus ABG
24.03.2004, 11:51
Hallo Arne.

Natürlich hast du wieder recht, es ist eine Eigenschaft.
Bin wie so oft auf den falschen Dampfer aufgesprungen, sorry.

Wer lesen kann ist eben doch im Vorteil!!

Danke Arne!!

mfg Kurt