PDA

Vollständige Version anzeigen : Eingabe in textfeld und siche in UFO


Lucasss
22.03.2004, 06:50
mal wieder ein problem
ich hab auf dem hauptformular (F_Suche) ein textfeld (Text0 ich weiß benamung unkorrekt)
und eine Abfrage die ein unterformular (U_Suchentest) mit daten versorgt
nun soll anhand der eingabe des textfeldes der wert im ufo selectiert werden und angezeigt werden

SELECT
A_T_ZCRPFehl_Eigenfertigung.[SAP-Nr],
T_Abschluss.Material,
T_Abschluss.Materialkurztext,
T_Abschluss.Auftrag,
T_Abschluss.Sollmenge,
T_Abschluss.Gel_Menge,
T_Abschluss.Eckstart,
T_Abschluss.Eckende,
T_Abschluss.[kpl/RM],
T_Abschluss.Fehlteil,
T_Abschluss.Fehlteil_Materialkurztext,
T_Abschluss.Fehlmenge,
T_Abschluss.Zugang,
T_Abschluss.UM_Dat,
T_Abschluss.Zugangsdatum,
T_Abschluss.[NR-Disp],
T_Abschluss.DE,
T_Abschluss.Disp,
T_ABschluss.Disponent
FROM A_T_ZCRPFehl_Eigenfertigung,
T_Abschluss ,
A_T_ZCRPFehl_Eigenfertigung INNER JOIN

T_Abschluss
ON A_T_ZCRPFehl_Eigenfertigung.Fehlteil = T_Abschluss.Material
Where (((A_T_ZCRPFehl_Eigenfertigung.[sap-nr])=[Form].[F_Suche].[Text0]))
Order by A_A_T_ZCRPFehl_Eigenfertigung.[SAP-Nr]

wo liegt der fehler??
egal was ich in dem textfeld eingebe ich bekomme keine ausgabe
und bei dem textfeld ist ein vba hinterlegt bei change soll er
Me!U_suchentest.Requery
Hat jemand ne idee / Lösung???

J_Eilers
22.03.2004, 07:02
Hi,

wenn du eine deutsche Accessversion hast:

Where (((A_T_ZCRPFehl_Eigenfertigung.[sap-nr])=[Formulare]![F_Suche]![Text0]))

Das Requery muss vermutlich auch so heissen:

Me!U_suchentest.Form.Requery

Lucasss
22.03.2004, 07:28
danke!! die abfrage funktioniert jetzt
(danke an unsere it dafür das ich nen engl. win2k hab aber deutsches office es lebe die babyloische sprachverwirrung)
das requery funzt leider noch nicht
muss noch rumprobieren
hat jemand ne ahnung wiso das requery nicht geht??
wenn ich in den entwurfsmodus gehe und wieder auf forumalaransicht dann werden die daten aktualisiert wiso nicht bei der eingabe in das textfeld daß die bedingung change hat und auch change macht wie ich mit nem testfeld festgestellt hab wo ist der verflixte bug???

J_Eilers
22.03.2004, 08:33
Da gibt es viele komische Dinge bei Microsoft ;)

Schau mal hier (http://home.arcor.de/ar/arne.d/datenbanken/grundlagen/formulare/index.html#SEC2)

Die korrekte Syntax muss so lauten:

Me!DeinUFoSteuerelement.Requery

HTH