PDA

Vollständige Version anzeigen : SVERWEIS Array Problem


Killerant
18.09.2003, 15:51
Hallo,

ich habe folgendes Problem:

Ich habe eine Tabelle, die aus mehreren Blättern besteht.

Auf dem ersten Tabellenblatt sind allgemeine Werte und auf allen anderen spezielle.

Zur Erklärung:

Schlüssel1, Schlüssel2, Name
Be1,1,Test4
Be3,1,Test6
Be1,2,Test8

Jetzt möchte ich auf einem anderen Tabellenblatt per SVERWEIS Werte, die mit dem selben Schlüssel1 beginnen auflisten. Dazu soll Schlüssel2 zusätzlich zum ersten ausgewertet werden. Im Prinzip müsste es über ein Array gehen. Nur leider weiss ich nicht wie ich das machen soll. Das Problem habe ich jetzt stark vereinfacht dargestellt, ich hoffe aber, das trotzdem irgendwer etwas damit anfangen kann.

Wer kann mir helfen??

Vielen Dank im Voraus.

Timo

jinx
18.09.2003, 16:03
<font size="2" face="Century Gothic">Moin, Timo,

vielleicht kannst Du verstehen, dass auf eine sehr allgemeine Frage auch nur eine unbefriedigende Antwort kommen kann - wie wäre es mit einer Mappe als Anhang oder einer genaueren Darstellung zur Verdeutlichung?</font>

Killerant
18.09.2003, 18:00
Hallo jinx,

anbei eine Beispielmappe. Auf dem zweiten Tabellenblatt kannst Du sehen, was ich meine. Es wird nur der höchste bzw. letzte Wert über den SVERWEIS ermittelt. Wie kann ich die lfd. Nr noch mit einbinden, so dass eindeutige "Datensätze" entstehen.

Danke
Timo


Sorry war nicht eingeloggt. Jetzt habe ich die Datei angehängt.

jinx
18.09.2003, 18:53
<font size="2" face="Century Gothic">Moin, Timo,

z.B. so in Anlehnung an Sverweis bei mehrfach vorkommendem Suchkriterium (http://www.excelformeln.de/formeln.html?welcher=28) - Zelle D8 fängt über Bedingte Formatierung den Fehler ab und schreibt in weiß:<table><tr style="vertical-align:top; text-align:center; "><tr><td>&nbsp;</td></tr><tr><td><pre><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial,Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "> <style type = "text/css"> th {font-weight:normal} </style> <colgroup><col width=30 style="font-weight:bold; "><col width=79.999998 ><col width=79.999998 ><col width=79.999998 ><col width=79.999998 ></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td>&nbsp;</td><td style=" border-width:3; border-style: groove;border-color:#f0f0f0; ">A</td><td style=" border-width:3; border-style: groove;border-color:#f0f0f0; ">B</td><td style=" border-width:3; border-style: groove;border-color:#f0f0f0; ">C</td><td style=" border-width:3; border-style: groove;border-color:#f0f0f0; ">D</td></tr><tr height=17 ><td style="border-width:3; border-style: groove;border-color:#f0f0f0; background-color:#cacaca; text-align:center; " >4</td><td style="">BA-1</td><td style="">test2</td><td style="text-align:left; ">test1</td><td style="text-align:left; ">test2</td></tr><tr height=17 ><td style="border-width:3; border-style: groove;border-color:#f0f0f0; background-color:#cacaca; text-align:center; " >5</td><td style="">BA-1</td><td style="">test2</td><td style="text-align:left; ">test1</td><td style="text-align:left; ">test2</td></tr><tr height=17 ><td style="border-width:3; border-style: groove;border-color:#f0f0f0; background-color:#cacaca; text-align:center; " >6</td><td style="">BA-2</td><td style="">test4</td><td style="text-align:left; ">test3</td><td style="text-align:left; ">test4</td></tr><tr height=17 ><td style="border-width:3; border-style: groove;border-color:#f0f0f0; background-color:#cacaca; text-align:center; " >7</td><td style="">BA-2</td><td style="">test4</td><td style="text-align:left; ">test3</td><td style="text-align:left; ">test4</td></tr><tr height=17 ><td style="border-width:3; border-style: groove;border-color:#f0f0f0; background-color:#cacaca; text-align:center; " >8</td><td style="">BA-3</td><td style="">test5</td><td style="text-align:left; ">test5</td><td style="color:#ffffff; background-color:#333333; text-align:left; ">#ZAHL!</td></tr></table></pre><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00"><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table style="font-family:Arial; font-size:10pt;">B4 : =SVERWEIS($A4;Tabelle1!$A$2:$C$6;3;WAHR)<br>C4 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A1:A1000=Tabelle2!A4);ZEILE(1:1000 ));1))}<br>D4 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A1:A1000=Tabelle2!A4);ZEILE(1:1000 ));2))}<br>B5 : =SVERWEIS($A5;Tabelle1!$A$2:$C$6;3;WAHR)<br>C5 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A2:A1001=Tabelle2!A5);ZEILE(2:1001 ));1))}<br>D5 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A2:A1001=Tabelle2!A5);ZEILE(2:1001 ));2))}<br>B6 : =SVERWEIS($A6;Tabelle1!$A$2:$C$6;3;WAHR)<br>C6 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A3:A1002=Tabelle2!A6);ZEILE(3:1002 ));1))}<br>D6 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A3:A1002=Tabelle2!A6);ZEILE(3:1002 ));2))}<br>B7 : =SVERWEIS($A7;Tabelle1!$A$2:$C$6;3;WAHR)<br>C7 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A4:A1003=Tabelle2!A7);ZEILE(4:1003 ));1))}<br>D7 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A4:A1003=Tabelle2!A7);ZEILE(4:1003 ));2))}<br>B8 : =SVERWEIS($A8;Tabelle1!$A$2:$C$6;3;WAHR)<br>C8 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A5:A1004=Tabelle2!A8);ZEILE(5:1004 ));1))}<br>D8 : {=INDEX(Tabelle1!C:C;KKLEINSTE(WENN((Tabelle1!A5:A1004=Tabelle2!A8);ZEILE(5:1004 ));2))}<br></table></td></tr></table><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#ff0000"><tr><td><b>Bedingte Formatierungen der Tabelle</b></td></tr><tr><td><table border=1 cellspacing=0 cellpadding=0 style="font-family:Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "><tr><td>Zelle</td><td>Nr.: / Bedingung</td><td>Format</td></tr><tr><td>D8</td><td>1. / Formel ist =ISTFEHLER(D8)</td><td style="color:#ffffff; ">Abc</td></tr></table></td></tr></table></td></tr><tr><td>&nbsp;</td></tr></tr></table> <span style=" font-size:9pt;"><b>Excel Tabellen einfach im Web darstellen</b> <a style ="color:#1506F7; background-color:#FCF507; font-weight:bold;" href="http://www.haserodt.de/ejh_do/ex_jean_info.htm" target="blank">&nbsp;&nbsp;Excel Jeanie HTML&nbsp;&nbsp;2.0&nbsp;&nbsp;&nbsp;&nbsp;Download&nbsp;&nbsp;</a></span></font>

Killerant
18.09.2003, 21:12
Hi Jinx,

scheinbar habe ich mein Problem noch nicht richtig ausgedrückt. Ich habe nochmal ein neues Beispiel angehängt, vielleicht wird es dadurch deutlicher. Im Beispiel habe ich auch erklärt, was ich erzielen möchte.

Gruß
Timo