MS-Office-Forum

Zurück   MS-Office-Forum > Archive > Microsoft Access - Archiv > Microsoft Access - Archiv (2001)
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 28.08.2001, 12:21   #1
anotherone
MOF User
MOF User
Frage Probleme mit Unterbericht

Hallo,

ich habe einen Bericht, der für die Mitarbeiter den Ablauf einer Dienstreise enthält. Über ein Unterformular werden dann noch die Informationen über Ankunft/Abflug eingefügt. Bisher hatte ich die ganzen Informationen aus der dazugehörigen Tabelle bezogen, aber aufgrund von verknüpfungen erscheinen immer nur die Personalnummer und nicht der Name und die Kundennummer und nicht der Kundenname. Also hab ich es über eine Abfrage laufen lassen. Jetzt wird zwar Name und Kundenname korrekt angezeigt, aber der Bericht verlangt nun jedesmal die eingabe der Zahlen(Reise.id, Reise), die die beiden Berichte verknüpft(was er ja eigentlich selbst machen soll). Hab das ganze natürlich schon an die geänderten Bedingungen angepasst, ändert nix. Außerdem stellt sich mir die Frage, ob es eine Möglichkeit gibt, die Größe der Unterberichtes dynamisch anzupassen, da manchmal nur 1 Info enthalten ist, ein anderes mal aber vielleicht 4, so das ich entweder nicht alles sehen kann oder viel Platz verschwenden muss. Hat jemand ne Idee???

Gruss

Anotherone
anotherone ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 28.08.2001, 12:28   #2
flori
MOF User
MOF User
Standard

Hallo!

Hast du in den Eigenschaften von dem Unterbericht die Felder Verknüpfen von/nach überprüft, ob sie vielleicht einen falschen Namen drin haben (Grossen anstatt kleinen Anfangsbuchstaben).
Hast du vielleicht das eine Feld dafür vergessen und er findet deswegen das verknüpfte Feld nicht?
Mehr weiss ich zur Zeit nicht!

Und mit dem dynamisch, habe ich auch keine Ahnung. Aber hast du so ein akutes Platzproblem auf dem Blatt?
flori ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 28.08.2001, 14:20   #3
anotherone
Threadstarter Threadstarter
MOF User
MOF User
Hinweis

Hallo,

ich hab es mittels des Assistenten eingetragen, daher sind Schreibfehler ausgeschlossen(habs auch noch mal kontrolliert). Wenn ich das Reise-Feld aus der Tabelle deparr(departure-arrive, Abflug-Ankunft) in die Abfrage mit einfüge, dann klappt es zwar, aber für jeden eintrag bekomme ich eine Seite(jeweils mit allen einträgen), dh bei 3 einträgen stehen zwar alle 3 untereinander da, aber ich bekomme 3 setien mit dem selben Inhalt und das ist ja nicht Zweck der Übung.extra noch mal kontrolliert, beide Felder sind longint, das eine ist Index, das andere nicht, das sollte aber eigentlich kein Prob sein.

Das nervt mich schon wieder an.

Anotherone

P.S. es handelt sich um A2K, erste Teile
wurden aber unter 97 entwickelt.
anotherone ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 28.08.2001, 14:28   #4
kaybuch
MOF User
MOF User
Standard

Hallo,

Unterbericht "ganz klein machen", in den Eigenschaften auf vergrößerbar stellen. Damit wäre das Platzproblem im Griff.

Wenn der Bericht ohne Sub nur eine Seite für den Mitarbeiter bringt ists gut, wenn nicht die Abfrage entsprechend über gruppieren modifizieren.
Die Abfrage für den Sub-Bericht enthält dann das Schlüselfeld zum verknüpfen. Einstellen, dann müßts gehen. Vertrau bei Unterberichten/Unterformularen NIEMALS dem Assistenten. Prüf alles von Hand nach.

Gruß
Kay
kaybuch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 28.08.2001, 14:58   #5
anotherone
Threadstarter Threadstarter
MOF User
MOF User
Standard

Hab es jetzt geschafft, das er mich nur noch einmal fragt, und zwar nach dem Parameter des Unterberichts, wenn ich das dann mit Enter übergehe, kommt der fertige und richtige Bericht, aber irgendwie muss sich doch auch das lösen lassen.

Anotherone

P.S. Wer hätte es gewusst? das ganze hing daran, das das Parameter des Hauptberichtes nicht mit auf "dem Zettel" war(ist nicht wichtig, ist ja nur die interne Unterscheidung). Habs dann auch beim Unterbericht so gemacht, aber da hilfts nix
anotherone ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 14:56 Uhr.



Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.