MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 09.02.2018, 10:05   #1
Dialux83
Neuer Benutzer
Neuer Benutzer
Standard Formel - SVERWEIS - Spaltenindex - erhöhen

Liebe Leute,

ich kämpfe gerade mit einer SVERWEIS Formel.
Folgende Ausgangsposition:
1)2 Tabelleblätter
2)Tabellenblatt 1 enthält die Matrix
3)Tabellenblatt 2 enthält den SVERweis auf Tabellenblatt1

Ziel:
Wenn ich nun den SVERWEIS, der grundsätzlich funktioniert, nach rechts ziehe, möchte ich, dass der Spaltenindex hochgezählt wird.

Das ist die Formel:
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;52)

Die 52 Spalte in Tabellenblatt 1 ist die Spalte BB innerhalb der Matrix.

Ich habe schon einiges probiert mit ZEILE(), SPALTE()....

Das wäre das gewünschte Verhalten:
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;53)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;54)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;55)

DAnke für Eure Hilfe!
Dialux83 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 10:06   #2
steve1da
MOF Meister
MOF Meister
Standard

Hola,

Spalte(A52)

Gruß,
steve1da
steve1da ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 10:58   #3
MisterBurns
MOF Koryphäe
MOF Koryphäe
Standard

@steve
wäre hier nicht Spalte(BB52) gefragt?

__________________

Schöne Grüße
Berni
MisterBurns ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:00   #4
steve1da
MOF Meister
MOF Meister
Standard

Hola,

nein.

Gruß,
steve1da
steve1da ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:01   #5
Dialux83
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Danke für die rasche Antwort,
aber wenn ich das mache passiert folgendes:

=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;SPALTE(A52))
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;SPALTE(B52))
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;SPALTE(C52))

usw.

Und außerdem liefern die Rückgabewerte nicht das selbe Ergebnis wie
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;52)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;53)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;54)

Im obigen Fall wird nämlich bei Spalte 1 begonnen der Matrix, erst wenn ich wieder auf zB 52 umstelle passt das Ergebnis des sverweis!?

Andere Vorschläge?
Dialux83 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:06   #6
MisterBurns
MOF Koryphäe
MOF Koryphäe
Standard

Na ich behaupte doch, denn sonst kriegt er ja das Ergebnis aus Spalte A.

@Dialux: Versuch mal Spalte(BB1)

__________________

Schöne Grüße
Berni
MisterBurns ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:19   #7
steve1da
MOF Meister
MOF Meister
Standard

Hola,

natürlich, du hast Recht! Mea culpa.

Gruß,
steve1da
steve1da ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:20   #8
Dialux83
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Leider alle beide falsch; richtig ist Zeike(BB52)

Trotzdem vielen Dank!
Dialux83 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:22   #9
steve1da
MOF Meister
MOF Meister
Standard

Hola,

aber nicht wenn du die Formel nach rechts ziehen willst.

Gruß,
steve1da
steve1da ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:31   #10
MisterBurns
MOF Koryphäe
MOF Koryphäe
Standard

ob nun BB1 oder BB52 müsste doch wurscht sein, da sich ja die Spalte (sprich BB) nicht ändert, egal ob nun Zeile 1 oder 52.

__________________

Schöne Grüße
Berni
MisterBurns ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:53   #11
Dialux83
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Es haperte doch noch etwas, nun stimmts:

ich muss 2 "Spalten" abziehen -> Anstatt "BB52" muss ich bei AZ52 starten, da der SVERWEIS ja in Spalte C beginnt!
Dialux83 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 12:02   #12
MisterBurns
MOF Koryphäe
MOF Koryphäe
Standard

Zitat:

> Anstatt "BB52" muss ich bei AZ52 starten, da der SVERWEIS ja in Spalte C beginnt!

Versteh ich nicht. Ist doch egal, wo der SVERWEIS beginnt, wenn ich das Ergebnis aus Spalte BB haben will. Aber du wirst schon wissen, wie deine Datei aussieht. Wir wissen es nämlich nicht.

__________________

Schöne Grüße
Berni
MisterBurns ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 23:58   #13
BKH_St
Neuer Benutzer
Neuer Benutzer
Standard

Das wäre das gewünschte Verhalten:
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;53)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;54)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;55)

Da würde ich wie folgt formulieren:

=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;SPALTE(A:A)+52)
wenn ich die nach rechts kopiere wird daraus
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;SPALTE(B:B)+52)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40;SPALTE(C:C)+52)
u.s.w.

und das sieht dann im Formelauswertungsdialog so aus:
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40; 1 + 52)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40; 2 + 52)
=SVERWEIS($E17;Ressourcenplan!$C$21:$NW$40; 3 + 52)
u.s.w.

Das würde mir jedenfalls beim Lesen weniger Kopfzerbrechen machen, als die anderen Vorschläge

Tschö mit "ö"
BKH_St ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 10.02.2018, 00:04   #14
steve1da
MOF Meister
MOF Meister
Standard

Hola,

Code:

SPALTE(A:A)+52)
bereitet mir Kopfschmerzen.

Gruß,
steve1da
steve1da ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 10:32 Uhr.


Partner und Co.
Access-Paradies -Alles rund um die Datenbank Microsoft Access -Code -Programme-Tools -Tipps   Kostenlose Tipps & Tricks, Downloads und Programme   www.kulpa-online.com - Tipps - Tricks - Tutorials - Meinungen - Downloads uvm...   vb@rchiv · Willkommen in der Welt der VB Programmierung   Access-Garhammer - Hier finden Sie jede Menge Beispiel-Datenbanken zu Access und mehr ...   mcseboard.de   Die Top Seite für Excel-VBA-Makros uvm.

Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.