MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 24.08.2017, 16:42   #1
Botpenner
Neuer Benutzer
Neuer Benutzer
Standard Frage - Excel gleiche Nummer zusammenfassen und Stückzahl zählen?

Hallo Leute,


folgendes Problem. Ich habe eine Liste mit Artikelnummern,
dahinter befindet sich die Stückzahl des Artikels.


Nun kann es sein das der Artikel in meiner Liste mehrmals untereinander auftaucht.
Ich möchte aber eine Übersicht habe wo der Artikel nur 1x auftaucht mit der Gesamten Stückzahl.


Beispiel:

Liste:
Spalte A | Spalte B
Art 1 | = 2
Art 2 | = 1
Art 1 | = 1
Art 1 | = 1
Art 2 | = 1
Art 3 | = 4

Soll werden:

Art 1 | = 4
Art 2 | = 2
Art 3 | = 4

Weiß jemand welche Formel ich da nehmen kann? Stehe gerade auf dem Schlauch
Botpenner ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 24.08.2017, 16:52   #2
steve1da
MOF Guru
MOF Guru
Standard

Hola,

http://www.excelformeln.de/formeln.html?welcher=194

Danach mit Summewenn() die Summen ermitteln.

Gruß,
steve1da
steve1da ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 24.08.2017, 16:59   #3
caplio
MOF User
MOF User
Standard

Da hilft "Summewenn".Tabelle1

 AB
1Art 12
2Art 21
3Art 11
4Art 11
5Art 21
6Art 34
7  
8  
9Art 14
10Art 22
11Art 34

Formeln der Tabelle
ZelleFormel
B9=SUMMEWENN($A$1:$A$6;A9;$B$1:$B$6)
B10=SUMMEWENN($A$1:$A$6;A10;$B$1:$B$6)
B11=SUMMEWENN($A$1:$A$6;A11;$B$1:$B$6)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
caplio ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 24.08.2017, 17:17   #4
Drogist
MOF Koryphäe
MOF Koryphäe
Standard

Auch bei extrem großen Datenmengen: Mit Power Query sind das wenige Mausklicks ...

__________________

Internette Grüße
Drogist

(Gut) Gefunden bei Storax: "This isn't a code writing service, you need to do some research and have a go at writing some of your own code."
Ich verwende Excel 2019. Wenn du keine Angaben über deine Version gemacht hast gehe ich davon aus, dass auch du mindestens diese Version hast.

¿¿ Wer schützt mich vor den Datenschützern ??
Drogist ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 25.08.2017, 07:16   #5
Botpenner
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Zitat: von caplio Beitrag anzeigen

Da hilft "Summewenn".Tabelle1

 AB
1Art 12
2Art 21
3Art 11
4Art 11
5Art 21
6Art 34
7  
8  
9Art 14
10Art 22
11Art 34

Formeln der Tabelle
ZelleFormel
B9=SUMMEWENN($A$1:$A$6;A9;$B$1:$B$6)
B10=SUMMEWENN($A$1:$A$6;A10;$B$1:$B$6)
B11=SUMMEWENN($A$1:$A$6;A11;$B$1:$B$6)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



Hallo geht das auch ohne das ich zuvor die Artikelnummern in Zelle A9 auflisten muss?


Ich habe eine liste mit über 200 verschiedenen Artikelnummern die mehrfach vorkommen. Ich möchte ungerne alle Artikelnummern zuvor definieren damit das System diese dann nach doppelten Einträgen sucht.

Viel mehr dachte ich daran, dass das System automatisch die Nummer erkennt ohen sie zuvor in eine weitere Zelle zu schreiben.
Botpenner ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 25.08.2017, 07:22   #6
steve1da
MOF Guru
MOF Guru
Standard

Hola,

wie das geht steht in dem Link in meiner Antwort.

Gruß,
steve1da
steve1da ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 25.08.2017, 07:29   #7
Botpenner
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Zitat: von caplio Beitrag anzeigen

Da hilft "Summewenn".Tabelle1

 AB
1Art 12
2Art 21
3Art 11
4Art 11
5Art 21
6Art 34
7  
8  
9Art 14
10Art 22
11Art 34

Formeln der Tabelle
ZelleFormel
B9=SUMMEWENN($A$1:$A$6;A9;$B$1:$B$6)
B10=SUMMEWENN($A$1:$A$6;A10;$B$1:$B$6)
B11=SUMMEWENN($A$1:$A$6;A11;$B$1:$B$6)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Zitat: von steve1da Beitrag anzeigen

Hola,

wie das geht steht in dem Link in meiner Antwort.

Gruß,
steve1da


Da steige ich nicht mehr durch :/
Botpenner ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 25.08.2017, 07:29   #8
RPP63neu
MOF Meister
MOF Meister
Standard

Moin!
Edit:
Steve hat Dir diesen Link geschickt:
http://www.excelformeln.de/formeln.html?welcher=194

Das Einfachste dürfte sein:
  • Klick in die Liste
  • Einfügen, Pivot-Table, OK
  • Artikel in Zeilen, Stückzahl in Werte
Fertig
Dauer: 2 Sekunden, ohne eine einzige Formel

Tabelle1

 ABCDE
1ArtikelAnzahl ArtikelSumme
2220 148
3419 269
4313 394
5319 4147
6318 Gesamt358
7412   
8119   
9219   
10417   
11115   
12416   
13420   
14114   
15417   
16312   
17216   
18313   
19420   
20415   
21319   
22214   
23411   


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Ralf

__________________

Meine Logik war nicht fehlerhaft, nur meine Interpretation!
Tuvok

Geändert von RPP63neu (25.08.2017 um 08:45 Uhr).
RPP63neu ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 20:25 Uhr.



Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.