MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 14.07.2012, 14:18   #1
tinocio
MOF User
MOF User
Standard Excel2007 - Doppelte Werte farbig markieren

Hi,
für experten sicher kein problem, für mich jedoch ein großes.
ich suche eine vba lösung um doppelte, mehrfache Einträge in einer spalte eines tabellenblattes farbig zu markieren.

danke für die hilfe
tinocio
tinocio ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 14.07.2012, 14:21   #2
Hajo_Zi
MOF Guru
MOF Guru
Standard

warum nicht bedingte Formatierung?
Annahme: Deine Werte stehen in A1 bis Axx
A1 anwählen, Format, Bedingte Formatierung (bei bedingter Formatierung soll es eine Grenze von 2050 Zeilen geben, mal selber Testen)
"Formel ist" auswählen NICHT "Zellwert ist"
Bei der Formel eingeben =ZÄHLENWENN(A$1:A1;A1)>1
Bei Format dann z.B. Musterfarbe rot auswählen mit OK beenden.
Die Formatierung auf Die Zellen A2 bis Axx kopieren. Fertig
Dann werden Doppelt farblich gekennzeichnet
oder
kann man auch die Doppeleingabe selber verhindern:
z.B. unter Daten, Gültigkeit, benutzerdefiniert
Formel
=ZÄHLENWENN(A:A;A1)=1
nach unten kopieren.
Von Ulrich Schneider
oder auch Unterscheidung Groß- und Kleinschreibung
=SUMME(N(IDENTISCH(E2;$E$2:$E$22)))=1
nicht für Version 2007

GrußformelHomepage

__________________

Signatur in jedem Beitrag
Bitte Version angeben. Bei keiner Angabe gehe ich von meinen Angaben aus.
Betriebssystem: Windows 10 - 64 Bit, Office 2016 - 32 Bit.
Fragen werden im Forum beantwortet, nicht per PN.

Beitrag bewerten.
Am Beitrag unten Links, mittleres Symbol, rechte Maustaste, im neuen Fenster öffnen.
Hajo_Zi ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 14.07.2012, 15:34   #3
tinocio
Threadstarter Threadstarter
MOF User
MOF User
Standard

thx, die lösung funzt einwandfrei

bin trotzdem an einer vba lösung interessiert

danke
tinocio
tinocio ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 14.07.2012, 16:10   #4
Hasso
MOF Meister
MOF Meister
Standard

Hallo tinocio,

angenommen, deine Werte stehen in Spalte A, Zeile 1 bis 100, dann

Code:

Sub doppelte_färben()

Dim zelle As Range

For Each zelle In ActiveSheet.Range("A1:A100")
  If WorksheetFunction.CountIf(ActiveSheet.Range("A1:A100"), zelle.Value) > 1 Then zelle.Interior.ColorIndex = 4
Next zelle
End Sub
Farbe und Bereich kannst du nach deinen Wünschen anpassen.

__________________

Gruß Hasso

Programmers don't die, they just GOSUB without RETURN

System Windows 7 Enterprise 64, Office 2013
Wenn dir mein Beitrag gefallen hat, kannst du ihn bewerten (mit dem Symbol links unten)
Hasso ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 14.07.2012, 16:27   #5
tinocio
Threadstarter Threadstarter
MOF User
MOF User
Strahlen

thx,
das ist die gewünschte lösung
klasse

danke
tinocio
tinocio ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 20:21 Uhr.



Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.