MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 04.04.2012, 15:06   #1
Gustav Lampe
Standard Excel2010 - Check Matrix auf Zahl oder Fehler

Hallo ich habe eine Zeitreihe an Daten. D.h. A1:A1000 steht das Datum der Zeireihe und B1:B1000 der jeweilige Wert (wenn korrekt dann immer eine Dezimalzahl). So manchmal fehlt aber auch ein Wert, dann ist zu einem Datum (zB: A4) die entsprechende Zelle B4 leer oder enthält "#N/A N/A" bzw. eine andere Zeichenkombination, die keine Dezimalzahl ist. Ich hätte gerne einen Check eingeführt der mir sagt ob irgendwo ein Wert fehlt bzw ob irgendwo etwas anderes als eine Deimalzahl steht. Die Formel =ISNUMBER(B4) macht diesen Check für eine Zelle möglich die Formel =ISNUMBER(A1:B1000) funktioniert aber nicht. Hier wird leider nicht geprüft, ob eine der Zellen deine Zahl sind... wie kann ich den check trotzdem durchführen? Funktioniert sowas wie WENN(A1:B1000<>Dezimalzahl;0;1) und was müsste man statt Dezimalzahl schreiben

DANKE für eure HILFE
 
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 04.04.2012, 15:13   #2
Uwe (:o)
MOF Profi
MOF Profi
Standard

Hallo Gustav,
die Formel:

=SUMMENPRODUKT(NICHT(ISTZAHL(A1:A1000))*1)

sagt Dir, wieviele Zellen in dem Bereich keine Zahl sind.
Hilft Dir das?

__________________

Gruß
Uwe
Uwe (:o) ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 04.04.2012, 15:16   #3
mücke
MOF Koryphäe
MOF Koryphäe
Ärger crosspost

siehe Office-Loesung.de _owT

__________________

Gruß Dirk

Ich helfe gerne … im Rahmen meiner Möglichkeiten
mücke ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 04.04.2012, 15:19   #4
IngGi
MOF Guru
MOF Guru
Standard

Hallo Gustav,

Code:

=COUNT(A1:A1000)
gibt dir die Anzahl von Zellen zurück, die eine Zahl enthalten. Das müssten im angegebenen Bereich ja 1000 sein, d.h.

Code:

=COUNT(A1:A1000)=1000
gibt dann TRUE zurück, wenn alle Zellen im Bereich Zahlen enthalten, bzw. FALSE, wenn mindestens 1 Zelle im Bereich etwas anderes enthält.

Gruß Ingolf
IngGi ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 14:57 Uhr.



Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.