MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Access & Datenbanken > Microsoft Access
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 06.07.2006, 10:15   #1
Dr.Elch
MOF User
MOF User
Normal Acc2003 - Access on Citrix

Hi @all,

hoffe hier kann mir jemand weiterhelfen.
Ich betreibe eine Access2003 DB als Published Application auf einem Citrix Server. Über diesen Weg haben wir eine sehr hohe Performance selbst wenn via Modem oder Handy die Applikation ausgeführt wird.

Nun zum Problem:
Die Citrix connection wird als Anonymer User aufgebaut d.h. auf dem Server wird Temporär für die dauer der Verbindung ein neuer Windows User erstellt (Anon000) der beim trennen dann wieder gelöscht wird.
Dies hat zur Folge das beim Starten von Access jedesmal aufs neue, für jeden User die "erster Start" Abfragen erscheinen. Sprich Benutzername, Initialien und die Marko Sicherheitsabfrage.
Da die Datenbank über ein kleines VB Program (*.exe) gestartet wird konnte ich die Makro geschichte austricksen indem ich in der exe erst einen Registry Key für den Local User ändere und dann die DB starte.

Soetwas ähnliches würde ich auch gerne mit den User Infos machen jedoch weiß ich beim Besten Willen nicht welchen Key ich ändern muss bzw. wo diese überhaupt gespeichert werden.
Hat hier jemand eine Idee?

Danke für die Hilfe...

__________________

Dr.Elch
Win XP Prof. SP 2, Office 2003 Prof. SP1, VB6.0 Ent. SP 6, ORACLE 10g, Visual C++ 6.0 Ent., Visual C++ 2005 Expr.
Dr.Elch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 10.07.2006, 14:09   #2
Dr.Elch
Threadstarter Threadstarter
MOF User
MOF User
Standard

Hi,

hat denn niemand eine Idee?
Das wo würde mir voll und ganz reichen.

__________________

Dr.Elch
Win XP Prof. SP 2, Office 2003 Prof. SP1, VB6.0 Ent. SP 6, ORACLE 10g, Visual C++ 6.0 Ent., Visual C++ 2005 Expr.
Dr.Elch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 10.07.2006, 14:53   #3
Paul.Ostermeier
MOF Koryphäe
MOF Koryphäe
Standard

@Dr.

Du könntest versuchen Access mit nem /Profile zu starten

http://www.vb123.com/workbench/help/commandline.htm#


MfG
Paul
Paul.Ostermeier ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 14.07.2006, 07:11   #4
Dr.Elch
Threadstarter Threadstarter
MOF User
MOF User
Standard

Hallo Paul,

erstmal danke für die Idee.
Hat aber leider nichts gebracht. Ich hab auf dem Citrix Server ein Profil in der Registry angelegt und lasse Access darüber starten. Das funktioniert auch prima jedoch kommt die Bentzerabfrage nach wie vor.

Noch irgendwelche anderen Ideen?

Gruß

__________________

Dr.Elch
Win XP Prof. SP 2, Office 2003 Prof. SP1, VB6.0 Ent. SP 6, ORACLE 10g, Visual C++ 6.0 Ent., Visual C++ 2005 Expr.
Dr.Elch ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 18:52 Uhr.



Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.