MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 12.06.2019, 19:50   #1
noluma
Neuer Benutzer
Neuer Benutzer
Standard Excel2007 - Addition von 3 Sverweis Ergebnissen

Hallo zusammen,

ich habe 6 Spalten.
In Spalte 1 wähle in einer Auswahl etwas aus und der dazugehörige Wert wird in der nächsten Spalte angegeben.
Das ist dreimal hintereinander.
Jetzt möchte ich, die jeweiligen individuellen Ergebnisse addieren, doch meine Formel wird als Fehler angezeigt.

Wer kann helfen?

Meine Formeln funktioniert nicht, ist aber eh nicht die finale, da diese hier nur den jeweiligen VK-Wert addiert, aber nicht den zweiten Wert (Marge) zur Auswahl.
=Summe(((=WENNFEHLER(SVERWEIS(E77;$A$5000:$B$5004;2;FALSCH);""))+(=WENNFEHLER(SVERWEIS(G77;$D$5000:$E$5000;2;FALSCH);""))+(=WENNFEHLER(SVERWEIS(I77;$F$5000:$G$5001;2;FALSCH);"")))

Mein Ziel ist ein jeweils anderer Wert, sprich:
Wenn in Spalte 1 'Auswahl1' ausgewählt wird und in Spalte 2 der dazugehörige Wert 100 (z.B. VK) angegeben wird, möchte ich in der Formel, dann in einem anderen Kästchen nicht der Wert '100' (z.B. Verkaufspreis) genutzt wird, sondern die zur Auswahl 1 Marge (Gewinn), z.B. 50.
Davon habe ich drei Spalten mit Auswahl und dazugehörigen Wert (VK).

Ich möchte jenach Auswahl in Spalte 1, 3 und 5, die Addition der Werte Marge, nicht des VKs.
Wie lautet die Formel?
Die Sverweis-Formeln der Spalte 2, 4 und 6 stehen in meinem Formelansatz für die Addition.

Danke für die Hilfe im Voraus.
noluma ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.06.2019, 19:57   #2
MisterBurns
MOF Meister
MOF Meister
Standard

Code:

=Summe(((=WENNFEHLER(SVERWEIS(E77;$A$5000:$B$5004;2;FALSCH);""))+(=WENNFEHLER(SVERWEIS(G77;$D$5000:$E$5000;2;FALSCH);""))+(=WENNFEHLER(SVERWEIS(I77;$F$5000:$G$5001;2;FALSCH);"")))
Das Gleichheitszeichen gehört nur ganz an den Anfang, mittendrin hat das nichts zu suchen. Außerdem ist SUMME doch vollkommen unnötig. Du rechnest ja auch nicht
Code:

=SUMME(2+3+4)
oder?

__________________

Schöne Grüße
Berni
MisterBurns ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.06.2019, 20:44   #3
noluma
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Doch, ich rechne ja die Ergebniswerte zusammen, wie im Text erklärt!!
Und auch nur mit dem vorderen Gleichheitszeichen ergibt es einen Fehler:

=Summe(((WENNFEHLER(SVERWEIS(E77;$A$5000:$B$5004;2;FALSCH);""))+(WENNFEHLER(SVERWEIS(G77;$D$5000:$E$5000;2;FALSCH);""))+(WENNFEHLER(SVERWEIS(I77;$F$5000:$G$5001;2;FALSCH);"")))

Geändert von noluma (12.06.2019 um 20:46 Uhr).
noluma ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.06.2019, 20:45   #4
MisterBurns
MOF Meister
MOF Meister
Standard

Das ist mir schon klar, trotzdem ist SUMME unnötig. =2+3+4 ergibt genau das gleiche wie =SUMME(2+3+4). Was du machst ist wie Gürtel plus Hosenträger. Aber mach ruhig...

__________________

Schöne Grüße
Berni
MisterBurns ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.06.2019, 21:05   #5
noluma
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Ok, Berni, aber das ist dennoch keine Lösung meines Problems.

Auch =(((WENNFEHLER(SVERWEIS(E77;$A$5000:$B$5004;2;FALSCH);""))+(WENNFEHLER(SVERWEIS(G77;$D$5000:$E$5000;2;FALSCH);""))+(WENNFEHLER(SVERWEIS(I77;$F$5000:$G$5001;2;FALSCH);"")))
funktioniert nicht.
noluma ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.06.2019, 22:01   #6
Mase
MOF User
MOF User
Standard

Wennfehler(;0) anstelle "" ?

__________________

gruß
Marco
Mase ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.06.2019, 22:10   #7
MisterBurns
MOF Meister
MOF Meister
Standard

Das liegt daran, dass du im WENNFEHLER-Teil einen Leerstring für den Fehlerfall einbaust. Das ist letztlich wie ein Text zu sehen und Texte addiert Excel nur am 30. Februar. Gib stattdessen 0 für den Fehlerfall an, dann klappt es.
Mach dir außerdem das Leben leicht und spar die unnötigen Klammern ein.
Code:

=WENNFEHLER(SVERWEIS(E77;$A$5000:$B$5004;2;FALSCH);0)+WENNFEHLER(SVERWEIS(G77;$D$5000:$E$5000;2;FALSCH);0)+WENNFEHLER(SVERWEIS(I77;$F$5000:$G$5001;2;FALSCH);0)

__________________

Schöne Grüße
Berni
MisterBurns ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 13.06.2019, 03:51   #8
EarlFred
MOF Guru
MOF Guru
Standard

Code:

SVERWEIS(G77;$D$5000:$E$5000;2;FALSCH)
Eine riesengroße Formel, um genau eine Zelle (D5000) auf Übereinstimmung zu prüfen?
Alle 3 Sverweise haben andere Suchbereiche - ist das wirklich so gewollt?

__________________

Datum und Uhrzeit, Makrorekorder-Code entschlacken, {Matrixformeln}
Tutorials zu Pivottabellen: Kurzeinstieg; Dynamischer Datenbereich; Daten und Zeiten gruppieren
Für 7 meiner Beiträge haben sich die Hilfesuchenden mit einer Spende an Wikipedia, die Tafeln oder Hilfe für krebskranke Kinder eV bedankt (das entspricht 0,049% per 19.12.2018) - eine tolle Geste!

Geändert von EarlFred (13.06.2019 um 03:55 Uhr).
EarlFred ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 13.06.2019, 06:54   #9
MisterBurns
MOF Meister
MOF Meister
Standard

@Earlfred: Guter Einwand, auf das hatte ich gar nicht geachtet!

__________________

Schöne Grüße
Berni
MisterBurns ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 14.06.2019, 18:55   #10
noluma
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Top, Berni, daran lag es! Vielen Dank!!

@EarlFred: Es gilt drei verschiedene Ergebnisse zu addieren, die aus je drei verschieden möglichen Werten sich ergeben.
Das ist aber wie gesagt nur ein Zwischenschritt. Die reine Addition geht ja viel einfacher. Final soll ein zweiter Wert, der für die jeweiligen Werte steht addiert werden.
noluma ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 08:22 Uhr.



Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.