MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 15.05.2019, 10:07   #1
Schlumpfine910
Neuer Benutzer
Neuer Benutzer
Standard Excel 2013 - Wenn Wort in Zelle, dann...

Guten Morgen.

Ich komme mal wieder mit einem kleinen Problem und vielleicht könnt Ihr mir wieder helfen.

Ich habe in Spalte D2150 Behandlungstexte stehen. In diesem Text stehen u.a. "ambulante Behandlung" oder "stationäre Behandlung".

Im ersten Schritt möchte ich jetzt, dass wenn ambulant als Text dort steht, dass in Spalte E2:E150 das Wort ambulant eingetragen wird.
Ich habe es mit dieser Formel probiert. Leider klappt das irgendwie nicht.

Code:

=WENN(FINDEN("ambulant";D2);"ambulant";"stationär")
Hier wirft mir Excel "'#WERT" aus. Kann mir jemand helfen.

LG
Schlumpfine910 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 15.05.2019, 10:09   #2
MisterBurns
MOF Meister
MOF Meister
Standard

Die Formel ist korrekt, allerdings unterscheidet sie nach Groß- und Kleinschreibung. Verwende statt FINDEN besser SUCHEN, dann klappt es.

BTW: Es gibt keine Spalte D2:D150. Es gibt nur eine Spalte D und einen Bereich D2:D150

__________________

Schöne Grüße
Berni
MisterBurns ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 15.05.2019, 10:11   #3
Schlumpfine910
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Ich nochmal. Habe jetzt mit dieser Formel mir die Lösung gebastelt.

Code:

=WENN(ISTFEHLER(FINDEN("ambulant";D2));"ambulant";"stationär")
Klappt auch. Gibt es eine Möglichkeit das mit zwei Bedingungen zu machen. Beispiel, wenn nicht nur "ambulant" dort zu finden ist, sondern "ambulant" oder "einmalig"? Muss eine ODER-Verknüpfung sein, keine UND!

Danke vorab.

LG
Schlumpfine910 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 15.05.2019, 10:30   #4
MisterBurns
MOF Meister
MOF Meister
Standard

Siehe meine Lösung oben.
Die von dir angegeben "Lösung" ist nicht richtig. Denn nun hast du genau den umgekehrten Fall. Wenn "ambulant" nicht gefunden wird, schreibt Excel "ambulant" hin. Wird es dagegen gefunden, schreibt es "stationär". Du müsstest also die DANN-SONST Bedingungen vertauschen.

Zur zweiten Frage:
Code:

=WENN(ODER(ISTZAHL(SUCHEN("ambulant";D2));ISTZAHL(SUCHEN("einmalig";D2)));"ambulant";"stationär")

__________________

Schöne Grüße
Berni
MisterBurns ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 15.05.2019, 10:39   #5
Schlumpfine910
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Super. Danke Dir.

Stimmt jetzt wo Du es sagst.

Klappt!!!
Schlumpfine910 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 01:27 Uhr.



Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.