MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 02.01.2011, 17:59   #1
RoteSocke
Standard Excel2007 - Zeitzuschläge mit Formel berechnen

Hallo liebe Forumsmitglieder,

ich suche schon seit langem nach einer Lösung.
Folgende Tabelle habe ich;

In C4 =Arbeitsbeginn
In D4 =Arbeitszeitende, auch nach 20:00 möglich
In M4= sollen 20% Zuschlag stehen auf die Zeit zwischen 18:30 und 20:00 Uhr, auch wenn Arbeitszeitende in D4 z.B. 20:30 ist
In O4= sollen 50 % Zuschlag stehen, diese Formel habe ich gefunden,
=WENN(D5>"20:00"*1;(D5-"20:00"*1)*24*50/100;(" "))

Die Zuschläge 20 + 50 % sollen jeweils in einer eigenen Zelle stehen.

Vielleicht kann mir jemand helfen.

Gruß

RS
 
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 02.01.2011, 21:50   #2
josef e
MOF Meister
MOF Meister
Standard


Hallo ?,

meinst du so?

Tabelle6

 CDEFG
1BeginnEndeAZ ges.+20%+50%
209:0020:4511,750,450,38
307:3018:0010,500,000,00
409:3018:309,000,000,00
509:3022:0012,500,701,00

Formeln der Tabelle
ZelleFormel
E2=(D2-C2)*24
F2=MAX(0;((D2-ZEIT(18;30;0))*0,2)*24)
G2=MAX(0;((D2-ZEIT(20;0;0))*0,5)*24)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Sepp
josef e ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 02.01.2011, 22:09   #3
RoteSocke
Standard

Ja, so ähnlich.
In Deinem Beispiel wird die Zeit zwischen 18:30 und 20:45 mit 20 % Zuschlag berechnet.
Es soll aber nur bis 20:00 Uhr der 20 % Zuschlag berechnet werden und ab 20:00 dann 50 %.
In Zelle F 2 dürfte maximal 0,30 stehen.
Und da bin ich bisher nicht hinter gekommen. Vielleicht hast Du da eine Lösung?

Danke
RS
 
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 02.01.2011, 22:42   #4
josef e
MOF Meister
MOF Meister
Standard


Hallo ?

dann halt so.

Tabelle6

 CDEFG
1BeginnEndeAZ ges.+20%+50%
209:0020:4511,750,300,38
307:3018:0010,500,000,00
409:3018:309,000,000,00
509:3022:0012,500,301,00

Formeln der Tabelle
ZelleFormel
E2=(D2-C2)*24
F2=MAX(0;((MIN(D2;ZEIT(20;0;0))-ZEIT(18;30;0))*0,2)*24)
G2=MAX(0;((D2-ZEIT(20;0;0))*0,5)*24)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Sepp
josef e ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 03.01.2011, 04:35   #5
RoteSocke
Standard

Ja, genau so.

Vielen Dank für Deine Mühe.
 
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 03.01.2011, 18:47   #6
RoteSocke
Standard

Sorry Sepp,

dass ich schon wieder nerve.
Habe heute morgen nur schnell die Formel in meine Tabelle kopiert und nicht mit anderen Endzeiten in F2 ausprobiert.
Die 0,30 werden in F2 auch angezeigt wenn die Zelle D2 leer ist.
Es kommt bei uns auch vor, dass nur an 3 oder 4 Tagen von den einzelnen MA gearbeitet wird.
Dann ergibt die Summe von Spalte F einen falschen Gesamtzuschlag.
Mit der Formel in Zelle G2

=WENN(D5>"20:00"*1;(D5-"20:00"*1)*24*50/100;(" "))

ist bei AzEnde vor 20:00, die Zelle G2 leer.

Wenn das auch mit der Zelle F2 gehen würde, wäre echt super.

Geändert von RoteSocke (03.01.2011 um 19:28 Uhr).
 
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 03.01.2011, 19:31   #7
josef e
MOF Meister
MOF Meister
Standard


Hallo ?,

na das wirst du wohl selber erledigen können!
Wenn(D5="";"";MAX(0;((MIN(D5;ZEIT(20;0;0))-ZEIT(18;30;0))*0,2)*24))


Wenn ein Formelergebnis ine leere Zelle darstellen soll, schreibt man im Algemeinen "", deine Version (" ") ist mir neu, was soll das bedeuten?




Gruß Sepp
josef e ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 04.01.2011, 17:07   #8
RoteSocke
Standard

Hallo Sepp,
dank Deiner Hilfe habe ich die Tabelle jetzt so wie ich es wollte.
Mit Deinem letzten Tipp habe ich etwas rumprobiert und habe es geschafft, Juhuuu.
Ehrgeiz ist auch gut, bin ein Anfänger.
Zelle F 3 bleibt leer wenn ArbtEnde vor 18:30 ist.
Zelle G 4 bleibt leer wenn ArbtEnde zwischen 18:30 und 20:00.

„meine“ Version für die Darstellung einer leeren Zelle bezieht sich auf den Teil der Formel „Wenn;Dann;SONST“, hab ich irgendwo im Netz gefunden, habe dann Deine Version ausprobiert und es geht auch.
Nur in der Formel in Zelle F 6 „WENN(ODER(…….. muss die Leertaste stehen, ansonsten wird in F 6 auch 0,30 angezeigt obwohl die Zelle D 6 leer ist.
Du wirst das bestimmt wissen, ich musste ein wenig probieren.
Also nochmals vielen Dank für Deine Hilfe.

Tabelle1

 CDEFG
1Arbeitszeit  
2BeginnEndeGesamt20%55%
307:0015:008,00  
414:0019:005,000,10 
516:0020:454,750,300,41
6   0,30 

Formeln der Tabelle
ZelleFormel
E3=WENN(D3>C3;(D3-C3)*24;(""))
F3=WENN(ODER(D3=" ";D3>"18:30"*1);MAX(0;((MIN(D3;ZEIT(20;0;0))-ZEIT(18;30;0))*0,2)*24);"")
G3=WENN(D3>"20:00"*1;(D3-"20:00"*1)*24*0,55;(""))
E4=WENN(D4>C4;(D4-C4)*24;(""))
F4=WENN(ODER(D4=" ";D4>"18:30"*1);MAX(0;((MIN(D4;ZEIT(20;0;0))-ZEIT(18;30;0))*0,2)*24);"")
G4=WENN(D4>"20:00"*1;(D4-"20:00"*1)*24*0,55;(""))
E5=WENN(D5>C5;(D5-C5)*24;(""))
F5=WENN(ODER(D5=" ";D5>"18:30"*1);MAX(0;((MIN(D5;ZEIT(20;0;0))-ZEIT(18;30;0))*0,2)*24);"")
G5=WENN(D5>"20:00"*1;(D5-"20:00"*1)*24*0,55;(""))
E6=WENN(D6>C6;(D6-C6)*24;(""))
F6=WENN(ODER(D6="";D6>"18:30"*1);MAX(0;((MIN(D6;ZEIT(20;0;0))-ZEIT(18;30;0))*0,2)*24);"")
G6=WENN(D6>"20:00"*1;(D6-"20:00"*1)*24*0,55;(""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Geändert von RoteSocke (04.01.2011 um 17:17 Uhr).
 
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 16.04.2018, 15:09   #9
DannO12
Neuer Benutzer
Neuer Benutzer
Standard

Hallo,

der Thread ist zwar uralt, trotzdem probiere ich es.
Die Formeln kann ich für mein Vorhaben super nutzen (Danke!), abgesehen von der Berechnung für die Nachtzuschläge.
Es wäre toll, wenn mir jemand die Formel:
=WENN(D6>"20:00"*1;(D6-"20:00"*1)*24*0,55;(""))
so umändert, dass sie die Zuschläge bis 6 Uhr morgens berechnet, eine neue Formel wäre mir auch sehr recht, wichtig ist nur, dass die Zuschläge ab 20:00 Uhr bis 06:00 Uhr mit einem Zuschlag von 55% errechnen kann.
Für Sonn und- Feiertage benötige ich ebenso eine Lösung, von 00:00-24:00 Uhr mit 100% Zuschlag.


Danke im voraus
DannO12 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 16.04.2018, 15:11   #10
steve1da
MOF Meister
MOF Meister
Standard

Hola,

http://www.excelformeln.de/formeln.html?welcher=9

Für alles weitere wäre eine Beispieldatei hilfreich.

Gruß,
steve1da
steve1da ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 16.04.2018, 19:23   #11
lupo1
MOF Koryphäe
MOF Koryphäe
Standard

Hier eine Datei:
  • Berücksichtigt ganze Feiertage und Wochenenden für ein ganzes Kalenderjahr
  • Zieht die gesetzlichen Pausen sauber in der jeweiligen Zuschlagzeit ab, auch überlappend abgrenzend, nicht arbeitnehmerschädlich!
  • Kann als .xls gespeichert werden und somit unter xl2003- laufen. Lade ich hier nicht hoch; bitte auf Konstruktionsmakro warten!
  • Bitte Hinweis oben links in der Datei nach Öffnen befolgen (H4:M368: Strg-U; erspart dem Forum 12 KB Dateianhanggröße ggü 34 KB, haha!)
Kann schnell erweitert werden auf:
  • halbe Feiertage (24.12. und 31.12.)
  • selbst rechnende Feiertage
  • wochentagsindividuelle Zuschlagzeiten (bspw. Fr. Spät ab 16 statt 18 Uhr)
  • mehr Untergliederung als nur Tag, Nacht, WE-FT
  • zusätzliche Pausen
Letztere Features habe ich hier weggelassen, um es zunächst einfach zu halten. Ein Konstruktionsmakro wird noch geliefert; ich hätte aber gern positives Feedback.
Angehängte Dateien
Dateityp: xlsx 180416 Schichtarbeit-mit-Feiertagen.xlsx (21,6 KB, 12x aufgerufen)

__________________

MfG Lupo - und ein Hallo ebenfalls!

Geändert von lupo1 (16.04.2018 um 20:12 Uhr).
lupo1 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 16.04.2018, 20:31   #12
DannO12
Neuer Benutzer
Neuer Benutzer
Standard

Hi steve1da,

hier die Datei. Den Link von dir kenne ich bereits... um das Ding zu verstehen sind meine Kenntnisse einfach zu schlecht.

@lupo1,
vielen Dank für die Datei, hilft mir leider nicht weiter. Zum einen möchte ich gerne selbst eine Datei erstellen, da ich künftig Excel lernen möchte und zum anderen, wie oben beschrieben, bin ich, was Excel-Formeln und Funktionen angeht, noch Anfänger.
Angehängte Dateien
Dateityp: xlsx Arbeitszeit.xlsx (9,3 KB, 11x aufgerufen)
DannO12 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 16.04.2018, 20:39   #13
lupo1
MOF Koryphäe
MOF Koryphäe
Standard

Na, dann viel Spaß.

Das Thema Zuschläge ist nämlich nicht trivial.

__________________

MfG Lupo - und ein Hallo ebenfalls!
lupo1 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 17.04.2018, 17:35   #14
DannO12
Neuer Benutzer
Neuer Benutzer
Standard

@lupo

wenn du mir helfen möchtest, dann wäre es nett, wenn du mein Anliegen berücksichtigst.
DannO12 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 17.04.2018, 18:18   #15
lupo1
MOF Koryphäe
MOF Koryphäe
Standard

Meine Datei ist genau zu Deinem Beispiel (0%, 55%, 100%) veröffentlicht. Hast Du sie geöffnet und mal Testdaten eingegeben?

Was ich noch ändern werde, ist, dass die Tage des Jahres und die Feiertage nicht darüber stehen, sondern in einem neuen Blatt, wo sie dann auch nicht ausgeblendet werden müssen. Das macht die Verwaltung dann leichter.

Falls Du mit Anliegen meinst, ich würde Dir bei einer eigenen Datei helfen: Nein (ergibt für mich keinen Sinn). Aber ich wandle meine gern für Dich ab.

Das Konstruktionsmakro wird übrigens dann dort veröffentlicht.

__________________

MfG Lupo - und ein Hallo ebenfalls!

Geändert von lupo1 (17.04.2018 um 18:25 Uhr).
lupo1 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 11:46 Uhr.


Partner und Co.
Access-Paradies -Alles rund um die Datenbank Microsoft Access -Code -Programme-Tools -Tipps   Kostenlose Tipps & Tricks, Downloads und Programme   www.kulpa-online.com - Tipps - Tricks - Tutorials - Meinungen - Downloads uvm...   vb@rchiv · Willkommen in der Welt der VB Programmierung   Access-Garhammer - Hier finden Sie jede Menge Beispiel-Datenbanken zu Access und mehr ...   mcseboard.de   Die Top Seite für Excel-VBA-Makros uvm.

Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.