MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 12.12.2017, 12:40   #1
schmil
Neuer Benutzer
Neuer Benutzer
Standard Frage - Excel, gebe Wert, der Kriterium am nächsten

Hallo, ich habe eine Tabelle mit Werten aus verschiedenen Jahren folgender Form:

[ Platzierung ] [2015] [2016] [2017]
[ 1 ] [2,5] [3,2] [3,3]
...


Ich möchte eine Formel schreiben, welche mir die Platzierung ausgeben würde, welche ein Wert X in einem Jahr erzielt hätte. Excel soll mir also den Wert der Spalte A ausgeben, wenn der Wert aus der dazugehörigen Spalte B das erste Mal kleiner ist als mein Kriterium.

Beispiel im Anhang.
Angehängte Dateien
Dateityp: xls Beispiel.xls (32,5 KB, 7x aufgerufen)
schmil ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.12.2017, 13:57   #2
Oge
MOF Profi
MOF Profi
Standard

Hallo s...,

es ginge zB.:
Code:

=WENNFEHLER(VERGLEICH(C11;C2:C7;-1)+1;1)-(INDEX(C2:C7;VERGLEICH(C11;C2:C7;-1))=C11)

__________________

helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.
Oge ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.12.2017, 14:44   #3
schmil
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

MEGA! WOW. Danke!!!!!
schmil ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.12.2017, 14:45   #4
Superingo2
MOF Koryphäe
MOF Koryphäe
Standard

Hallo Helmut,

meinen Respekt für Deine Lösung!
Mach nur um die Subtraktion besser auch noch ein WENNFEHLER für die Fälle größer dem größtem Wert ;-)

Kollegiale Grüße
Ingo

__________________

Viel Spaß


.....ein Feedback wäre nett.....
Superingo2 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.12.2017, 16:10   #5
Frank Furter
MOF Koryphäe
MOF Koryphäe
Standard

Hallo, ich komme zu den selben Ergebnissen mit..:

=WENNFEHLER(INDEX($A$2:$A$7;ZÄHLENWENN(B$2:B$7;">"&B11)+1);"")

bzw.:

=WENNFEHLER(ZÄHLENWENN(B$2:B$7;">"&B11)+1;"")

__________________

gruß vom Frank Furter mit hiob's botschaften

Geändert von Frank Furter (12.12.2017 um 16:13 Uhr).
Frank Furter ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.12.2017, 16:11   #6
Oge
MOF Profi
MOF Profi
Standard

Hallo s...,

hier die Korrektur nach Ingo's Bemerkung.
Code:

=WENNFEHLER(VERGLEICH(B11;B2:B7;-1)+1-(INDEX(B2:B7;VERGLEICH(B11;B2:B7;-1))=B11);1)

__________________

helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.
Oge ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 13.12.2017, 08:15   #7
Superingo2
MOF Koryphäe
MOF Koryphäe
Standard

Hallo Frank Furter,

schöne effektive Lösung!
Wie immer von Dir.

Kollegiale Grüße
Ingo

__________________

Viel Spaß


.....ein Feedback wäre nett.....
Superingo2 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 08:03 Uhr.


Partner und Co.
Access-Paradies -Alles rund um die Datenbank Microsoft Access -Code -Programme-Tools -Tipps   Kostenlose Tipps & Tricks, Downloads und Programme   www.kulpa-online.com - Tipps - Tricks - Tutorials - Meinungen - Downloads uvm...   vb@rchiv · Willkommen in der Welt der VB Programmierung   Access-Garhammer - Hier finden Sie jede Menge Beispiel-Datenbanken zu Access und mehr ...   mcseboard.de   Die Top Seite für Excel-VBA-Makros uvm.

Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.