MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 04.12.2018, 17:52   #1
tombal
Neuer Benutzer
Neuer Benutzer
Standard Frage - Verschiedene WENN-Bedingungen und DANN-Folgen

Hallo

Ausgangslage: der Wert einer Ziffer in einer Ziffernfolge in einer Zelle enthält dummerweise unter gewissen Bedingungen mehrere Bedeutungen.

Die Ziffernfolge: 19.343.XYZ.AB; wichtig sind die Ziffern an Stelle Y und Z.
Y-Ziffern stehen für Folgendes: 4 = NMG, 5 = Math, 6 = Deutsch, 7 = Gestalten, 8 = Musik, 9 = BuS; habe ich ausgelesen in Spalte Q.
Z-Ziffern stehen
- einmal für den Zyklus: 1= 1. Zyklus, 2=2. Zyklus, 3=3. Zyklus (mehr gibts nicht); habe ich in Spalte P ausgelesen.
NUN ABER: Wenn Y=4(bzw. Wert in Spalte Q) und Z=3 (bzw. Wert in Spalte P), dann hat der Y-Wert eine neue Bedeutung, nämlich "NT", was ich in Spalte S schreiben möchte. Dito Y=4 und Z=4, dann wäre der neue S-Wert "RZG" und zusätzlich der neue Z-Wert in Spalte R müsste 3 lauten.
Auch Kombinationen von Y=7 mit versch. Z-Werten verlangen neue Werte in S und R (vgl. Formeln unten).

Ich habe für beide neuen Spalten folgende Formeln erstellt:
Für S-Spalte: =WENN(UND(Q2=4;P2=3);"NT";WENN(P2=4;"RZG";WENN(UND(Q2=7;P2=1);"BG";WENN(UND(Q2=7;P2=2);"TTG";WENN(UND(Q2=7;P2=3);"BG";WENN(UND(Q2=7;P2=4);"TTG";WENN(UND(Q2=7;P2=5);"BG";WENN(UND(Q2=7;P2=6);"TecG";WENN(UND(Q2=7;P2=7);"TexG";Q2)))))))))

Für R-Spalte: =WENN(P2=4;3;WENN(UND(Q2=7;P2=2);1;WENN(UND(Q2=7;P2=3);2;WENN(UND(Q2=7;P2=4);2;W ENN(UND(Q2=7;P2=5);3;WENN(UND(Q2=7;P2=6);3;WENN(UND(Q2=7;P2=7);3;P2)))))))

Problem nun: Formel gibt nur den "Ansonsten"-Wert raus, also den Wert aus Q2 bzw. P2.

Wo liegt mein Überlegungsfehler?

Danke für Tipps und beste Grüsse
Tom
tombal ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 04.12.2018, 18:49   #2
Der Steuerfuzzi
MOF User
MOF User
Standard

Hallo,

mein Tipp: Lade hier eine Beispieltabelle hoch. Dann hat der Helfer mehr Freude ;-)

__________________

Gruß
Michael
Der Steuerfuzzi ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 05.12.2018, 03:37   #3
WS-53
MOF Koryphäe
MOF Koryphäe
Standard

Hallo Tom,

vermutlich sind deine Formel zum füllen der Spalte Q und P falsch. Denn wenn du die Spalten per Hand füllst, dann ermitteln deine Formel die gewünschen Werte.

Allerdings muss m.E. die 2. bzw. 1. Wenn-Abfrage an das Ende gestellt werden. Und wenn du dann bei der Foremleingabe mit Zeilenumbruch arbeitest, werden die Formel auch lesbar.

Falsch:

=WENN(UND(Q2=4;P2=3);"NT";
WENN(P2=4;"RZG";
WENN(UND(Q2=7;P2=1);"BG";
WENN(UND(Q2=7;P2=2);"TTG";
WENN(UND(Q2=7;P2=3);"BG";
WENN(UND(Q2=7;P2=4);"TTG";
WENN(UND(Q2=7;P2=5);"BG";
WENN(UND(Q2=7;P2=6);"TecG";
WENN(UND(Q2=7;P2=7);"TexG";
Q2)))))))))

=WENN(P2=4;3;
WENN(UND(Q2=7;P2=2);1;
WENN(UND(Q2=7;P2=3);2;
WENN(UND(Q2=7;P2=4);2;
WENN(UND(Q2=7;P2=5);3;
WENN(UND(Q2=7;P2=6);3;
WENN(UND(Q2=7;P2=7);3;
P2)))))))

Richtig:

=WENN(UND(Q2=4;P2=3);"NT";
WENN(P2=4;"RZG";
WENN(UND(Q2=7;P2=1);"BG";
WENN(UND(Q2=7;P2=2);"TTG";
WENN(UND(Q2=7;P2=3);"BG";
WENN(UND(Q2=7;P2=4);"TTG";
WENN(UND(Q2=7;P2=5);"BG";
WENN(UND(Q2=7;P2=6);"TecG";
WENN(UND(Q2=7;P2=7);"TexG";
WENN(P2=4;"RZG";
Q2)))))))))

=WENN(UND(Q2=7;P2=2);1;
WENN(UND(Q2=7;P2=3);2;
WENN(UND(Q2=7;P2=4);2;
WENN(UND(Q2=7;P2=5);3;
WENN(UND(Q2=7;P2=6);3;
WENN(UND(Q2=7;P2=7);3;
WENN(P2=4;3;
P2)))))))

__________________

VG, WS-53


>>> Ein Spezialist kann nicht viel, dies aber gut. Die Steigerung ist, noch weniger noch besser zu können. Die Krönung ist, nichts zu können, aber darin perfekt zu sein! Es gibt aber auch Naturtalente, die überspringen die Ersten beiden Stufen. <<<

Übrigens, Feedback, egal welcher Art, ist immer hilfreich. Und erledigte Beiträge sollten auch den Status "erledigt" erhalten.
WS-53 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 05.12.2018, 10:06   #4
tombal
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Danke für den Hinweis. Ich habe das ausprobiert, ergibt aber das gleiche Ergebnis.
Ich lade auch noch eine Testtabelle hoch.

Beste Grüsse
Tom
Angehängte Dateien
Dateityp: xlsx Testtabelle.xlsx (12,2 KB, 5x aufgerufen)
tombal ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 05.12.2018, 10:16   #5
Der Steuerfuzzi
MOF User
MOF User
Standard

Kann es sein, dass Du in der Datei oder in Deiner ersten Beschreibung Y und Z vertauscht hast?Außerdem steht in Deiner Beschreibung, dass Z die Werte 1 bis 3 annehmen kann, in der Datei stehen aber Werte von 1 bis 7 drin.

Hilfreich wäre auch eine Aufstellung, welche Werte bei welcher Kombination als Ergebnis herauskommen sollen. Zusätzlich könntest Du in der Datei Dein Wunschergebnis eintragen.

__________________

Gruß
Michael
Der Steuerfuzzi ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 05.12.2018, 14:58   #6
caplio
MOF User
MOF User
Standard

Zitat:

Ich habe das ausprobiert, ergibt aber das gleiche Ergebnis.

In deiner Testdatei enthalten Spalte B + C Text, deshalb geht es nicht.
Nimm die Werte mal 1 und schau noch einmal.
Code:

=TEIL(A2;9;1)*1
caplio ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 05.12.2018, 19:26   #7
WS-53
MOF Koryphäe
MOF Koryphäe
Standard

Hallo Tom,

du kannst überhaupt das probiert haben, was ich beschrieben habe. Denn sonst hätte es auch bei dir funktioniert !!!

Und meine Vermutung war richtig. Denn wenn du mit der Funktion Teil() etwas in andere Zellen übernimmst, dann ist das Ergebnis Text. Und eine Text Eins ist halt etwas anderes als als die Zahl 1.

weiterhin frage ich mich, warum du anfangs Spalten und Formeln beschreibst, die dann in deiner Mustermappe gar nicht vorkommen ???

Sollen mit diesen Maßnahmen die verwirrt werden, die bereit sind, dir kostenlos zu helfen ???

Weiterhin hat der Steuerfuzzi ja auch schon darauf hingewiesen, dass du in deinen Formeln Werte abfragst, die es laut deiner Beschreibung gar nicht geben dürfte.

__________________

VG, WS-53


>>> Ein Spezialist kann nicht viel, dies aber gut. Die Steigerung ist, noch weniger noch besser zu können. Die Krönung ist, nichts zu können, aber darin perfekt zu sein! Es gibt aber auch Naturtalente, die überspringen die Ersten beiden Stufen. <<<

Übrigens, Feedback, egal welcher Art, ist immer hilfreich. Und erledigte Beiträge sollten auch den Status "erledigt" erhalten.
WS-53 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 06.12.2018, 11:06   #8
tombal
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Liebe Beitragende

Vielen Dank für die Hinweise und sorry, dass ich mich missverständlich ausgedrückt hatte. Dass, wie Steuerfuzzi bemerkte, die Ziffer an der Stelle Z eigentlich nur die Werte 1 bis 3 annehmen sollte, aber in Kombination mit den Ziffern 4 und 7 an der Stelle Y eben noch weitere Bedeutungen hat, war gerade das Ausgangsproblem.
Und die anderen Spaltenbeschreibungen bei meinem ersten Beitrag entsprechen der Originaltabelle, weil ich nicht auf die Idee kam, eine Testtabelle zu erstellen.

Mit der Umwandlung der Werte der "Teil"-Funktion in Zahlen funktioniert die Wenn-Dann-Funktion so einwandfrei.

Noch einmal Danke und beste Grüsse
Tom
tombal ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 07.12.2018, 15:58   #9
tombal
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Bei der Kontrolle habe ich im Ergebnis einen Fehler ergeben, dessen Ursache ich auch auf den zweiten Blick in der Formel nicht sehe. Eine Bedingungskombination funktioniert nicht:

= WENN(B2=4;3;
WENN(UND(C2=7;B2=2);1;
WENN(UND(C2=7;B2=3);2;
WENN(UND(C2=7;B2=4);2;
WENN(UND(C2=7;B2=5);3;
WENN(UND(C2=7;B2=6);3;
WENN(UND(C2=7;B2=7);3;
B2)))))))

Gemäss Formel sollte der Wert bei dieser Bedingung doch 2 ergeben, ergibt aber 3?! (vgl. Testtabelle im Anhang)
Bei den anderen Bedingungen stimmt das Ergebnis.
Angehängte Dateien
Dateityp: xlsx Testtabelle.xlsx (13,5 KB, 0x aufgerufen)
tombal ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 07.12.2018, 16:09   #10
tombal
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

Habe die Umstellung in der Formel, wie ja schon von WS-53 angegeben, vorgenommen, dann klappt es. Kann mir jemand erklären, warum?
tombal ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 09:13 Uhr.


Partner und Co.
Access-Paradies -Alles rund um die Datenbank Microsoft Access -Code -Programme-Tools -Tipps   Kostenlose Tipps & Tricks, Downloads und Programme   www.kulpa-online.com - Tipps - Tricks - Tutorials - Meinungen - Downloads uvm...   vb@rchiv · Willkommen in der Welt der VB Programmierung   Access-Garhammer - Hier finden Sie jede Menge Beispiel-Datenbanken zu Access und mehr ...   mcseboard.de   Die Top Seite für Excel-VBA-Makros uvm.

Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.