MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 11.02.2019, 19:48   #1
ElleMrLA
Neuer Benutzer
Neuer Benutzer
Standard Formel - Zeilen wiederholen

Hallo liebe Excelperten,

ich habe eine Original-Tabelle vorliegen, in welcher in einer Spalte Wiederholungen stehen.
In einer neuen Tabelle sollen per Formel die einzelnen Einträge so oft wiederholt werden, wie in der Spalte Wiederholungen angegeben ist.

Ist so etwas mit Formeln lösbar?

Ich bitte um Eure geschätzte Hilfe.

Liebe Grüße
Elle
PS: Ich hänge mal ein Beispiel per HTML an und hoffe, das klappt (ist mein erster Post hier...)

Beispiel

 ABCDEFG
1Originaltabelle    Wunschergebnis 
2NrNameWiederholungen  NrName
31Müller2  1Müller
42Meier5  1Müller
53Schulze3  2Meier
64Lehmann1  2Meier
7     2Meier
8     2Meier
9     2Meier
10     3Schulze
11     3Schulze
12     3Schulze
13     4Lehmann


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
ElleMrLA ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 11.02.2019, 20:11   #2
Drogist
MOF Profi
MOF Profi
Standard

Moin Elle,
ob es mit einer Formel in dem von dir gemeinten Sinne geht, weiß ich nicht. Aber wahrscheinlich ja. Ich löse so etwas mit Power Query, -> http://www.excel-ist-sexy.de/power-query-das-add-in/ ... (auch mit einer Formel, obwohl da sehr viel ausschließlich mit ein paar Mausklicks zu erledigen ist).

__________________

Internette Grüße
Drogist

(Gut) Gefunden bei Storax: "This isn't a code writing service, you need to do some research and have a go at writing some of your own code."
Ich verwende Excel 2019. Wenn du keine Angaben über deine Version gemacht hast gehe ich davon aus, dass auch du mindestens diese Version hast.

¿¿ Wer schützt mich vor den Datenschützern ??
Drogist ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 11.02.2019, 22:18   #3
aloys78
MOF Meister
MOF Meister
Standard

Hallo,

mein Vorschlag.

Gruß
Aloys
Angehängte Dateien
Dateityp: xlsx Elle_Formel.xlsx (16,2 KB, 2x aufgerufen)
aloys78 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 12.02.2019, 00:51   #4
Frank Furter
MOF Koryphäe
MOF Koryphäe
Standard

Hi Aloys, guter Job. Ich bin aber eher beim Drogisten. In Power Query ist das in Windeseile gemacht. Auch mit null-Einträgen und ohne Formelvorrat. Da müsste man formeltechnisch nachbessern...

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJ
2NrNameWiederholung  NrName NrName
31Müller2  1Müller 1Müller
42Meier1  1Müller 1Müller
53Schulze0  2Meier 2Meier
64Lehmann3  3Schulze 4Lehmann
7     4Lehmann 4Lehmann
8     4Lehmann 4Lehmann
9     4Lehmann   
10     5Lehmann   
11     #BEZUG!#BEZUG!   
12     #BEZUG!#BEZUG!   
13     #BEZUG!#BEZUG!   

ZelleFormel
F3=A3
G3=SVERWEIS($F3;$A$3:$B$6;2)
F4=WENN(ZÄHLENWENN($F$3:$F3;$F3)<INDEX($C$3:$C$6;$F3);$F3;$F3+1)
G4=SVERWEIS($F4;$A$3:$B$6;2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Aber es war ja eine Formellösung gefragt... und keine XL-Version angegeben... Ab XL2010 eine Aufgabe wie gemalt für Power Query...

__________________

gruß vom Frank Furter mit hiob's botschaften
Frank Furter ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 12:28 Uhr.



Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.