MS-Office-Forum

Zurück   MS-Office-Forum > Microsoft Office > Microsoft Excel
Registrieren Forum Hilfe Alle Foren als gelesen markieren

Banner und Co.

Antworten
Ads
Themen-Optionen Ansicht
Alt 09.02.2018, 11:35   #1
Dialux83
Neuer Benutzer
Neuer Benutzer
Standard Formel - SVERWEIS Verhalten

Ich habe ein Problem bei meinem Sverweis: Dieser liefert mir falsche Ergebnisse:
So sieht es aus (Habe 2 Tabellenblätter):

=WENN(WENNFEHLER(ODER(
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="BS";
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="UR";
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="FT";
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="FE";
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="AW";
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="KH";
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="SA";
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="PK";
(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52)))="AT")
;0);"Frei";"Planbar")

Hier ein Beispiel der Ausgangsdaten in Tabelle Ressourcenplan:
BS BS BS BS BS BS "leer" "leer" "leer"

Ergebnis mit obigen s-Verweis:
Frei Frei Frei Frei Frei Frei Frei Frei Frei

Soll:
Frei Frei Frei Frei Frei Frei "Planbar" "Planbar" "Planbar"

Warum ist das so?
Danke
Dialux83 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 11:42   #2
steve1da
MOF Meister
MOF Meister
Standard

Hola,

deine Sverweise haben keinen vierten Parameter. Dann muss die Suchmatix aufsteigend sortiert sein. Setz den mal auf FALSCH.

Gruß,
steve1da
steve1da ist gerade online  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 12:23   #3
Dialux83
Threadstarter Threadstarter
Neuer Benutzer
Neuer Benutzer
Standard

DANKE Steve, das wars!
Dialux83 ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Alt 09.02.2018, 14:04   #4
EarlFred
MOF Guru
MOF Guru
Standard

Hallo,

könnte man auch noch etwas einkürzen:
Code:

=WENN(
   WENNFEHLER(
      MAX(--(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52);0)={"BS"."UR"."FT"."FE"."AW"."KH"."SA"."PK"."AT"}));
      0);
   "Frei";
   "Planbar")
oder
Code:

=WENN(
   WENNFEHLER(
      FINDEN(SVERWEIS($E16;Ressourcenplan!$C$21:$NW$40;ZEILE(BB52);0);"BS#UR#FT#FE#AW#KH#SA#PK#AT");
      0);
   "Frei";
   "Planbar")
Grüße
EarlFred

__________________

Datum und Uhrzeit, Makrorekorder-Code entschlacken, {Matrixformeln}
Tutorials zu Pivottabellen: Kurzeinstieg; Dynamischer Datenbereich; Daten und Zeiten gruppieren
Für 5 meiner Beiträge haben sich die Hilfesuchenden mit einer Spende an Wikipedia, die Tafeln oder Hilfe für krebskranke Kinder eV bedankt (das entspricht 0,037% per 04.04.2018) - eine tolle Geste!

Geändert von EarlFred (09.02.2018 um 14:08 Uhr).
EarlFred ist offline  
verlinken auf Del.icio.us Diese Seite zu Mister Wong hinzufügen
Antworten Auf Beitrag antworten
Ads
Antworten


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Besucher: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge anzufügen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

vB Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist An.
Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 10:50 Uhr.


Partner und Co.
Access-Paradies -Alles rund um die Datenbank Microsoft Access -Code -Programme-Tools -Tipps   Kostenlose Tipps & Tricks, Downloads und Programme   www.kulpa-online.com - Tipps - Tricks - Tutorials - Meinungen - Downloads uvm...   vb@rchiv · Willkommen in der Welt der VB Programmierung   Access-Garhammer - Hier finden Sie jede Menge Beispiel-Datenbanken zu Access und mehr ...   mcseboard.de   Die Top Seite für Excel-VBA-Makros uvm.

Powered by: vBulletin Version 3.6.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Copyright ©2000-2018 MS-Office-Forum. Alle Rechte vorbehalten.
Copyright ©Design: Manuela Kulpa ©Rechte: Günter Kramer
Eine Verwendung der Inhalte in anderen Publikationen, auch auszugsweise,
ist ohne ausdrückliche Zustimmung der Autoren nicht gestattet.