PDA

Vollständige Version anzeigen : Passwort setzen


DanyLux
17.03.2003, 20:18
Hallo

Ich wollt mal wissen wie man es macht um auf eine Seite im Web ein Passwort setzt. zB wenn ich auf eine seite www.xyz.zyx/test/ und wen ich auf diese Verzeichnis zugreife soll ich zuerst ein Passwort gefragt werden :)

Danke fuer euere Hilfe

Manuela Kulpa
18.03.2003, 06:14
Hi Dany,

schau dir doch bitte mal diesen Thread an: http://www.ms-office-forum.net/forum/showthread.php?s=&threadid=88363

slg

DanyLux
18.03.2003, 15:27
Danke

Manuela

DanyLux
18.03.2003, 18:14
Hallo Manuela
ich hab es versucht aber ich krieg immer dies meldung :(


Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, GomesDany@pt.lu and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


--------------------------------------------------------------------------------

Apache/2.0.44 (Win32) Server at idefix Port 80

Kanns du mir weiter helfen

auf diese datei will ich den passwort setzen:
C:\Program Files\Apache Group\Apache2\htdocs\Shool

Manuela Kulpa
18.03.2003, 18:38
Hi Dany,

da stimmt wohl was nicht mit deiner htaccess bzw. htpasswd Datei. Hmmm, so aus dem Bauch kann ich dazu nicht viel sagen, da ich dafür den Aufbau deiner Dateien und deiner Verzeichnisstruktur benötige. Recht hilfreich ist noch folgendes: http://www.trash.net/faq/htaccess.shtml

Vielleicht kommst du damit schon ein Stück weiter.

Gruß

DanyLux
18.03.2003, 19:37
ich versuchs mal mal sehen op es jetzt klappt :)
ich hoffe es

DanyLux
19.03.2003, 16:36
Hallo

Ich hab mal in der error.log des apache nachgeschaut und dort krieg ich diese meldung:

[alert] [client 192.168.16.2] C:/Program Files/Apache Group/Apache2/htdocs/.htaccess: AuthName not allowed here

[alert] [client 192.168.16.2] C:/Program Files/Apache Group/Apache2/htdocs/.htaccess: AuthType not allowed here

und da klappt was nicht was muss ich machen

Manuela Kulpa
19.03.2003, 21:13
Ok, Dany, jetzt erstmal der Reihe nach :angel: ...

... also was steht genau in deiner htaccess und htpasswd Datei? Poste doch mal den Inhalt und nach der Durchsicht, hast du ja nochmals die Möglichkeit die Einträge neu zu definieren, damit nicht jeder im Forum erfährt, welches Passwort bzw. welchen Nutzer du verwendest.

Anschließend ist es wichtig zu erfahren, in welchen Verzeichnissen du die Datei htaccess hinterlegt hast. Die htpasswd Datei dürfte sich eigentlich nur im Root-Verzeichnis befinden.

Wenn du die Sachen gepostet hast, versuche ich es mal bei mir nachzuvollziehen und werde mich dann morgen bei dir noch mal melden.

Gruß

PS: Soll der Schutz nur für lokale Zwecke dienen oder möchtest du diesen später bei deiner Webpräsenz einsetzen? Berücksichtige bitte, wenn du ihn lokal über Apache/Windows realisieren möchtest, dass die Passwörter in der .htpasswd nicht verschlüsselt angegeben werden dürfen. Zudem ist die "AllowOverride" des Apache-Servers in der httpd.conf standardmäßig deaktiviert (Es muss AllowOverride All heißen, dort wo dein persönlicher Root-Pfad des Apache-Servers angegeben ist).

DanyLux
19.03.2003, 22:37
.htAccess

AuthType Basic
AuthName "Protected Area"
AuthUserFile C:/Program Files/Apache Group/Apache2/htdocs/.htpasswd
<limit GET>
require valid-user
</limit>


.htpasswd
Test:$apr1$1C1.....$K7PomaR0ILxoSi4riGZSi1


ich hab die htaccess in ein anderes Verzeichnis gesetzt aber fehlermeldung immer gleich:
Die .htacces steht im Verzeichnis C:\Program Files\Apache Group\Apache2\htdocs\shool und die .htpasswd im C:\Program Files\Apache Group\Apache2\htdocs

Es ist fuer lokale Zwecke aber das geht irgend wie auch nicht und wenn ich AllowOverride All angebe dann bekomme ich den fehler sonst bekomme ich ja gar nichts

Ich Danke dir fuer deine Hilfe!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Manuela Kulpa
20.03.2003, 08:08
So Dany, nun eine kleine Schritt für Schritt Anleitung für dich :angel:

Also, wie gehst du vor:

Schritt 1
Lege ein neues Verzeichnis unterhalb eines existierenden WWW-Verzeichnisses an. Im Beispiel gehe ich davon aus, dass dieses neue Verzeichnis shool/ heißt.

Schritt 2
Besorge Dir das Tool htpasswd für dein Betriebssystem.

Im Folgenden die Kurzhilfe zu htpasswd:
Usage: htpasswd [-cmdps] passwordfile username
htpasswd -b[cmdps] passwordfile username password
-c Create a new file.
-m Force MD5 encryption of the password (default).
-d Force CRYPT encryption of the password.
-p Do not encrypt the password (plaintext).
-s Force SHA encryption of the password.
-b Use the password from the command line rather than prompting for it.
On Windows and TPF systems the '-m' flag is used by default.
On all other systems, the '-p' flag will probably not work.
Schritt 3
Erzeuge ein neues Passwortfile mit dem Tool htpasswd (findest du eigentlich überall im Netz, such einfach mal nach htpasswd.exe).
Dabei wird auch gleich der erste Benutzer angelegt. In diesem Beispiel soll der erste Benutzer test und sein Passwort geheim sein. Also gib folgendes C:\DeinPfadZurDatei\htpasswd.exe -c .htpasswd test im Ausführendialog von Windows ein (Start - Ausführen).

Der Parameter -c ist dabei wichtig – damit legt das Programm eine neue Passwortdatei an. Im Beispiel heißt die Datei .htpasswd – und kann natürlich auch anders heißen. Das Programm fordert dann zweimal (damit man sich nicht vertippt hat) zur Eingabe des Passwortes für den ersten Benutzer auf. Wir geben zweimal geheim [ENTER] ein. Dann ist die neue Passwortdatei unter dem Namen .htpasswd angelegt und enthält in etwa folgende Zeile:test:$apr1$s23.....$jx08hs9fElkAYPek6uU750.
Das Passwort ist hier nicht lesbar, denn es ist durch den MD5-Algorithmus (eine mathematische Falltür: man kommt nur in einer Richtung durch!) verschlüsselt.

Schritt 4
Nun kann man optional noch weitere Benutzer in die Passwortdatei aufnehmen. Zum Beispiel den Benutzer gast mit dem Passwort auchgeheim. Achtung: Jetzt lässt man den Parameter -c weg, denn man möchte an eine vorhandene Passwortdatei neue Einträge anfügen. Beispielaufruf: htpasswd test.pwd gast

Schritt 5
Diese Passwortdatei speichert man nun in einem beliebigen Verzeichnis – unter Windows z.B. hierhin: C:\apache\htdocs\.htpasswd (achte hierbei bitte auf die korrekte Pfadangabe zu deinem Ordner).

Schritt 6
Nun legt man unterhalb des DOCUMENTROOT des WWW-Servers, direkt in dem zu schützenden Verzeichnis aus Schritt 1 - z.B. shool/ mit einem Texteditor eine Datei .htaccess an (der Punkt am Anfang ist wichtig!). In diese Datei schreibt man in etwa Folgendes hinein (Alle Zeilen natürlich ohne die führenden Leerzeichen!):

AuthUserFile "C:/apache/htdocs/.htpasswd"
AuthGroupFile /dev/null
AuthName ByPassword
AuthType Basic
<Limit GET>
require user test
</Limit>
Dabei muss natürlich in der Zeile AuthUserFile der absolute Pfad zur in Schritt 5 erzeugten Passwortdatei stehen! Dabei unter Windows alle Backslashes (\) durch normale Slashes (/) ersetzen. Und wenn im Pfadnamen ein Leerzeichen steht, dann den gesamten Pfad in Anführungszeichen packen! Auf dein Beispiel bezogen. so:
AuthUserFile "C:/Program Files/Apache Group/Apache2/htdocs/.htpasswd". Innerhalb des <Limit GET> Blocks stehen alle User, auf die ein GET beschränkt ist.

Schritt 7
Achtung: Wenn Du beim Apache WWW Server in der Konfigurationsdatei (ältere Apache: access.conf, neuere Apache httpd.conf) stehen hast: AllowOverride None, dann kann bei darunter liegenden Verzeichnissen das <Limit GET> aus .htaccess nicht ausgeführt werden. Schlimmer noch: bei None schaut Apache nicht mal nach, ob es eine .htaccess Datei in den Unterverzeichnissen gibt. Also in der Configdatei evtl. noch AllowOverride All einstellen. (Neustart von Apache nicht vergessen, wenn die Konfiguration geändert wurde!). So könnte das dann ausschauen:

#
# This controls which options the .htaccess files in directories can
# override. Can also be "All", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"
#
AllowOverride All
Schritt 8
Fertig :happy:! Nun sollte man den Zugriff per WWW auf dieses Verzeichnis testen. Der WWW-Browser sollte nun bei Zugriff auf das shool/ Verzeichnis (und alle URL-Adressen die hierarchisch darunter liegen) eine Dialogbox öffnen, die zur Eingabe von Benutzername und Passwort auffordern. Achte hierbei auf Groß- und Kleinschreibung!
Viel Spaß beim Ausprobieren :sun:

DanyLux
20.03.2003, 17:03
Hallo Manuela

Endlich es hat geklappt :))

Hab nur noch ein kleines Problem dass ich aber leider nicht verstehe. Ich hab in den Verzeichnis Shool ein neues Verzeichnis gesetzt und wenn ich beim Verzeichnis shool das passwort angebe dan komm ich in das verzeichnis und auch in das neue Verzeichnis was normal ist, fuer mich:)

Aber setzt ich jetzt die .htaccess in den phpMyAdmin dann bekomm ich wenn ich in das verzeichnis gehe dreimal den passwort feld und wenn ich irgend etwas mache oder aendere in diesem Verezcinhis ist dass normal

DanyLux
20.03.2003, 17:18
Ich hab das problem geshen es war dass ich mit dem name des computer propierte anstaat localhost oder 127.0.0.1 :)))
Danke aber